Annonce

  •  » Styles
  •  » Imoppsible de se connecter avec EDGE

#1 2020-05-06 19:51:19

Klavin
Membre
2020-05-06
17

Imoppsible de se connecter avec EDGE

Bonjour/Bonsoir,

J'ai crée très récemment ma galerie chez free. Elle fonctionne bien avec le thème modus. J'ai voulu essayer le thème  Bootstrap Darkroom  mais j'ai un problème de fonctionnement avec EDGE.
La galerie fonctionne bien avec Firefox, je peux me connecter en tant qu'administrateur et utiliser correctement le menu principal (album , découvrir, contacter etc...).

Par contre, si je veux consulter la galerie avec EDGE (navigateur Microsoft) , le menu principal ne fonctionne pas (à part le menu contacter) et il est impossible de se connecter comme invité ou administrateur.

Comment faire pour utiliser ce thème avec EDGE (20 % du marché des navigateur).

Version de Piwigo: 2.10.1
Version de PHP:
Version de MySQL:
URL Piwigo: http://klavind.free.fr/photo

Hors ligne

#2 2020-05-07 10:00:45

Klavin
Membre
2020-05-06
17

Re: Imoppsible de se connecter avec EDGE

En complément, je rajoute le point suivant :

sous EDGE, je peux me connecter si je vais directement à la page administrateur à l'adresse

monsite/admin.php.

j'ai bien l'impression que les liens du menu principal sont mal lus sous EDGE, contrairement aux autres navigateurs.


j'ai  en plus l'erreur suivante en activant le plugin advanced menu manager :

Warning: Undefined script gpc.categorySelector is required by someone in /var/www/sda/7/7/klavind/photo/include/template.class.php on line 1755



Une idée pour corriger ça?

Merci

Hors ligne

#3 2020-05-07 12:40:02

Katryne
Membre
Provence
2016-12-03
587

Re: Imoppsible de se connecter avec EDGE

Hello, pas seulement avec Edge : j'ai essayé avec 9 navigateurs.
Déjà, Contact ne marche nulle part, ça mouline et on est toujours sur la page d'accueil.
Pour Firefox, Brave, Palemoon, Vivaldi, Opéra : les menus se déroulent correctement
Pour Edge, SeaMonkey et OperaNeon, rien ne marche.
Et Internet Explorer, c'est le ponpon : il n'affiche même pas tous les liens de menu et bien sûr, les 2 qu'il affiche ne se déroulent pas.


https://photos.revestou.fr/  (Test même config: http://photos.katrynou.fr/)
Piwigo 2.10.2 -  Système d'exploitation: Linux - Hébergeur 1&1-Ionos
PHP: 7.3.15 - MySQL: 5.7.28-log
Bibliothèque graphique: External ImageMagick 6.8.9-9

Hors ligne

#4 2020-05-07 14:15:07

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
15290

Re: Imoppsible de se connecter avec EDGE

Bonjour

@Klavin tu as modifié les fichiers spécifique pour free ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2020-06-09 16:04:26

Klavin
Membre
2020-05-06
17

Re: Imoppsible de se connecter avec EDGE

Je n'ai jamais modifié le thème, par contre, j'ai modifié un fichier Piwigo pour que ça fonctionne chez Free. : change line 48 of file include/smarty/libs/plugins/shared.mb_str_replace.php by following line
      $parts = preg_split('~preg_quote($search)~', $subject);

J'avais essayé de charger le thème Bootstrap darkroom depuis la galerie hébergée chez Free et j'avais un message d'erreur ( téléchargement impossible). Alors j'ai téléchargé  le thème Bootstrap darkroom depuis le site Git Hub et je l'ai installé par via FTP.

Il a fonctionné avec Firefox mais pas avec Edge. Ca s'est arrangé tout seul quand Microsoft a fait évoluer Edge ( passage sur la version basée Chrome).  Ensuite, à cause du confinement, le serveur Free n'était plus administré (erreur 500) et plus rien ne marchait.

Pour avancer pendant le confinement et la panne Free , j'ai re-installé la galerie sur un serveur local (Wamp). J'ai supprimé complètement  le thème Bootstrap darkroom que j'avais installé depuis Git Hub et je l'ai re-installé depuis la galerie Piwigo  sur mon serveur local(sans passer par Git Hub et FTP). Puis j'ai récupéré ces fichiers pour les installer via FTP sur le serveur Free de ma galerie quand le serveur Free est sortie du confinement.

Depuis ça marche bien, sur la galerie locale et la galerie hébergée par Free avec Edge ancienne et nouvelle version. Je n'ai pas testé avec Internet explorer.

J'ai donc eu trois problèmes : l’impossibilité d'installer depuis la galerie hébergée par Free (toujours d'actualité),  ensuite je pense que la version Git Hub n'est pas aussi complète celle que l'on récupère via la galerie Piwigo ( problème contourné en installant une galerie locale pour récupérer le thème), et  enfin les serveurs Free n'ont pas été administrés pendant le confinement (problème résolu depuis quelques jours)

Hors ligne

#6 2020-06-09 18:58:24

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
15290

Re: Imoppsible de se connecter avec EDGE

Bonjour
déjà super si cela fonctionne :-)

Klavin a écrit:

J'ai donc eu trois problèmes : l’impossibilité d'installer depuis la galerie hébergée par Free (toujours d'actualité)

Malheureusement cela fait plusieurs année que free ne veux pas ajouter le serveur de piwigo dans sa liste des serveurs autorisé ... nous ne pouvons rien faire


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

  •  » Styles
  •  » Imoppsible de se connecter avec EDGE

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2020 · Contact