Annonce

  •  » Plugins
  •  » Insensible à la casse...

#466 2011-04-27 19:25:17

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Insensible à la casse...

Le [Bugtracker] ticket 2285 est corrigé dans [Subversion] r10643.

LCAS devient compatible Piwigo 2.1 aussi bien que 2.2. J'ai aussi remis le "codage en dur" de la version du plugin (2.2.2) au lieu de la fonction "auto" de PEM.

Hors ligne

#467 2011-04-28 09:40:42

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: Insensible à la casse...

cljosse a écrit:

C'est loin ou vous allez?

:-D

Whiler je ne sais pas (encore faudrait-il que nous nagions dans la même direction :-) !), personnellement je n'ai pas l'intention d'aller trop loin : c'est crevant de cette façon-là ! (Je vais pas me mettre à faire du sport, non plus ?!)

Eric a écrit:

Qu'avez-vous besoin ? Des explications sur la publication dans PEM ?

Non mais en fait ça va ; c'est plutôt
http://smileys.urpix.fr/smileys/Vacances/7_3_101v.gif
... juste l'impression de pas avoir assez de temps, et que ce n'est pas mon métier de base :-/ ... (D'ailleurs, ce sont pas que des impressions...!)

;-)

Eric a écrit:

LCAS devient compatible Piwigo 2.1 aussi bien que 2.2. J'ai aussi remis le "codage en dur" de la version du plugin (2.2.2) au lieu de la fonction "auto" de PEM.

Super.

Je regarde maintenant [Bugtracker] ticket 2100.

Par MP, Eric a écrit:

Après, il reste la partie "publication". Là, il y a PEM qui vous est accessible à tous deux comme à moi. Je regrette seulement qu'on ne puisse afficher tous les auteurs du plugin. Pour l'instant, c'est "LCAS by Eric" qui est affiché et cela me gène vis à vis de vous. Je vais vois avec Damien (ddtddt) ou Pierrick (plg) si on peut faire quelque chose de ce côté.

Franchement je ne pense pas que ce soit indispensable. Le titre est effectivement "by Eric", mais ailleurs il est noté tous les auteurs ; vraiment à mon avis ça va bien, pas de besoin impératif de changer PEM pour ça.

Hors ligne

#468 2011-04-28 09:44:32

Whiler
Membre
Clichy
2004-12-24
189

Re: Insensible à la casse...

LucMorizur a écrit:

Franchement je ne pense pas que ce soit indispensable. Le titre est effectivement "by Eric", mais ailleurs il est noté tous les auteurs ; vraiment à mon avis ça va bien, pas de besoin impératif de changer PEM pour ça.

+1

Hors ligne

#469 2011-04-28 22:33:44

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Insensible à la casse...

LucMorizur a écrit:

Eric a écrit:

LCAS devient compatible Piwigo 2.1 aussi bien que 2.2. J'ai aussi remis le "codage en dur" de la version du plugin (2.2.2) au lieu de la fonction "auto" de PEM.

Super.

Je regarde maintenant [Bugtracker] ticket 2100.

Veux-tu qu'on attende avant de publier la prochaine version ? Les dernières corrections permettent déjà d'étendre la porté du plugin à la branche 2.1 de Piwigo. Je serai personnellement partant pour une publication de la version 2.2.2 de LCAS.

Hors ligne

#470 2011-04-29 08:54:33

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: Insensible à la casse...

Eric a écrit:

Veux-tu qu'on attende avant de publier la prochaine version ?

Holà non il vaudrait mieux pas ;-) ... Non, publions 2.2.2.

Hors ligne

#471 2011-04-29 09:35:47

Whiler
Membre
Clichy
2004-12-24
189

Re: Insensible à la casse...

2.2.2.... j'comprends pas... c'est pour que le plugin soit dispo pour la prochaine version de piwigo ?

Hors ligne

#472 2011-04-29 09:43:43

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: Insensible à la casse...

Whiler a écrit:

2.2.2.... j'comprends pas... c'est pour que le plugin soit dispo pour la prochaine version de piwigo ?

Ben, disons qu'il n'est pas vraiment possible de suivre à la lettre la règle qui voudrait qu'une version de plugin suive la version de Piwigo. Là, on a publié une version 2.2.1 de LCAS, pour suivre la version actuelle de Piwigo (2.2.1 à l'heure où j'écris). Étant donné qu'on doit faire évoluer LCAS, on est bien obligé de faire évoluer son numéro de version, qui va donc devenir 2.2.2, même si Piwigo est en retard ;-) et reste pour le moment à 2.2.1 -- ce qui ne va pas durer longtemps.

De même, on ne modifiera pas le numéro de version de LCAS à chaque évolution de Piwigo, s'il n'y a aucune modification du code de LCAS.

Dernière modification par LucMorizur (2011-04-29 09:44:45)

Hors ligne

#473 2011-04-29 09:45:21

Whiler
Membre
Clichy
2004-12-24
189

Re: Insensible à la casse...

Pourquoi on ne fait pas des 2.2.1.a, 2.2.1.b, 2.2.1.c, ou des 2.2.1.1, 2.2.1.2, 2.2.1.3, ... ?

Hors ligne

#474 2011-04-29 09:49:50

LucMorizur
Membre
Vienne (Isère, 38)
2009-03-01
1969

Re: Insensible à la casse...

Whiler a écrit:

Pourquoi on ne fait pas des 2.2.1.a, 2.2.1.b, 2.2.1.c, ou des 2.2.1.1, 2.2.1.2, 2.2.1.3, ... ?

Ben, parce qu'on n'y avait pas pensé :-/ ...

Personnellement, m'oui pourquoi pas... Éric ?

Hors ligne

#475 2011-04-29 09:53:38

Whiler
Membre
Clichy
2004-12-24
189

Re: Insensible à la casse...

Personnellement, les 3 premiers, je les laisserais conforme au build piwigo, et le 4è correspondrait à notre build...
Pour une nouvelle version de piwigo, on incrémente tout.. quand c'est juste pour nous, on incrémente que le 4è...

Hors ligne

#476 2011-04-29 10:37:47

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16233

Re: Insensible à la casse...

[hs]
les plugins en général son compatible sur une branche.
beaucoup son simplement numéroté
2.2.a
2.2.b
.....
[/hs]


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#477 2011-04-29 10:40:07

Whiler
Membre
Clichy
2004-12-24
189

Re: Insensible à la casse...

2.2.b me plairait plus que 2.2.2 qui, je trouve, porte plus à confusion...

Hors ligne

#478 2011-04-29 12:43:52

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: Insensible à la casse...

ddtddt a écrit:

[hs]
les plugins en général son compatible sur une branche.
beaucoup son simplement numéroté
2.2.a
2.2.b
.....
[/hs]

Oui mais justement, quid des plugin v2.1.xyz qui sont compatibles en l'état avec Piwigo v2.2.x ???
C'est pourquoi je n'aime pas trop cette numérotation...


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#479 2011-04-29 13:21:34

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Insensible à la casse...

LucMorizur a écrit:

Whiler a écrit:

Pourquoi on ne fait pas des 2.2.1.a, 2.2.1.b, 2.2.1.c, ou des 2.2.1.1, 2.2.1.2, 2.2.1.3, ... ?

Ben, parce qu'on n'y avait pas pensé :-/ ...

Personnellement, m'oui pourquoi pas... Éric ?

On a déjà tenté une approche sur ce sujet : http://fr.piwigo.org/forum/viewtopic.ph … 6#p163686.

J'aurai le même réponse que ddtddt : Un plugin est compatible avec une branche de Piwigo. Ici, on s'appuie sur la branche 2.2 en considérant (un peu à l'arrache, il est vrai) "qui peut le plus, peut le moins". On suppose donc une rétrocompatibilité sur la branche inférieure 2.1 de Piwigo.

D'où une numérotation des versions de LCAS en [Branche haute de Piwigo compatible].[N° de build de LCAS dans cette branche de compatibilité].

Après, on peut remplacer le N° de build par une lettre. Cela n'a aucune importance.

On peut aussi se poser la question : Pourquoi prendre en compte la branche de Piwigo active ? On aurait très bien pu numéroter la première version de LCAS en 1.0. Mais si un jour des modifications sont nécessaires uniquement pour la branche 2.1 de Piwigo (peu probable mais supposons), on pourra toujours la noter 2.1.x.


Ceci dit, on a commencé la numérotation à 2.2.0. On est un peu coincé maintenant pour changer, non ?

Hors ligne

#480 2011-04-29 13:27:29

Whiler
Membre
Clichy
2004-12-24
189

Re: Insensible à la casse...

Eric a écrit:

Ceci dit, on a commencé la numérotation à 2.2.0. On est un peu coincé maintenant pour changer, non ?

[troll]ah.. ben la suivante, c'est 2.2.P...

Avec LCAS, on peut s'authentifier avec Oscar ou 0scar ?[/troll]

Hors ligne

  •  » Plugins
  •  » Insensible à la casse...

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact