Annonce

#1 2024-07-09 07:58:59

AnthonyS
Membre
2020-06-05
23

[Résolu] Tags absents

Bonjour,

J'ai il y a quelques mois complètement réinstallé piwigo suite à un souci de téléchargement d'images.
J'ai tout réinstallé et tout semblait rouler.
Mais j'ai fini par remarquer que les tags n'avaient jamais été recréés (contrairement à l'ancienne base que j'ai conservé, les tables piwigo_tags et piwigo_image_tag sont vides)

J'ai pourtant bien un message lors de la simulation qui indique le nombre de photos synchronisées avec métadonnées.
J'ai aussi un message d'erreur pour chaque photo synchronisée :
object, null given in /volume2/web/piwigo/plugins/exiftool_gps/main.inc.php on line 23 Warning: foreach() argument must be of type array
J'imagine que ça doit être une conséquence de l'absence des tags ou de certaines métadonnées sur un plugin.

Merci d'avance pour vos retours.

Version de Piwigo: 14.4.0
Version de PHP: 8.0
Version de MySQL: 10.3.32 MariaDB

Dernière modification par AnthonyS (2024-07-09 07:59:54)

Hors ligne

#2 2024-07-09 12:59:25

k5
Équipe Piwigo
La reppe
2014-01-26
1350

Re: [Résolu] Tags absents

Bonjour
Dans l'ancien piwigo est ce qu'il y a une sauvegarde de base de données (particulièrement images_tags et tags ) ?

...)

Possible que exiftool gps fasse défaut. Je regarderai.
Essayer d'augmenter la version PHp peut être que ???

A très vite


Piwigo 14.4 VM alpneLinux php 8.4
Piwigo 14.4 php 8.4 -- 8.4 mysql -- ImageMagick 7.1.1.34

Hors ligne

#3 2024-07-09 13:40:09

AnthonyS
Membre
2020-06-05
23

Re: [Résolu] Tags absents

Bonjour k5,
Meci pour la réponse.
Pour PHP je ne peux pas.
Je suis sur un Synology et pour le moment il n'y a pas d'autre version de PHP installable sur ce NAS.

Concernant l'ancienne base oui j'ai une sauvegarde.
Mais j'ai comparé certaines images et je n'ai pas forcément les mêmes id, car lorsque j'ai réinstallé, j'avais de nouvelles images, albums à rajouter...

Hors ligne

#4 2024-07-10 08:08:09

AnthonyS
Membre
2020-06-05
23

Re: [Résolu] Tags absents

Bonjour,
J'ai réussi à mettre à jour le NAS et à installer PHP 8.2
Le problème est toujours là.
Seul le message d'erreur du plugin exif gps a changé :

object, null given in /volume2/web/piwigo/plugins/exiftool_gps/main.inc.php on line 23 Deprecated: json_decode(): Passing null to parameter #1 ($json) of type string is deprecated in /volume2/web/piwigo/plugins/exiftool_keywords/main.inc.php on line 23

Hors ligne

#5 2024-07-10 08:28:01

AnthonyS
Membre
2020-06-05
23

Re: [Résolu] Tags absents

En creusant un peu la doc j'ai trouvé çà :

Attention ! Piwigo ne prend pas en charge l’import des tags que vous pouvez associer à une photo depuis le Finder de Mac OS

Ma collègue journaliste qui s'occupe d'importer les photos travaille... sous mac OS...

C'est bien la source du problème ?

Ce qui est bizarre, c'est que je n'avais pas ce soucis avant de réinstaller piwigo !

Hors ligne

#6 2024-07-10 11:04:56

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16847

Re: [Résolu] Tags absents

Bonjour

@AnthonyS

A tu regarder avec [extension by ddtddt] Read Metadata si tu voyais les mots clés ?

As tu réglé ta config local ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#7 2024-07-10 11:59:50

AnthonyS
Membre
2020-06-05
23

Re: [Résolu] Tags absents

Bonjour @ddtddt

Voici ce que j'ai avec ReadMetadata :

IPTC Fields in 2022-07-13_Basket3x300001.jpg
1#090 = %G
2#025 = inauguration,sport,park nevez,2022,basket

EXIF Fields in 2022-07-13_Basket3x300001.jpg
FileName = 2022-07-13_Basket3x300001.jpg
FileDateTime = 1657713596
FileSize = 2828905
FileType = 2
MimeType = image/jpeg
SectionsFound = ANY_TAG, IFD0, THUMBNAIL, EXIF, INTEROP
COMPUTED
      html = width="3000" height="4000"
      Height = 4000
      Width = 3000
      IsColor = 1
      ByteOrderMotorola = 1
      ApertureFNumber = f/1.8
      Thumbnail.FileType = 2
      Thumbnail.MimeType = image/jpeg
      Thumbnail.Height = 512
      Thumbnail.Width = 384
ImageWidth = 3000
ImageLength = 4000
BitsPerSample
      0 = 8
      1 = 8
      2 = 8
Make = HUAWEI
Model = JSN-L21
Orientation = 0
XResolution = 72/1
YResolution = 72/1
ResolutionUnit = 2
Software = JSN-L21 9.1.0.431(C431E3R1P1)
DateTime = 2022:07:13 10:23:37
YCbCrPositioning = 1
Exif_IFD_Pointer = 270
DeviceSettingDescription = ipp
THUMBNAIL
      ImageWidth = 384
      ImageLength = 512
      Compression = 6
      Orientation = 0
      XResolution = 72/1
      YResolution = 72/1
      ResolutionUnit = 2
      JPEGInterchangeFormat = 9076
      JPEGInterchangeFormatLength = 23654
DocumentName =
ExposureTime = 559000/1000000000
FNumber = 180/100
ExposureProgram = 2
ISOSpeedRatings = 50
ExifVersion = 0210
DateTimeOriginal = 2022:07:13 10:23:37
DateTimeDigitized = 2022:07:13 10:23:37
ComponentsConfiguration = 
CompressedBitsPerPixel = 95/100
ShutterSpeedValue = 298973/10000
ApertureValue = 169/100
BrightnessValue = 0/1
ExposureBiasValue = 0/10
MaxApertureValue = 169/100
MeteringMode = 5
LightSource = 1
Flash = 0
FocalLength = 5400/1000
MakerNote = ##**dav
SubSecTime = 086297
SubSecTimeOriginal = 086297
SubSecTimeDigitized = 086297
FlashPixVersion = 0100
ColorSpace = 1
ExifImageWidth = 3000
ExifImageLength = 4000
InteroperabilityOffset = 8916
SensingMethod = 2
FileSource = 
SceneType = 
CustomRendered = 1
ExposureMode = 0
WhiteBalance = 0
DigitalZoomRatio = 100/100
FocalLengthIn35mmFilm = 27
SceneCaptureType = 0
GainControl = 0
Contrast = 0
Saturation = 0
Sharpness = 0
SubjectDistanceRange = 0
InterOperabilityIndex = R98
InterOperabilityVersion = 0100
XMP Properties:

Pour la config locale je pense que oui. Mais à quoi pensez-vous pour être plus précis ?

Hors ligne

#8 2024-07-10 13:41:47

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16847

Re: [Résolu] Tags absents

Bonjour

est ce que les tags sont "inauguration,sport,park nevez,2022,basket" ?

dans le config local un truc du genre

$conf['use_iptc'] = true;

$conf['use_iptc_mapping'] = array(
'keywords'        => '2#025',
);


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#9 2024-07-10 16:43:19

AnthonyS
Membre
2020-06-05
23

Re: [Résolu] Tags absents

Oui, ce sont bien les tags que vous citez

En tout cas merci, c'est passé !

Dernière modification par AnthonyS (2024-07-10 16:45:26)

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2024 · Contact