Annonce

  •  » Utilisation
  •  » Incompatibilité avec PHP 8.2 ???

#1 2023-08-17 17:56:10

Nounours18200
Membre
2004-04-24
60

Incompatibilité avec PHP 8.2 ???

Bonjour/Bonsoir,

Bonjour,

Ayant eu des problèmes de sécurité, j'ai passé mon hébergement (multi-domaines) en PHP 8.2

Mes autres sites (de ce même hébergement) fonctionnent avec PHP 8.2, mais pas mon Piwigo qui m'indique des fonctions "deprecated" (ce qui m'empêche de passer globalement l'hébergement en 8.2).

La copie écran du message d'erreur se trouve ici:

https://mega.nz/file/824iWbYB#sTXEiJbQj … nmF5yE-ifM

Est-ce que la version 14.x Beta est compatible avec PHP 8.2 ?

Merci

Version de Piwigo: 13.6
Version de PHP: 8.2
Version de MySQL: 5.6 (je crois)
URL Piwigo: http://elodie-photo.fr

Dernière modification par Nounours18200 (2023-08-17 18:21:34)

Hors ligne

#2 2023-08-18 03:07:12

k5
Équipe Piwigo
La reppe
2014-01-26
1331

Re: Incompatibilité avec PHP 8.2 ???

Bonjour

je dirais de passer piwigo 13.8 puis de cacher les erreurs.
à savoir, rajouter la ligne suivante dans LocalFiles Editor permet d'ignorer le message d'erreur (je sais, ce n'est pas terrible) :

$conf['show_php_errors'] = E_ALL & ~E_DEPRECATED;

A très vite


Piwigo 14.4 VM alpneLinux php 8.4
Piwigo 14.4 php 8.4 -- 8.4 mysql -- ImageMagick 7.1.1.33

Hors ligne

#3 2023-08-18 11:56:55

Nounours18200
Membre
2004-04-24
60

Re: Incompatibilité avec PHP 8.2 ???

OK je vais déjà passer en 13.8 et faire ce que tu dis sur le fichier de conf.

Mais sais-tu si la 14.x Beta est compatible avec la 8.2 ??

parce que vu que mon site est un "petit site", je prendrais probablement pas beaucoup de risque à passer sur la 14.x Beta si elle est compatible avec PHP 8.2....

Hors ligne

#4 2023-08-18 14:28:07

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16834

Re: Incompatibilité avec PHP 8.2 ???

@Nounours18200

piwigo 14beta est normalement compatible les extensions et thèmes sans doute pas ...


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

En ligne

#5 2023-08-18 17:06:44

Nounours18200
Membre
2004-04-24
60

Re: Incompatibilité avec PHP 8.2 ???

La 13.8 a été installée avec succès, mais impossible de rajouter la ligne que vous indiquez en utilisant LocalFiles Editor, voici le message d'erreur lorsqu'on essaie:

Parse error: syntax error, unexpected variable "$conf" in /home/elodiephyk/www/piwigo/piwigo/plugins/LocalFilesEditor/include/functions.inc.php(45) : eval()'d code on line 5

Une solution ?

Merci

Hors ligne

#6 2023-08-19 10:25:09

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16834

Re: Incompatibilité avec PHP 8.2 ???

Bonjour,

le ; à la fin de la ligne ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

En ligne

  •  » Utilisation
  •  » Incompatibilité avec PHP 8.2 ???

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2024 · Contact