Annonce

#1 2022-01-02 11:14:27

gerardbonnier
Membre
2014-04-09
19

mise à jour et version de PHP

Bonjour/Bonsoir,
je suis hébergé par OVH. avec PHP 7.3. Très curieusement Piwigo affiche que j'utilise PHP 5.4.45 et refuse d'installer la nouvelle version car je n'ai pas PHP 7

Je ne comprends pas la situation ni comment faire en sorte que Piwigo et OVH soient cohérents sur la version de php

cordialement
Gérard


Version de Piwigo: 12.0.0
Version de PHP: 7.3 (mais piwigo voit une version 5 !)
Version de MySQL:
URL Piwigo: http://

Hors ligne

#2 2022-01-03 06:05:33

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: mise à jour et version de PHP

Bonjour,

Vérifie par FTP que tu n'a pas un fichier qui impose php 5.4.45


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2022-01-03 10:24:31

gerardbonnier
Membre
2014-04-09
19

Re: mise à jour et version de PHP

Merci effectivement je trouve dans les fichiers Piwigo une référence à la version PHP 5 malgré le fait que j'utilise une version 12.0.0 de piwigo en particulier dans le dossier install le fichier hosting.php mais dans ce même dossier je trouve un fichier php5_apache_configuration.php !!

Hors ligne

#4 2022-01-03 20:26:05

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: mise à jour et version de PHP

Bonjour,

gerardbonnier a écrit:

Merci effectivement je trouve dans les fichiers Piwigo une référence à la version PHP 5 malgré le fait que j'utilise une version 12.0.0 de piwigo en particulier dans le dossier install le fichier hosting.php mais dans ce même dossier je trouve un fichier php5_apache_configuration.php !!

non pas dans piwigo mais dans un fichier .htaccess ou comme tu est chez ovh dans un fichier .ovhconfig


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2022-01-04 16:10:00

gerardbonnier
Membre
2014-04-09
19

Re: mise à jour et version de PHP

j'ai tenté de modifier .ovhconfig et .htaccess mais chaque fois j'ai mise en panne le service"
piwigo m'affiche :
la version de php 5.4.45 erst incompatoble avec la version requise 7.0.0

coté OVH je suis en php 7.3

contenu de .htaccess dans le dossier www
SetEnv PHP_VER 7.3

contenu de .ovhconfig à la racine de l'hebergement
app.engine=php
app.engine.version=7.3
http.firewall=none
environment=production
container.image=stable

Contenu de .ovhconfig dans le dossier www
; ovhconfig
;
; this file must be placed in $HOME/.ovhconfig or in $DOCUMENT_ROOT/.ovhconfig

; __app.engine__
;
; values: php (php engine + opcache accelerator)
; notice: if php, a phpcgi engine will be activated as fallback (if previous engine crash)
;
;   php:
;       IMPORTANT: register_globals and magic_quotes_gpc are off for security
;       php options .htaccess (like php version) are ignored
;   phpcgi:
;       IMPORTANT this is a fallback or previous system
;       in this case __app.engine.version__ will be considerated as AUTO and php version will be old system
;       (meaning depending .htaccess or .phpX extension)
;
app.engine=php

; __app.engine.version__ specify version of your engine
;
; for php:
;    default: 7.3
; for phpcgi:
;   this options is ignored (= fallback in AUTO)
;
app.engine.version=7.3

; __http.firewall__ used to add application firewall  (filter http requests)
;
; values: none | security
; default: none
;
http.firewall=none

; __environment__
;
; values: production | development
;
;   production:
;       apache will maximise local cache
;       mod_expires will grow up TTL of js, css, pdf, images, video, audio
;       you can override it changing expiration explicitly or in your .htaccess
;       feel free to look on our guide.
;   development:
;       no expiration is added, files are not locally in cache,
;       will speed up tests but decrease performances
;
; choosen environment will also be available in your variable ENVIRONMENT unix env
;
; default: production
;
environment=development

Hors ligne

#6 2022-01-04 16:11:41

gerardbonnier
Membre
2014-04-09
19

Re: mise à jour et version de PHP

je n'arrive pas à trouver quel fichier je dois modifier pour que piwigo ne trouve plus une version 5.4.45 de php

Hors ligne

#7 2022-01-04 18:45:24

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: mise à jour et version de PHP

Bonjour,

Avez vous essayer de faire un petit fichier phpinfo() ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#8 2022-01-05 08:53:14

gerardbonnier
Membre
2014-04-09
19

Re: mise à jour et version de PHP

Non mais je peux le faire
que faut-il que je mette dans un tel fichier (version de PHP ?)
et dans quel dossier dois-je le mettre ?

cordialement Gérard BONNIER

Hors ligne

#9 2022-01-05 09:30:50

gerardbonnier
Membre
2014-04-09
19

Re: mise à jour et version de PHP

finalement j'ai su faire un fichier phpinfo et l'executer !

j'ai comme résultat : PHP Version 5.4.45
et les infos suivantes
Configuration File (php.ini) Path     /usr/local/php5.4/etc
Loaded Configuration File     /images/stable/usr/local/php-config/5.4/php-fpm.ini

Hors ligne

#10 2022-01-05 09:32:20

gerardbonnier
Membre
2014-04-09
19

Re: mise à jour et version de PHP

Voici le détail de la réponse à phpinfo

System     Linux webm141.cluster014.gra.hosting.ovh.net 4.14.253-ovh-vps-grsec-zfs-classid #1 SMP Thu Oct 28 11:15:35 CEST 2021 x86_64
Build Date     Jul 28 2021 10:57:36
Configure Command     './configure' '--with-openssl' '--enable-memcached' '--prefix=/usr/local/php5.4' '--enable-fpm' '--enable-opcache' '--enable-memcache' '--enable-redis' '--with-gd' '--enable-intl' '--enable-gd-native-ttf=/usr' '--with-png-dir=/usr' '--enable-wddx' '--with-config-file-path=/usr/local/php5.4/etc' '--enable-sigchild' '--enable-short-tags' '--disable-rpath' '--enable-libgcc' '--with-zlib=/usr' '--enable-bcmath' '--enable-calendar' '--with-curl=/usr' '--with-gdbm=/usr' '--enable-ftp' '--with-gettext=/usr' '--with-imap=/usr' '--with-kerberos' '--with-imap-ssl=/usr' '--with-mcrypt=/usr' '--with-mhash=/usr' '--with-jpeg-dir=/usr' '--enable-exif' '--with-regex=system' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-zip' '--enable-inline-optimization' '--enable-soap' '--enable-mbstring' '--enable-mbregex' '--with-gnu-ld' '--with-libxml-dir' '--enable-shared=yes' '--enable-static=yes' '--with-xsl=/usr' '--enable-sockets' '--with-xmlrpc' '--with-iconv' '--with-imagick' '--enable-pdo' '--with-pdo-pgsql=external/libpq/usr' '--enable-mongo' '--with-xpm-dir=/usr' '--with-pcre-regex' '--with-freetype-dir=/usr' '--with-pspell' '--with-pgsql=external/libpq/usr' '--with-bz2' '--with-gmp' '--enable-igbinary' '--enable-memcached-igbinary' '--enable-memcached-json'
Server API     FPM/FastCGI
Virtual Directory Support     disabled
Configuration File (php.ini) Path     /usr/local/php5.4/etc
Loaded Configuration File     /images/stable/usr/local/php-config/5.4/php-fpm.ini
Scan this dir for additional .ini files     (none)
Additional .ini files parsed     (none)
PHP API     20100412
PHP Extension     20100525
Zend Extension     220100525
Zend Extension Build     API220100525,NTS
PHP Extension Build     API20100525,NTS
Debug Build     no
Thread Safety     disabled
Zend Signal Handling     disabled
Zend Memory Manager     enabled
Zend Multibyte Support     provided by mbstring
IPv6 Support     enabled
DTrace Support     disabled
Registered PHP Streams    https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, phar, zip
Registered Stream Socket Transports    tcp, udp, unix, udg, ssl, sslv3, tls
Registered Stream Filters    zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, mcrypt.*, mdecrypt.*

Hors ligne

#11 2022-01-05 10:55:49

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: mise à jour et version de PHP

Bonjour

gerardbonnier a écrit:

finalement j'ai su faire un fichier phpinfo et l'executer !

j'ai comme résultat : PHP Version 5.4.45

donc cela ne viens pas de piwigo mais de l'hébergement ovh !
as tu un php.ini sur le FTP ? ou dans le manager ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#12 2022-01-05 14:31:44

gerardbonnier
Membre
2014-04-09
19

Re: mise à jour et version de PHP

Ou dois-je trouver le fichier php.ini ? (piwigo, wwws ?)

Hors ligne

#13 2022-01-05 18:24:33

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: mise à jour et version de PHP

bonjour,

gerardbonnier a écrit:

Ou dois-je trouver le fichier php.ini ? (piwigo, wwws ?)

votre hébergement ovh est en php 5.4.45 ce n'est pas lié à piwigo

a travers le temps ovh a utilisé plusieurs façon pour forcer la valeur de php
un moment il autorisait un fichier php.ini dans un répertoire ou a la racine

dsl mais je ne peux pas savoir comment vous avez imposé le php 5.4.45 sur votre hébergement
j'essaie de vous dépaner en vous donnant des piste mais ovh qui a accès à vos espaces, qui connait votre offre ... pourrait sans doute mieux vous guider


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#14 2022-01-05 23:56:51

gerardbonnier
Membre
2014-04-09
19

Re: mise à jour et version de PHP

Merci je vais voir du coté d'OVH

Hors ligne

#15 2022-01-06 10:02:57

gerardbonnier
Membre
2014-04-09
19

Re: mise à jour et version de PHP

Avant que je fasse "le siege de OVH" j'ai des informations que je ne sais pas bien analyser
j'ai trouvé le fichier .ovhconfig dans la ricione de mon site (sous www). Si je le supprime Piwigo ne fonctionne pas mais phpinfo me décrit la version 4.4.9
voici le contenu de .ovhconfig qui permet à Piwigo de fonctionner :
; ovhconfig

app.engine=php


app.engine.version=5.4


http.firewall=none


environment=development

OVH m'indique que j'utilise la version 7.3 de PHP (dans le tableau de bord de mon site)

si dans le fichier .ovhconfig j'écris app.engine.version=7.3 alors Piwigo ne fonctionne pas et phpinfo non plus !

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact