Annonce

#1 2021-02-09 15:51:49

gesualda
Membre
2010-12-09
87

Piwigo et php8

Bonjour,

Je viens de transférer PIWIGO dans un autre dossier WWW pour test en local. J'ai activé php 8.02 et j'accède à une page blanche.

Peut être une piste ou bien y a t-il encore une incompatibilité ? J'ai activé l'affichage des erreurs php, mais il n'y en pas pour le moment.

Quelqu'un pour me donner une piste, SVP ?

Merci d'avance,

-------------------
Version de Piwigo: 11.3.0
Version de PHP: 8.02
Version de MySQL:  5.5.57-MariaDB
URL Piwigo: http://

Hors ligne

#2 2021-02-09 16:39:39

Dom59
Membre
Lille
2020-05-02
145

Re: Piwigo et php8

le mieux est de regarder ici
https://fr.piwigo.org/guides/installati … 3%A9requis
j'ai comme l’impression qu'il va falloir patienter un peu


Piwigo 11.4.0
Bootstrap_darkroom 2.4.5
PHP: 7.3.27 MySQL: 5.6.50-log
https://lillephotos.com

Hors ligne

#3 2021-02-09 16:57:04

gesualda
Membre
2010-12-09
87

Re: Piwigo et php8

Merci Dom59

Cela ne me dit pas si c'est compatible avec php8.
C'est juste pour que je ne cherche pas plus longtemps pour le moment ... lol

Hors ligne

#4 2021-02-09 17:23:21

Dom59
Membre
Lille
2020-05-02
145

Re: Piwigo et php8

Il y a quelques extensions qui ne sont pas à jour pour ma version
Piwigo bouge beaucoup en ce moment
[2021-02-06] Piwigo 11.3.0
[2021-01-31] Piwigo 11.2.0
[2021-01-22] Piwigo 11.1.0
Lorsque les extensions seront à jour ce sera peut-être le moment de passer a la suite.


Piwigo 11.4.0
Bootstrap_darkroom 2.4.5
PHP: 7.3.27 MySQL: 5.6.50-log
https://lillephotos.com

Hors ligne

#5 2021-02-09 17:55:03

gesualda
Membre
2010-12-09
87

Re: Piwigo et php8

ok, ca marche, je vais patienter ...

Hors ligne

#6 2021-02-26 14:50:08

flop25
Équipe Piwigo
2006-07-06
6539

Re: Piwigo et php8

nous avons du mal à maintenir une compatibilité pour les versions 7.x récentes alors la 8 qui date de janvier !
avec les ressources actuelles du projet, il est plutôt probable que nous ne soyons pas garanti d'être compatible php 8 cette année.

Hors ligne

#7 2021-04-09 23:17:41

SebSimpli
Invité

Re: Piwigo et php8

Bonsoir,

Bloqué aussi depuis PHP 8 (sortie en novembre 2020)... En principe, PHP 8 est rétro compatible avec PHP 7.x. L'inverse n'est en revanche pas possible. J'ai même une appli qu'un client avait laissé tomber depuis PHP 5.6 et qui tourne sans problème sur PHP 8.

Tant pis, je trouvais cette application vraiment bien faite !

Bons développements à vous.

Sébastien

#8 2021-04-09 23:46:49

flop25
Équipe Piwigo
2006-07-06
6539

Re: Piwigo et php8

ah non à chauque maj de PHP il ya des incompatiblités : https://www.php.net/manual/fr/migration … atible.php

et c'est normal

mais PHP 8 c'est fin d'année dernière ; pour des projets bénévoles, il faut genre au moins 1-2 ans pour etre 100% compatible

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2021 · Contact