Annonce

#1 2021-02-09 19:08:16

jym_22
Membre
2018-03-12
12

Problème de cache

Bonsoir,

J'ai un problème depuis quelque temps : quand je modifie une image, que je la recharge dans piwigo en gardant le même nom, je retrouve l'ancienne image même si je relance une synchronisation.
J'ai essayé toutes les purges possibles, effacements
Les rafraichissements, effacements de l'historique ... ne changent rien
Si je donne un nouveau nom à l'image, pas de problème.
Si je redonne le nom initial, il retr
Ou y a-t-il d'autres caches avec une longue persistance  ?

Merci pour votre assistance.

Jean-Yves

Version de Piwigo: 11.3.0
Version de PHP: 7.3.23
Version de MySQL: 5.5.5-10.4.14-MariaDB [2021-02-09 19:06:17]
URL Piwigo: localhost (mais je peux mettre un site LWS)

Hors ligne

#2 2021-02-09 19:50:48

jym_22
Membre
2018-03-12
12

Re: Problème de cache

Je reprends la page (que je n'avais pas relue):
------------------------------------------------------

J'ai un problème depuis quelque temps : quand je modifie une image, que je la recharge dans piwigo en gardant le même nom, je retrouve l'ancienne image même si je relance une synchronisation.
J'ai essayé toutes les purges possibles, effacements des images générées ...
Les rafraichissements, effacements de l'historique ... ne changent rien
Si je donne un nouveau nom à l'image, pas de problème.
Si je redonne le nom initial, il retrouve les anciennes images
Y a-t-il d'autres caches avec une longue persistance  ?

Hors ligne

#3 2021-02-09 20:09:36

Guillaume C
Membre
Belgium
2014-04-08
335

Re: Problème de cache

jym_22 a écrit:

Y a-t-il d'autres caches avec une longue persistance  ?

Celui du navigateur, tout simplement.

Hors ligne

#4 2021-02-09 21:14:12

jym_22
Membre
2018-03-12
12

Re: Problème de cache

merci, mais ça ne suffit pas toujours.

Je vais reprendre le tout demain !

Hors ligne

#5 2021-02-09 21:36:21

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: Problème de cache

Bonjour

As tu vidé le cache de ton navigateur ?

Dans administration > Outils > maintenance

cache de l'utilisateur


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#6 2021-02-10 10:45:45

jym_22
Membre
2018-03-12
12

Re: Problème de cache

Je crois effectivement que je ne faisais pas les choses dans l'ordre !

De plus je croyais que piwigo utilisait toujours les miniatures utilisées par PhpWebGallery dans un répertoire thumbnail alors que manifestement tout se trouve maintenant dans le cache _data/i/galleries.

Il faut donc passer par "Supprimer les tailles multiples des photos:" et sélectionner "tout"

Merci beaucoup.

Jean-Yves.

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact