Annonce

#1 2020-12-28 18:00:20

Celtica
Membre
2012-02-15
19

[Résolu] Problème codage banière PHP+HTML

Bonsoir,

Je suis actuellement en train de travailler sur la version bilingue de mon site internet professionnel qui comporte un bandeau de navigation graphique avec des boutons dont un qui a été rajouté pour changer de langue.

Mon souci est au niveau de la galerie photo dont je voudrais faire afficher la bannière correspondante à la langue de la galerie photo en cours et de la changer quand on clique sur le bouton de changement de langue ou quand on clique sur le bouton de changement de langue des plugins de changement de langue.

Doncrètement, j'ai deux bannières, une en Anglais et une en Français, chacune codé en HTML et qui fonctionne toute seule.

Mon souci commence à partir du moment où je veux afficher l'une ou l'autre en fonction du code langue les deux codes html bannière inséré dans du PHP et insérer dans Configuration/Option/Paramètres de bases/Bannières Pages.

Après avoir insérer le code complet, les deux bannières s'affichent alors qu'il ne devrait y avoir que celle de langue sélectionnée qui devrait s'afficher et pas l'autre. ça donne donne l'impression qu'il n'y a que le code HTML qui est pris en compte et pas le code PHP, je n'arrive pas à comprendre ce qui se passe alors que je n'utilise qu'une fonction if très basique avec récupération de langue : Si la langue est le français, ça affiche la bannière en français; si la langue est en anglais ça affiche celle en anglais.

Le code PHP que je veux insérer est basique :

<?php if ($_GET['lang']=='fr'): ?>

Table HTML bannière en français

<?php endif ?>

<?php if ($_GET['lang']=='en'): ?>

Table HTML bannière en anglais

<?php endif ?>


J'ai essayé pas mal d'autre variante du code avec ifelse, else et d'autre manière de récupérer la langue, même avec la deuxième variante du codage PHP de la fonction ne veut pas non plus fonctionner et affiche aussi les deux bannières à la fois sans prendre en compte les lignes de code PHP.

J'ai essayé de voir si il y avait la possibilité d'ajouter mon code directement dans la variable de la bannière dans un fichier de l'application, n'était pas très calé en PHP à part à faire quelques modifications basiques de code, je n'ai pas trouvé quel fichier modifié et à quel endroit rajouter mon bout de code.

J'espère que mes explications sont suffisamment claires et que quelqu'un aurait une idée pour que mon bout de code PHP soit pris en compte par la galerie photo.

Il y a des moments où je me dis que ça serait peut être plus pratique d'installer une deuxième galerie photo, une dans chaque langue qui serait peut être moins galères à paramétrer avec toutes les balises métas, tags, titres et autres en fonction de langue de l'utilisateur.

Merci beaucoup par avance.

Bonne soirée.


Version de Piwigo: 2.9.5
Version de PHP: 7.2.31
Version de MySQL: 5.5.30

Hors ligne

#2 2020-12-28 18:26:49

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
15914

Re: [Résolu] Problème codage banière PHP+HTML

Bonjour

perso j'utiliserais le plugin extended description pour cela


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2020-12-28 19:07:29

Celtica
Membre
2012-02-15
19

Re: [Résolu] Problème codage banière PHP+HTML

Bonsoir,

Merci beaucoup pour cette suggestion, ça fonctionne très bien du premier coup !

Je n'avais pas encore regarder ce plugin, je comptais l'utilisé plus tard pour les catégories, je ne savais pas que ce plugin pouvait être utilisé aussi sur la bannière.

C'est nettement plus simple d'utiliser ce plugin que de chercher à vouloir absolument à faire ingurgiter du code PHP mélanger à du html.

Il y a une chose curieuse qui se passe c'est quand la galerie est passée en anglais et qu'on navigue dans les catégories tout repasse en français au premier clic.

Est-ce que ça viendrais du fait que le navigateur est en français ou que les descriptions bilingues n'ont pas encore été rajouté ?

Dernière modification par Celtica (2020-12-28 19:42:01)

Hors ligne

#4 2020-12-28 20:26:47

Celtica
Membre
2012-02-15
19

Re: [Résolu] Problème codage banière PHP+HTML

Pour info, finalement la chose étrange de la langue qui revient à la langue d'origine dès que l'on navigue dans la galerie semble être un bug lorsque l'on utilise Internet Explorer 11.

J'ai fais le test sur 4 autres navigateurs dont un d'une version qui commence à ne plus être toute jeune, ça fonctionne correctement.

Encore merci beaucoup pour l'aide, à par pour le changement de langue à partir du bouton de langue de ma bannière si j'arrive à trouver le morceau de code pour le faire (sinon je vire ce bouton pour garder que celui de la galerie qui simplifierait la manip en rognant sur la charte graphique), avec ce plugin tout est beaucoup plus simple à mettre en place.

Bonne soirée.

Hors ligne

#5 2020-12-29 06:30:25

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
15914

Re: [Résolu] Problème codage banière PHP+HTML

Bonjour,

en config local ajouter

$conf['browser_language'] = false;


pour que la langue du navigateur ne soit pas pris par défaut


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#6 2021-01-04 16:01:20

Celtica
Membre
2012-02-15
19

Re: [Résolu] Problème codage banière PHP+HTML

Merci de l'information, je regarderais dès que j'aurais un moment.

J'ai une dernière personnalisation encore un peu tordu à voir dans le fichier common.inc pour afficher mes pages externes quand la galerie est verrouillée, ça c'est une autre histoire qui fera peut être l'objet d'un autre post).

Je ne sais pas si c'est normal, je ne vois pas la possibilité d'indiquer que ce post est résolu.

Hors ligne

#7 2021-01-04 16:51:39

dreamer
Membre
St Cyr/mer (83)
2006-02-26
821

Re: [Résolu] Problème codage banière PHP+HTML

Celtica a écrit:

Merci de l'information, je regarderais dès que j'aurais un moment.

J'ai une dernière personnalisation encore un peu tordu à voir dans le fichier common.inc pour afficher mes pages externes quand la galerie est verrouillée, ça c'est une autre histoire qui fera peut être l'objet d'un autre post).

Je ne sais pas si c'est normal, je ne vois pas la possibilité d'indiquer que ce post est résolu.

Salut

C'est marqué sur ton PREMIER post !!

A+


beauxvoyages.fr/photos (photos), beauxvoyages.fr/jukebox (musiques) et tout nouveau beauxvoyages.fr/camping (camping-car) le tout en version 11.5.0

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2021 · Contact