Annonce

#1 2020-07-05 12:00:48

rjulie95
Membre
2020-07-05
3

Problème de permission

Bonjour

J'ai un problème avec les permissions sur les albums. Les albums sont publiés via le plugin Lightroom piwigo.

L'album Melting Pot Safari qui est public, n’apparaît pas au simple visiteur


L'album de ma fille est privé donc lui il n’apparaît pas aux visiteurs c'est normal, par contre même avec un utilisateur autorisé il n'apparaît pas non plus

Avez vous des pistes ? Sinon j'ai aussi un message d'erreur à la création des comptes, mais ça je le résoudrai plus tard

Piwigo 2.10.2
Système d'exploitation: Linux
PHP: 7.4.3 (Montrer les informations) [2020-07-05 11:50:22]
MySQL: 5.5.5-10.5.3-MariaDB-1:10.5.3+maria~focal-log [2020-07-05 09:50:22]
Bibliothèque graphique: External ImageMagick 6.9.10-23
URL Piwigo: http://piwigo.en-voyages.fr/

Hors ligne

#2 2020-07-05 14:03:58

deheme
Membre
IDF
2014-05-14
238

Re: Problème de permission

Bonjour Julie,

Je serais toi, je resoudrais le problème de création d'utilisateur et l'erreur fatale qu'elle génère pour qu'on puisse s'inscrire sur ton site.

Par ailleurs, il faut savoir que Piwigo n'affiche pas les albums vides (qui ne contiennent pas de photos ou non accessibles), n'est ce pas le cas?

Regarde aussi du côté des droits d'accès aux photos, n'as tu pas limité cet accès? Dans un premier temps, pour la mise au point, je te suggère  de mettre "tout le monde" dans le paramètre "qui peut voir ces photos?" et traiter les questions 'accès avec les albums.

En tant qu'admin, vois tu les albums?

Dis nous ensuite ce qu'il en est.
DéHème

Hors ligne

#3 2020-07-05 15:48:38

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16134

Re: Problème de permission

Bonjuor

je dirais qu'ils sont verrouillé ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#4 2020-07-06 16:03:53

rjulie95
Membre
2020-07-05
3

Re: Problème de permission

Bonjour,

Vos commentaires m'ont mis sur la voie, merci

Alors déjà pour la connexion les messages d'erreurs étaient du à l'absence des librairies suivantes, php-xml, php-mbstring. Dommage que ça ne sort pas un message de blocage pendant l’installation.

Pour la gestion des droits, j'avais bien mis les utilisateurs dans le bon groupe, mais manifestement il faut aussi les mettre dans le niveau de confidentialité, va falloir que je creuse pour comprendre.

En tout ça merci ça fonctionne maintenant

Hors ligne

#5 2020-07-06 21:49:46

deheme
Membre
IDF
2014-05-14
238

Re: Problème de permission

Bonne nouvelle, on accède à ton site...
et désolé de t'avoir appelé Julie, Régis!

Cordialement
DéHème

Hors ligne

#6 2020-07-07 09:09:37

rjulie95
Membre
2020-07-05
3

Re: Problème de permission

Ne t'inquiète pas, ça m'agaçait fortement quand j'étais gamin, maintenant je m'en contrefout et je n'avais même pas remarqué

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact