Annonce

  •  » Installation
  •  » Impossible d'envoyer des mails (gmail)

#1 2020-06-22 12:16:52

nmicoud
Membre
1970-01-01
65

Impossible d'envoyer des mails (gmail)

Bonjour,

Je viens de me rendre compte que les mails ne partaient plus de ma galerie (installée sur un serveur dédié).
J'avais configuré username/password avec mon compte gmail principal.
Je me suis dit que ça pouvait venir du fait que Google considérait piwigo comme une appli "non sûre" (accès pour les applications moins sécurisées).

Je me suis donc créé une autre adresse, dédiée celle-ci, sur laquelle j'ai autorisé les applications considérés comme non sûres et ai mis à jour le config.inc.php pour refléter ces changements :

$conf['mail_options'] = false;
$conf['send_bcc_mail_webmaster'] = true;

$conf['smtp_host'] = 'smtp.gmail.com';
$conf['smtp_user'] = 'xxx.yyy@gmail.com';
$conf['smtp_password'] = 'mon_mot_de_passe';
// 'ssl' or 'tls'
$conf['smtp_secure'] = 'tls';

Mais ça n'a rien changé, les mails refusent de partir.

J'ai ajouté hier soir une galerie et au moment d'envoyer les notifications, j'obtiens sur le haut de la page :
Warning: Mailer Error: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/ … leshooting in /media/www-dev/public/pwg/include/functions_mail.inc.php on line 908

Malgré tout, piwigo me dit "1 mail a été envoyé. (nom utilisateur)" (sur fond vert).


Je vois pas bien ce qui a pu changer (les mails partaient bien en novembre dernier par exemple, je n'ai pas ajouté beaucoup de photos depuis) ou l'action à entreprendre pour corriger.

Des idées ?

Merci

Nico

nb: je voulais mettre des copies d'écran, mais n'ai pas trouvé comment faire :-/

Version de Piwigo: 2.10.2
Version de PHP: PHP Version 7.0.15-0ubuntu0.16.04.4
Version de MySQL: 5.7.19-0ubuntu0.16.04.1
URL Piwigo: http://nicololo.fr/public/pwg/

Hors ligne

#2 2020-06-25 21:36:42

deheme
Membre
IDF
2014-05-14
224

Re: Impossible d'envoyer des mails (gmail)

Bonjour Nico,

As tu essayé ?

$conf['smtp_host'] = 'smtp.gmail.com:465';
avec
$conf['smtp_secure'] = 'ssl';

Cordialement
DéHème

Hors ligne

#3 2020-06-26 06:30:23

nmicoud
Membre
1970-01-01
65

Re: Impossible d'envoyer des mails (gmail)

Bonjour,

Je viens de tester (j'avais aussi tenté le 587), mais ça ne change rien (:

Hors ligne

  •  » Installation
  •  » Impossible d'envoyer des mails (gmail)

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2020 · Contact