Annonce

  •  » Installation
  •  » impossible d'installer Piwigo sur un serveur WAMP

#1 2020-06-01 13:12:43

Klavin
Membre
2020-05-06
19

impossible d'installer Piwigo sur un serveur WAMP

Bonjour/Bonsoir,
Mon piwigo chez Free ne fonctionne plus (problème de serveur chez Free). Alors j'ai décidé de rapatrier Piwigo sur une machine locale en attendant mieux.

J'ai installé Wampserver32 (vielle machine  avec un windows10 32 bits)
J'ai crée une base de donnée vide 'piwigo' et un utilisateur 'user' autre que root avec phpMyAdmin.
root n'a pas de mot de passe et tous les privilèges sur les bases de données
user a un mot de passe et tous les privilèges sur la base piwigo.
le port utilisé par MySQL est le port 3308 (rien touché de ce coté)

je peux me connecter par phpMyAdmin sur la base de donnée mais pas avec Adminer, Pourquoi?
Si je lance l'installation de piwigo, l'accès au serveur est autorisé mais pas l'accès à la base de donnée.

"La connexion au serveur est OK, mais la connexion à cette base de données est impossible"

J'ai essayé d'installer avec root (sans mot de passe) ou avec user (avec mot de passe) , rien à faire
Je bloque et la documentation Piwigo sur l'installation sur serveur Wamp ne m'aide pas.

A l'inverse avec UBUNTU 20.xx, c'est adminer qui fonctionne mais pas phpMyAdmin, pour des problèmes de compatibilités de version mais ce n'est pas le sujet car je dois utiliser une machine Windows pour d'autres raisons.



Si quelqu'un avait une piste...
Version de Piwigo: 2.10.2
Version de PHP: 7.3.12
Version de MySQL: 5.7.28
URL Piwigo: http://

Hors ligne

#2 2020-06-01 16:10:54

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
15686

Re: impossible d'installer Piwigo sur un serveur WAMP

Bonjour

pour l’installation tu as choisis mysqli ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2020-06-01 20:00:56

Klavin
Membre
2020-05-06
19

Re: impossible d'installer Piwigo sur un serveur WAMP

Après plusieurs jours à tourner autour de mon serveur Wamp pour Piwigo, j'ai enfin compris pourquoi je n'arrivais pas à installer piwigo sur un serveur WAMP tout neuf.

Wamp installe 2 systèmes de base de données : MariaDB et MySQL, et par défaut il essaye d’installer piwigo avec mariaDB mais il ne le dit pas. Il faut aller dans les paramètres au plus profond  pour changer la base de données par défaut. Ouf ! Pas d'explication sur le blocage Adminer mais PHHMyAdmin fait le job.


Clic droit sur l’icone WAMP
clic gauche Outils/
inverser par défault MariaDB--Mysql


C'est tout bête et je ne dois pas être le premier.

j'ai donc réussi à débloquer la situation, j'ai transféré dans la foulée ma galerie Piwigo hébergée chez Free  (import BD+  copie dossier de données). J'ai ouvert le parefeu Windows et paramétré la freebox. Je peux voir la galerie depuis mon voisin. J'ai un nom de domaine freeboxos.fr proposé par la freebbox et j'attends le certificat pour passer en Https.

Question : j'ai noté toutes mes opérations  (copie d'écran etc...) . Où peut-on partager une telle expérience?

Hors ligne

#4 2020-06-01 20:26:58

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
15686

Re: impossible d'installer Piwigo sur un serveur WAMP

Bonjour

sur le wiki (doc) ou sur ce post en modifiant le titre pour qu'il soit plus explicite


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

  •  » Installation
  •  » impossible d'installer Piwigo sur un serveur WAMP

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2021 · Contact