Annonce

  •  » Outils
  •  » pLoader + SSL = La connexion échoue

#1 2012-09-09 16:10:38

Al95
Membre
2012-09-09
5

pLoader + SSL = La connexion échoue

Bonjour le forum,

Ceci est mon premier message alors j'en profite pour remercier tout ceux et celles qui ont fait Piwigo et qui nous permettent de l'utiliser Librement.

Pour ce qui m'amène ici, tout est dans le titre.
Le message d'erreur est :

Code:

Moved Temporarily
La connection à http://....(IP publique) a échoué

Le site sur lequel est installé Piwigo 2.1.2-3 est sous Apache2 en https sur Debian Squeeze.
Il est derrière un firewall avec redirection des ports 80 et 443.
Le certificat est auto-certifié.
Chaque requête http est systématiquement redirigée vers https :

Côté serveur, sur Piwigo il n'y a aucun problème sauf qu'on ne peut pas déposer des photos avec pLoader.
Tous les utilisateurs enregistrés peuvent pourtant s'y connecter avec leur login + password.

Le problème c'est uniquement côté client avec pLoader 1.6.0-1 pour se connecter sur Piwigo.

En parcourant le forum j'ai vu que sous Windows il fallait supprimer le répertoire .pLoader.
Mes clients sont sous Linux et Windows. J'ai supprimé ce répertoire sur les clients. Il est recréé à chaque tentative.
J'ai désinstallé/réinstallé pLoader. En vain.

Un tail -f sur les logs d'Apache dans /var/log et dans /etc/apache2/logs/ssl montre les tentatives de connexion mais je ne sais pas interpréter si ce sont des message normaux ou des erreurs.

Quand pLoader est utilisé sur un site sans le SSL alors les connexions se font sans problème.

Est-ce que quelqu'un aurait une voie de recherche à m'indiquer pour que pLoader puisse se connecter dans cette condition?

Merci par avance.

Dernière modification par Al95 (2012-09-09 16:23:29)

Hors ligne

#2 2012-11-24 04:47:49

Al95
Membre
2012-09-09
5

Re: pLoader + SSL = La connexion échoue

UP...

Transmettre de façon sécurisée avec pLoader : est-ce possible?

Hors ligne

#3 2012-11-24 08:02:24

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16339

Re: pLoader + SSL = La connexion échoue

Bonjour,

Le développeur de pLoader ne participe plus au projet, je ne suis pas sur que l'on puisse répondre à ta question.

Il y a d'autre outil pour envoyer les photos que tu peux peux être tester

Je vais faire des essais sur un serveur avec des caractéristiques qui ressemblent un peux


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#4 2012-11-24 08:17:38

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16339

Re: pLoader + SSL = La connexion échoue

Bon en https je n'arrive pas à me connecter non plus :-(


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2012-11-24 23:12:18

Al95
Membre
2012-09-09
5

Re: pLoader + SSL = La connexion échoue

ddtddt a écrit:

Il y a d'autre outil pour envoyer les photos que tu peux peux être tester

Je suis preneur. Lesquels sous Linux?

Pour uploader de façon sécurisée sous Linux je ne connais que scp et sftp.
Pour monter des répertoires distants : sshfs. Il y a aussi curlftpfs que je n'ai jamais utilisé.
Malheureusement il faut préparer les photos avant.

pLoader était bien pratique car côté client il faisait tout le boulot de préparation des photos de façon à alléger la charge sur le serveur. Il ne lui manque que la sécurité.

Merci de t'être intéressé à mon problème.

Hors ligne

#6 2012-11-24 23:21:05

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12590

Re: pLoader + SSL = La connexion échoue

Je confirme que techniquement pLoader n'est pas compatible SSL si je me souviens bien.

Le code source est disponible, si tu parviens à le rendre compatible HTTPS, je livrerai une nouvelle version pour Linux.


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

#7 2012-11-24 23:21:31

Al95
Membre
2012-09-09
5

Re: pLoader + SSL = La connexion échoue

ddtddt a écrit:

Bon en https je n'arrive pas à me connecter non plus :-(

Si, c'est possible avec Piwigo sur un serveur en https.
Je t'envoie un MP.

Hors ligne

#8 2012-11-24 23:39:29

Al95
Membre
2012-09-09
5

Re: pLoader + SSL = La connexion échoue

plg a écrit:

Le code source est disponible, si tu parviens à le rendre compatible HTTPS, je livrerai une nouvelle version pour Linux.

Je suis totalement incompétent pour une telle tâche :-(

Hors ligne

  •  » Outils
  •  » pLoader + SSL = La connexion échoue

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2023 · Contact