Annonce

  •  » Styles
  •  » [Résolu] Problème JS avec le nouveau thème simple (grey / black)

#1 2012-03-15 07:56:20

Peric
Membre
2012-01-03
10

[Résolu] Problème JS avec le nouveau thème simple (grey / black)

Hello,

  Je viens d'installer la dernière version de Piwigo 2.3.3
J'ai ce message d'erreur sur toutes les pages de ma galerie:

Warning: filemtime() [function.filemtime]: stat failed for ./themes/simple/js/scripts.js in /homez.433/krupapho/www/piwigo/include/template.class.php on line 1240

Warning: filemtime() [function.filemtime]: stat failed for ./themes/simple/js/jquery.cookie.min.js in /homez.433/krupapho/www/piwigo/include/template.class.php on line 1240

c'est à dire cette ligne 1240:
if ($conf['template_compile_check']) $key[] = filemtime( PHPWG_ROOT_PATH . $this->files[$i] );

Quelques infos:
Dans le répertoire ./themes/simple/ je n'ai pas ces 2 fichiers "scripts.js" et "jquery.cookie.min.js " car je n'ai pas le répertoire "js", il est seulement dans le répertoire " default".
Je n'ai pas ce problème avec le thème "Sylvia", seulement avec "simple grey" et "simple black".


(Pour voir: http://www.krupa-photo.fr/piwigo/index.php)

Quelqu'un a eu ce problème?

Merci

Dernière modification par Peric (2012-03-15 11:03:24)

Hors ligne

#2 2012-03-15 09:50:13

delmarty
Invité

Re: [Résolu] Problème JS avec le nouveau thème simple (grey / black)

je confirme que j'ai lememe type de message:

Warning: filemtime() [function.filemtime]: stat failed for ./themes/simple/js/scripts.js in /home/ikonfo96/public_html/piwigo/include/template.class.php on line 1240

Warning: filemtime() [function.filemtime]: stat failed for ./themes/simple/js/jquery.cookie.min.js in /home/ikonfo96/public_html/piwigo/include/template.class.php on line 1240


et en plus je n'ai plus de menu.

#3 2012-03-15 11:53:54

Peric
Membre
2012-01-03
10

Re: [Résolu] Problème JS avec le nouveau thème simple (grey / black)

Résolu si on copie/colle à la main le répertoire js après avoir télécharger le .zip du thème simple.

Hors ligne

#4 2012-03-15 13:21:16

delmarty
Invité

Re: [Résolu] Problème JS avec le nouveau thème simple (grey / black)

impossible via le ftp de rajouter le dossier js.pourtant je mets bien tout a 777.

#5 2012-03-15 14:14:27

Peric
Membre
2012-01-03
10

Re: [Résolu] Problème JS avec le nouveau thème simple (grey / black)

1/ j'ai téléchargé la dernière version du thème simple .zip
2/ j'ai pris le repertoire /js (qui contient 2 fichiers)
3/ j'utilise Fizilla
4/ Mon répertoire ./themes/simple/  a les droits "705"
5/ j'y ai collé le /js

Si tu n'arrives pas à copier/coller ce fichier en faisant comme moi, je ne peux pas vraiment t'aider... :-(

Je pense que le problème venait du fait que ce répertoire /js a été perdu d'une version à l'autre (et comme c'est du javascript -> plus de menu, border balnc des images disparus etc etc...)

+

Hors ligne

#6 2012-03-15 15:56:41

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12529

Re: [Résolu] Problème JS avec le nouveau thème simple (grey / black)

Il y a un bug dans le générateur d'archive : le fichier obsolete.list contient le répertoire "js" dans sa liste, ce qui fait que le répertoire est supprimé automatiquement... Je cherche le problème (avec P@t)


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#7 2012-03-15 17:19:07

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12529

Re: [Résolu] Problème JS avec le nouveau thème simple (grey / black)

p@t, j'ai commencé à regarder. Notamment en générant une version 3.2, mais on a toujours le même soucis avec obsolete.list. Je ne peux continuer à chercher qu'a partir de 21h donc si tu trouves avant...


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#8 2012-03-15 18:45:40

loranbass
Membre
Aussevielle - 64
2011-07-05
12

Re: [Résolu] Problème JS avec le nouveau thème simple (grey / black)

Bonsoir;

Même problème...

Voilà ce qui est inscrit au lancement de ma page :

Warning: filemtime() [function.filemtime]: stat failed for ./themes/simple/js/scripts.js in /mnt/149/sdb/d/e/loranbass/piwigo/include/template.class.php on line 1240

Warning: filemtime() [function.filemtime]: stat failed for ./themes/simple/js/jquery.cookie.min.js in /mnt/149/sdb/d/e/loranbass/piwigo/include/template.class.php on line 1240

Je n'ai même plus accès au menu et donc à la partie administration...

'Suis perdu !!! Booooooouuuuuuh !!!

Une solution ???

Voici ma page : http://loranbass.free.fr/piwigo/

Merci...

Dernière modification par loranbass (2012-03-15 18:47:25)

Hors ligne

#9 2012-03-15 19:21:05

loranbass
Membre
Aussevielle - 64
2011-07-05
12

Re: [Résolu] Problème JS avec le nouveau thème simple (grey / black)

loranbass a écrit:

Bonsoir;

Même problème...

Voilà ce qui est inscrit au lancement de ma page :

Warning: filemtime() [function.filemtime]: stat failed for ./themes/simple/js/scripts.js in /mnt/149/sdb/d/e/loranbass/piwigo/include/template.class.php on line 1240

Warning: filemtime() [function.filemtime]: stat failed for ./themes/simple/js/jquery.cookie.min.js in /mnt/149/sdb/d/e/loranbass/piwigo/include/template.class.php on line 1240

Je n'ai même plus accès au menu et donc à la partie administration...

'Suis perdu !!! Booooooouuuuuuh !!!

Une solution ???

Voici ma page : http://loranbass.free.fr/piwigo/

Merci...

J'ai suivi ce qu'a dit Peric et ça refonctionne à merveille...

Merci Peric... ;)

Dernière modification par loranbass (2012-03-15 19:21:48)

Hors ligne

#10 2012-03-15 21:59:27

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12529

Re: [Résolu] Problème JS avec le nouveau thème simple (grey / black)

bug corrigé, version 3.2 disponible.


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

  •  » Styles
  •  » [Résolu] Problème JS avec le nouveau thème simple (grey / black)

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact