#1 2010-09-13 22:01:12

julien1311
Membre
2010-09-01
141

[Résolu] phpmybackuppro

Bonjour à tous,

Je sauvegarde ma base de données à l'aide de phpmybackuppro.

J'ai créé un script afin de sauvegarder régulièrement la base de données. Ce script est lancé par la ligne suivante à la fin du fichier index.php à la racine de la galerie :

Code:

require_once("phpmybackuppro/schedule_backup.php");

Cependant, j'aimerais trouver une manière d'appeler la fonction sans modifier directement le index.php (pour ne pas perdre la modification à chaque mise à jour). Si j'utilise les templates, le code php n'est pas interprété. Comment faire ?

Merci par avance pour votre aide,

Hors ligne

#2 2010-09-14 00:53:02

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12345

Re: [Résolu] phpmybackuppro

Avec un plugin personnel.

1) installer puis activer le plugin [extension by Piwigo Team] LocalFiles Editor
2) [Administration > Plugins > LocalFiles Editor > Plugin personnel], coller le code

Code:

<?php
/*
Plugin Name: Personal Plugin
Version: 1.0
Description: Personal Plugin
Plugin URI: http://piwigo.org
Author:
Author URI:
*/

add_event_handler('loc_end_index', 'call_phpmybackuppro');
function call_phpmybackuppro()
{
  require_once("phpmybackuppro/schedule_backup.php");
}
?>

3) installer puis activer le plugin Personnel dans [Administration > Plugins > Gérer > Liste des plugins]


Dernier billet du blog Piwigo.com (20 juin 2019) Modus, nouveau thème par défaut sur Piwigo.com

Hors ligne

#3 2010-09-14 12:21:28

julien1311
Membre
2010-09-01
141

Re: [Résolu] phpmybackuppro

Merci pour cette réponse, je teste ça ce soir.

Juste une petite précision, pourquoi ça ne marche pas avec un template ? Ils ne sont pas exécuté côté serveur ?

Hors ligne

#4 2010-09-14 21:32:27

julien1311
Membre
2010-09-01
141

Re: [Résolu] phpmybackuppro

Bon, j'ai testé ce que m'a proposé plg, et on ne peut pas dire que ça marche parfaitement.

Le plugin permet bien d'appeler le bon fichier php et la sauvegarde se fait.

Cependant, j'ai des erreurs php qui s'affichent :
1) avec le code de plg, j'ai les erreurs suivantes sur la page index.php de mon site :

Code:

Warning: Smarty error: unable to read resource: "index.tpl" in /mnt/142/free.fr/2/e/nomdemonsite/include/smarty/libs/Smarty.class.php on line 1093

Warning: include() [function.include]: Unable to access ./include/page_tail.php in /mnt/142/free.fr/2/e/nomdemonsite/index.php on line 301

Warning: include(./include/page_tail.php) [function.include]: failed to open stream: No such file or directory in /mnt/142/free.fr/2/e/nomdemonsite/index.php on line 301

Warning: include() [function.include]: Failed opening './include/page_tail.php' for inclusion (include_path='/mnt/142/free.fr/2/e/nomdemonsite/include:.:/usr/php5/lib/php') in /mnt/142/free.fr/2/e/nomdemonsite/index.php on line 301

Ces warnings sont juste sous la bannière et rien d'autre ne s'affiche.

2) En remplaçant le premier argument de add_event_handler par 'loc_end_page_tail', je n'ai plus d'erreur sur les pages de ma galerie mais j'ai les erreurs suivantes dans les pages d'administration qui remplacent le footer :

Code:

Warning: Smarty error: unable to read resource: "footer.tpl" in /mnt/142/free.fr/2/e/nomdemonsite/include/smarty/libs/Smarty.class.php on line 1093

Warning: Smarty error: unable to read resource: "footer.tpl" in /mnt/142/free.fr/2/e/nomdemonsite/include/smarty/libs/Smarty.class.php on line 1093

Ces warning n'étant pas vraiment explicite, je ne m'en sors pas.

Quelqu'un aurait une idée pour me débloquer ?

Merci par avance,

Hors ligne

#5 2010-09-14 21:52:46

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: [Résolu] phpmybackuppro

Avez-vous pensé à remettre un fichier "index.php" vierge de toutes modifications ?
Vérifiez que votre fichier ne se termine pas avec des lignes vides après le symbole " ?> "


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#6 2010-09-14 22:05:16

julien1311
Membre
2010-09-01
141

Re: [Résolu] phpmybackuppro

Gotcha a écrit:

Avez-vous pensé à remettre un fichier "index.php" vierge de toutes modifications ?
Vérifiez que votre fichier ne se termine pas avec des lignes vides après le symbole " ?> "

Bon, en fait c'est juste que je suis un boulet ;)
J'avais mis un "chdir" dans mon script et du coup, à la sortie du script, les chemins relatifs ne pointaient plus vers ce qu'il faut.

En tout cas, merci pour ta réponse, qui, je ne sais pour quelle raison, m'a mis sur la voie.

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact