#46 2010-05-28 22:53:23

saimon
Membre
2006-12-04
367

Re: [2.1.0RC3] simple grey

yes alors j'ai pas tout précisé, c'était plus un billet d'humeur car j'avais pas trop le temps de rentrer dans les détails ;-).

Donc tous les fichiers de mon install piwigo appartiennent à httpd, le user apache, sauf le repertoire "galleries" qui est en fait un lien symbolique vers un autre répertoire qui est une copie locale de mon répertoire galleries "de prod", donc tout ce qui est dans galleries/ appartient à mon user y compris index.php et apache n'avait pas de droit dessus. J'avais fait ça pour faire simple et rapide me disant qu'au pire piwigo gnognerait un coup s'il lui manquait des permissions.
Sauf que du coup, auto-upgrade a mis à jour tous les fichiers sauf galleries/index.php et a du s'arrêter là, sans mettre à jour la bdd. Il a peut être pas nettoyé les anciens fichiers aussi (les répertoires template/ et template-common/ sont encore là).
Voili voulou

Tu n'as plus qu'à le mettre à jour à la main et lancer l'upgrade.php

ah mon sauveur ! merci, ça a marché !

Dernière modification par saimon (2010-05-28 22:57:53)

Hors ligne

#47 2010-05-28 23:16:33

P@t
Équipe Piwigo
Nice
2007-06-13
5695

Re: [2.1.0RC3] simple grey

saimon a écrit:

Donc tous les fichiers de mon install piwigo appartiennent à httpd, le user apache, sauf le repertoire "galleries" qui est en fait un lien symbolique vers un autre répertoire qui est une copie locale de mon répertoire galleries "de prod", donc tout ce qui est dans galleries/ appartient à mon user y compris index.php et apache n'avait pas de droit dessus. J'avais fait ça pour faire simple et rapide me disant qu'au pire piwigo gnognerait un coup s'il lui manquait des permissions.
Sauf que du coup, auto-upgrade a mis à jour tous les fichiers sauf galleries/index.php et a du s'arrêter là, sans mettre à jour la bdd. Il a peut être pas nettoyé les anciens fichiers aussi (les répertoires template/ et template-common/ sont encore là).
Voili voulou

Ok, j'avais pas vu que c'était le index.php de galleries!
En effet, c'est un cas un peu particulier... le nettoyage n'a pas été effectué, normal...


P@t

Hors ligne

#48 2010-05-29 00:06:19

saimon
Membre
2006-12-04
367

Re: [2.1.0RC3] simple grey

@plg:

> corrigé pour les commentaires,

> Lorsque je navigue sur un tag, il n'y a pas d'icône pour supprimer le tag et les X sont sur une autre ligne, les une à côté des autres.

corrigé, par contre tout ce code html est rajouté par {'Tags'|@translate} ce qui ne laisse pas trop de choix sur le code ...

> Ca je sais que c'est normal, mais un "Powered by Piwigo..." sur picture.php, ce serait... bien :-)

je veux bien le mettre, le problème est que du coup il s'afficherait aussi sur le diaporama et là c'est pas très joli. Donc je le cache. S'il y a moyen de séparer les 2 je prend !

> image haute définition : ok

> Sur Simple, pour un visiteur (ma famille par exemple), ce n'est absolument pas évident de trouver le menu. Or, le menu est nécessaire pour se connecter. Et ma famille ne voit rien qui les intéresse s'ils ne sont pas connectés. Du coup, je me fais insulter parce qu'ils reçoivent des emails de notification, mais qu'il n'y a rien sur la galerie :-/

c'est facilement modifiable pour le comportement par défaut, et après c'est un cookie

> Peut-on envisager de sortir le block "Identification" du menu et de le mettre sous forme de liste...

c'est une idée, je verrais si j'ai le temps (pour l'instant j'essaye de parer au plus pressé, corriger les bugs).

> screenshot ok

> barre de navigation ok

ca se précise, tout ça est sur bitbucket ;-)

Hors ligne

#49 2010-05-30 01:20:31

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12615

Re: [2.1.0RC3] simple grey

Excellent pour les corrections :-)

saimon a écrit:

> Ca je sais que c'est normal, mais un "Powered by Piwigo..." sur picture.php, ce serait... bien :-)

je veux bien le mettre, le problème est que du coup il s'afficherait aussi sur le diaporama et là c'est pas très joli. Donc je le cache. S'il y a moyen de séparer les 2 je prend !

Actuellement, par défaut, en cas de slideshow, on charge slideshow.tpl à la place de picture.tpl mais dans les 2 cas, l'id du body est "thePicturePage".

Si je propose d'ajouter un $page['body_class'] = 'slideshowPage' dans le core (pour la 2.1.2) et que dans simple/theme.css tu ajoutes un .slideshowPage #copyright {display:none} (et que tu vires le #thePicturePage #copyright {display:none;} du coup), ça t'irait ? (faudra aussi gérer le {if isset($BODY_CLASS)} dans header.tpl qui est dupliqué pour le thème simple.

Une autre solution un peu crado, c'est de mettre un <style>#copyright {display:none}</style> dans ton slideshow.tpl.


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

#50 2010-05-31 11:22:50

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12615

Re: [2.1.0RC3] simple grey

saimon a écrit:

ca se précise, tout ça est sur bitbucket ;-)

Je viens de refaire un essai. Nickel toutes les corrections. Screenshot très bien.

J'ai activé [extension by gbo] Look_like_Gbo 2 et...

Notice: Undefined offset: 1 in /.../2.1/plugins/look_like_gbo2/main.inc.php on line 186

De même, les blocks de [extension by plg] PWG Stuffs ne sont pas supportés je pense. Dans le screenshot ci-joint, j'ai ajouté un block "images au hasard".


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

#51 2010-05-31 13:05:55

gbo
Membre
PACA
2006-11-01
1183

Re: [2.1.0RC3] simple grey

plg a écrit:

J'ai activé [extension by gbo] Look_like_Gbo 2 et...

Notice: Undefined offset: 1 in /.../2.1/plugins/look_like_gbo2/main.inc.php on line 186

C'est pour moi, la version 2.1.C de LLGBO2 corrige le souci.
La version corrigée est dans SVN, je la livrerai dans les extensions au moment ou Boulde livrera le thème simple.
(je préfère prendre un peu de recul sur les retours d'autres utilisateurs)
Le souci vient du fait que simple n'a pas de theme par défaut et cela fait planté mon test.
Car je n'avais pas prévu ce cas!!!!

Hors ligne

#52 2010-05-31 13:15:25

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12615

Re: [2.1.0RC3] simple grey

EX-FTB a écrit:

Le souci vient du fait que simple n'a pas de theme par défaut [...]

Que veux-tu dire ?


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

#53 2010-05-31 13:36:33

gbo
Membre
PACA
2006-11-01
1183

Re: [2.1.0RC3] simple grey

Tous les autres thèmes  dark....,Gally*,Pure*  ont un parent (*default qui n'est pas affichable).
Simple Grey s'affiche et n'a pas de parent.
Cela ne gène  pas le fonctionnement, mais mon test était basé (par erreur ** )  sur la présence d'un thème parent.


** voir le 4° message de cette discussion.

Hors ligne

#54 2010-05-31 13:50:07

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12615

Re: [2.1.0RC3] simple grey

si un thème ne déclare pas de parent, alors c'est implicitement "default".


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

#55 2010-05-31 21:57:22

saimon
Membre
2006-12-04
367

Re: [2.1.0RC3] simple grey

plg a écrit:

Si je propose d'ajouter un $page['body_class'] = 'slideshowPage' dans le core (pour la 2.1.2) et que dans simple/theme.css tu ajoutes un .slideshowPage #copyright {display:none} (et que tu vires le #thePicturePage #copyright {display:none;} du coup), ça t'irait ? (faudra aussi gérer le {if isset($BODY_CLASS)} dans header.tpl qui est dupliqué pour le thème simple.

yes, un id slideshowPage serait parfait :-). Par contre je comprend pas l'histoire du isset($BODY_CLASS) ?
pour PWG Stuffs  c'est juste pour les images, j'ai fait une modif pour que ce soit mieux.

Hors ligne

#56 2010-05-31 22:14:36

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12615

Re: [2.1.0RC3] simple grey

saimon a écrit:

yes, un id slideshowPage serait parfait :-). Par contre je comprend pas l'histoire du isset($BODY_CLASS) ?

un class= pas un id=. Le body aura déjà id=thePicturePage.

Dans le header.tpl, il faudrait avoir :

Code:

<body id="{$BODY_ID}" {if isset($BODY_CLASS)}class="{$BODY_CLASS}"{/if}>

Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

#57 2010-05-31 22:27:33

saimon
Membre
2006-12-04
367

Re: [2.1.0RC3] simple grey

ok

Hors ligne

#58 2010-05-31 22:32:03

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12615

Re: [2.1.0RC3] simple grey

Je rajoute ça pour la 2.1.2 alors : [Bugtracker] ticket 1712


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

#59 2010-06-01 00:53:35

P@t
Équipe Piwigo
Nice
2007-06-13
5695

Re: [2.1.0RC3] simple grey

plg a écrit:

si un thème ne déclare pas de parent, alors c'est implicitement "default".

Non! Si un thème ne déclare pas de parent, ce n'est pas "default" son thème parent!
Il faut donc tous les fichiers tpl nécessaires dans son dossier "template".


P@t

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2023 · Contact