Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

isaric
2013-04-14 08:47:09

Merci flop25
J'ai en local

Code:

~$ ls -la
...
-rw-rw-rw- 1 isaric isaric 3640360 avril 11 19:29 A.JPG
~$ chmod 777 A.JPG
~$ ls -la
…
-rwxrwxrwx 1 isaric isaric 3640360 avril 11 19:29 A.JPG

Après transfert avec filezilla, il arrive en 644 et il m'est impossible de mettre 777 , il reste en 644§

flop25
2013-04-13 17:59:05

Re bonjour
les sites distants oui ne sont plus supportés, mais cette page -qui doit être remaniées- marche pour des images étant sur le même serveur et accessible en lecture (je le fait en local pour éviter de dupliquer x fois des images sur mes x galeries de tests)

Là je ne sais pas quel est le problème : il faudrait essayer avec chmod 777 pour le dossier et les images, vérifier qu'il n'y a pas de caractères interdits, qui est l'utilisateur propriétaire des fichiers...

isaric
2013-04-12 14:48:01

Merci flop25, je vais supprimer les dossiers pwg_high et thumbnail

flop25 a écrit:

..
Le chmod permet il la lecture du fichier ?

Il est à 700 tout comme celui de /piwigo/galleries

Édit :
Aussi, je n'ai pas mis de fichiers autres sur le site distant comme :

Code:

create_listing_file.php
create_listing_file_local.inc.php

Je vois aussi sur Piwigo 2.4 et sites distants que les sites distant ne sont plus gérés est-ce mon cas ? Je suis avec piwigo-2.5.0.

flop25
2013-04-12 14:13:17

Depuis la 2.4 plus besoin de pwg_high ni thumbnail
Le chmod permet il la lecture du fichier ?

isaric
2013-04-12 14:07:11

Je reprends ici seulement que la question C), les autres j'ai posté ailleurs (voir l'édit poste 1)

flop25 a écrit:

isaric a écrit:

C) J'ai créé dans le gestionnaire des sites un site "../Photo", j'y ai mis ma petite photo (via FTP) mais lorsque je fais synchroniser j'ai 0 photo d'enregistrée. Faut-il autre chose ? (sous phpwebgallerie on parlait de miniatures .thumbs, de create_listing_file.php est-ce d'actualité ?)

non plus du tout
vous avez bien :
-piwigo
"\_galleries
-photo
"\_images.jpeg
et pas
-piwigo
"\_galleries
"\_photo
"""\_images.jpeg

Mon arborescence est :
/
/piwigo/...
/photo/image.jpg
/photo/pwg_high/image.jpg
/photo/thumbnail/TN-image.jpg

J'ai créé un site distant "../Photo", mais j’ai 0 photo de synchronisé

Il doit me manquer autre chose ?

isaric
2013-04-11 10:24:29

Merci flop25

flop25
2013-04-11 10:09:00

ha et si vous souhaitez approfondir plusieurs réponses, une question par sujet, donc ouvrez un nouveau sujet pour la seconde question

flop25
2013-04-11 10:08:14

Bonjour

isaric a écrit:

A) Peut-on le faire par FTP ?

bien entendu et c'est le but de la méthode
Néanmoins un soucis se posera pour la création des miniatures et autres tailles d'images sous Free
Il y a pas mal de sujet à ce propos

isaric a écrit:

B) Avec une photo plus petite cela marche, elle se retrouve sous /pwg/upload/2013/04/11 (et elle a été renommé), mais je ne vois pas le fichier .xmp, est-il utilisable par piwigo ?

Non, il s'agit d'un format propriétaire : Piwigo par contre lit les métadata/métadonnées incristes dans l'image (exif/iptc)

isaric a écrit:

C) J'ai créé dans le gestionnaire des sites un site "../Photo", j'y ai mis ma petite photo (via FTP) mais lorsque je fais synchroniser j'ai 0 photo d'enregistrée. Faut-il autre chose ? (sous phpwebgallerie on parlait de miniatures .thumbs, de create_listing_file.php est-ce d'actualité ?)

non plus du tout
vous avez bien :
-piwigo
"\_galleries
-photo
"\_images.jpeg
et pas
-piwigo
"\_galleries
"\_photo
"""\_images.jpeg

isaric
2013-04-11 09:09:21

Bonjour,

Je viens d'installer piwigo et je souhaite y mettre des photos. Je suis chez Free.fr et l'importation n'est pas autorisé pour une photo >[2048]

A) Peut-on le faire par FTP ?

B) Avec une photo plus petite cela marche, elle se retrouve sous /pwg/upload/2013/04/11 (et elle a été renommé), mais je ne vois pas le fichier .xmp, est-il utilisable par piwigo ?

C) J'ai créé dans le gestionnaire des sites un site "../Photo", j'y ai mis ma petite photo (via FTP) mais lorsque je fais synchroniser j'ai 0 photo d'enregistrée. Faut-il autre chose ? (sous phpwebgallerie on parlait de miniatures .thumbs, de create_listing_file.php est-ce d'actualité ?)

D'avance merci

Édit :
Suite à la bonne intervention de flop je poursuis là  pour les questions A & B :
    A) [Résolu] [Free] Téléverser des photos via le formulaire en ligne
    B) Utilisation des métadonnées

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact