Annonce

  •  » Plugins
  •  » [1.5.x] Video Integrator 2.1

#1 2006-01-06 22:45:13

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

[1.5.x] Video Integrator 2.1

Bonjour,

Dans les extensions, Video Integrator 2 est disponible.

Quoi de neuf?
- Support des players Quicktime, Macromedia Flash, et Windows Media Player.
- Possibilité d'utiliser un background (curtain=rideau).

Décompresser video-integrator.zip
Lire et suivre la procédure "Video Integrator II.txt"

Etapes:

1- Modifications de include/config_local.inc.php
2- Modification des templates (ne cherchez pas noflash.png (option retirée en dernière minute)).
3- Modifications des css
4- Modifications des TPL (celui livré est basé sur yoga-dark)
5- Modifications des php (dont la création du répertoire modules).

Bonnes lectures (de videos ;-)).


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#2 2006-01-07 09:19:09

CHUCKYCHUCK
Membre
2005-09-25
19

Re: [1.5.x] Video Integrator 2.1

cool ! c'est super génial !
je vais bientôt l'installer, mais est-il compatible avec les sites distants ? ( vidéos sur un autre FTP, si oui y-a-t-il d'autres modifs de fichiers à faire ?? )
et la validité html est-elle conservée ??

merci @+


http://www.pikkitux.com des tutoriaux sur Ubuntu/Linux, l'informatique en général, la création web ...
ainsi que des photos de mes potes et moi jouant au street hockey, au lycée ...

Hors ligne

#3 2006-01-07 09:54:34

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: [1.5.x] Video Integrator 2.1

CHUCKYCHUCK a écrit:

est-il compatible avec les sites distants ? ( vidéos sur un autre FTP, si oui y-a-t-il d'autres modifs de fichiers à faire ?? )

Lui est compatible, ton hébergeur distant peut être pas, c'est un coup à ce faire fermer son compte.
Coté gestion via un site distant de PWG, je t'avoue ne pas avoir encore essayé.
Il faut bien entendu modifier create_listing_file.php pour lui faire prendre en compte les extensions mais je ne suis pas certain que cela suffise.

CHUCKYCHUCK a écrit:

La validité html est-elle conservée ??

Si tu veux dire par là, est-ce que les normes du W3C sont respectées: Oui, pour la partie VI.
Il reste cependant encore quelques broutilles dans le code de PWG, mais les pages sont valides.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#4 2006-01-07 12:29:09

CHUCKYCHUCK
Membre
2005-09-25
19

Re: [1.5.x] Video Integrator 2.1

bon je l'ai installé ca marche nickel même avec les sites distants,
il faut par contre faire une petite modif au fichier createlisting, situé dans /tools :

remplacer

Code:

// $conf['file_ext'] lists all extensions (case insensitive) allowed for
// your PhpWebGallery installation
$conf['file_ext'] = array('jpg','JPG','png','PNG','gif','GIF','mpg','zip',
                          'avi','mp3','ogg','mov');

// $conf['picture_ext'] must be a subset of $conf['file_ext']
$conf['picture_ext'] = array('jpg','JPG','png','PNG','gif','GIF');

Code:

// file_ext : file extensions (case sensitive) authorized

$conf['file_ext'] = array('jpg','JPG','png','PNG','gif','GIF','mpg','MPG','zip',

                          'avi','AVI','mp3','ogg','wmv','WMV','mov','MOV','swf','SWF');



// picture_ext : file extensions for picture file, must be a subset of

// file_ext

$conf['picture_ext'] = array('jpg','JPG','png','PNG','gif','GIF');



// movie_ext : file extensions for movie file, must be a subset of

// file_ext

$conf['movie_ext'] = array('avi','AVI','mpg','MPG','wmv','WMV');

// qtime_ext : file extensions for QuickTime file, must be a subset of

// file_ext 

$conf['qtime_ext'] = array('mov','MOV');

// flash_ext : file extensions for flash movie file, must be a subset of

// file_ext 

$conf['flash_ext'] = array('swf','SWF');

par contre le code html que tu donnes pour insérer les vidéos n'est pas valide html4 ... ( j'ai validé les exemples que tu donnais dans l'autre post, ainsi que sur mon install ), c'est pas vraiment génant en soi, mais si vous voulez absolument garder votre 0 fautes au W3C validator, voici comment intégrer de manière valide html, fonctionne sur tout les OS :
http://forum.alsacreations.com/faq/#item51
( pour le mov ), pour les autres formats j'ai pas de liens sorry :s


un autre petit truc, lors de la modification de fichier config local php, pour ceux qui le crée pour la 1ère fois, ne pas oublier de mettre les tags php ( <?php ?> )

@+

Dernière modification par CHUCKYCHUCK (2006-01-07 12:35:31)


http://www.pikkitux.com des tutoriaux sur Ubuntu/Linux, l'informatique en général, la création web ...
ainsi que des photos de mes potes et moi jouant au street hockey, au lycée ...

Hors ligne

#5 2006-01-07 14:03:25

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: [1.5.x] Video Integrator 2.1

CHUCKYCHUCK a écrit:

par contre le code html que tu donnes pour insérer les vidéos n'est pas valide html4 ... ( j'ai validé les exemples que tu donnais dans l'autre post, ainsi que sur mon install ), c'est pas vraiment génant en soi, mais si vous voulez absolument garder votre 0 fautes au W3C validator, voici comment intégrer de manière valide html, fonctionne sur tout les OS :
http://forum.alsacreations.com/faq/#item51
( pour le mov ), pour les autres formats j'ai pas de liens sorry :s

J'avais bien vu... Sauf qu'il me semble bien qu'embed est obligatoire pour certains navigateurs...
Et c'est embed qui crée le bazar dans les css et le reste. Tant que certains navigateurs continueront à s'appuyer sur cette balise...
A tel point que pour Flash, il est documenté que l'embed n'est plus obligatoire chez Macromedia, et pourtant les tests ont démontré qu'avec certaines versions de navigateurs, on n'obtient qu'une belle fenêtre noire. Et il en va de même avec Quicktime.
Je vais essayer la proposition d'alsacreations dans les prochains jours,
mais je l'avais vue et elle ne respecte pas non plus les indications d'Apple.
Alors que choisir? La norme... ?

8-(


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#6 2006-01-07 14:06:16

volcom
Former Piwigo Team
2005-01-24
489

Re: [1.5.x] Video Integrator 2.1

(vous comprenez la nécessité du respect des standards par TOUS les navigateurs maintenant ? :D je sais je suis lourd!)

Hors ligne

#7 2006-01-07 15:22:19

CHUCKYCHUCK
Membre
2005-09-25
19

Re: [1.5.x] Video Integrator 2.1

bon la méthode d'alsacréations marche sous windows, linux, avec quicktime, mplayer-plug-in, et est valide html, que demander de mieux :)


http://www.pikkitux.com des tutoriaux sur Ubuntu/Linux, l'informatique en général, la création web ...
ainsi que des photos de mes potes et moi jouant au street hockey, au lycée ...

Hors ligne

#8 2006-01-07 19:52:52

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: [1.5.x] Video Integrator 2.1

CHUCKYCHUCK a écrit:

bon la méthode d'alsacréations marche sous windows, linux, avec quicktime, mplayer-plug-in, et est valide html, que demander de mieux :)

Que demander de mieux?
Oui, que ça marche avec Firefox, sous Opera ça marche, mais pas sous mon Firefox (dernière version).
Très étrange. Je vais tenter d'autres solutions paramètres.

Ton aide aurait été précieuse pendant les tests, proposer d'autres techniques après la sortie, ce n'est pas terrible.
Bref, je vais passer encore deux ou trois jours à tester encore Quicktime
(que je considère guère meilleur aujourd'hui que sa version 2, et très loin d'être digne d'Apple).

Merci quand même. 8-)


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#9 2006-01-08 12:20:03

CHUCKYCHUCK
Membre
2005-09-25
19

Re: [1.5.x] Video Integrator 2.1

Vdigital a écrit:

Ton aide aurait été précieuse pendant les tests, proposer d'autres techniques après la sortie, ce n'est pas terrible.

désolé j'ai vraiment pas beaucoup de temps en ce moment ( classe prépas, en plus j'ai un nombre limité d'heures sur mon PC :s ( ahh les mères ))

mais si jamais tu as besoin de tests sous linux, n'hésites pas

bye


http://www.pikkitux.com des tutoriaux sur Ubuntu/Linux, l'informatique en général, la création web ...
ainsi que des photos de mes potes et moi jouant au street hockey, au lycée ...

Hors ligne

#10 2006-01-09 07:51:32

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: [1.5.x] Video Integrator 2.1

Voici ce qui est écrit sur le forum d'Apple (A noter que la question portait bien sur embed et la conformité stricte HTML):

Le forum d'Apple a écrit:

The embed tag is for older browsers that do not
support the W3 specification for the <object> tag
which is the now most supported and recommended option
for embedding QTVR. For example as of IE5.5 SP2, the
embed tag is no longer supported at all, yet Netscape
6 still can use it....

Typically you use both by nesting them. Browsers that
can use the <object> tag will ignore the <embed> and
older browsers that don't use the <object> tag will
use the <embed> and ignore the <object>. The most
simplest version of this combined structure should
look something like this (Apple also recommends this):

<OBJECT
CLASSID="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B"
CODEBASE="http://www.apple.com/qtactivex/qtplugin.cab";
WIDTH="xx" HEIGHT="yy">
<PARAM NAME="src" VALUE="my.mov">
<EMBED SRC="my.mov" height="yy" width="xx"></EMBED>
</OBJECT>

Hope this helps :)

Ils disent bien "For example as of IE5.5 SP2, the embed tag is no longer supported at all, yet Netscape 6 still can use it....." et vous notez qu'ils ne parlent pas des normes du W3C...

Alsacréations n'a peut être pas testé les mêmes cas que moi. Je confirme que les browsers de la Netscape family ont besoin de "embed" comme le dit Apple, pour gérer le lecteur Quicktime correctement. (Exception: Opera qui arrive à traiter sans l'embed).
La norme refuse "embed", je vais sans doute revenir sur le TPL pour si possible en éliminer et ainsi me rapprocher de la norme.
Il est donc normal que Video Integrator reste un MOD.

Une idée: Pourquoi Alsacréations ne propose pas une video exemple pour montrer que sa solution marche???

A suivre, car je contitnue de chercher la solution.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#11 2006-01-09 20:56:51

CHUCKYCHUCK
Membre
2005-09-25
19

Re: [1.5.x] Video Integrator 2.1

je viens de tester la méthode alsacréations avec le pc familial sous xp ( moi je suis sous ubuntu linux avec mplayer plug-in ), j'ai un bug qui fait planter IE avec certaines des vidéos mais pas d'autres ... ( pourtant elle est moins volumineuse ... )

si ca t'intéresse je peux faire quelques tests ( le week-end qui vient au plus tôt ) dis-moi quels couples OS/browser tu voudrais tester (j'ai windows 2000 pro qui tourne dans VMWare :D )

à bientôt


http://www.pikkitux.com des tutoriaux sur Ubuntu/Linux, l'informatique en général, la création web ...
ainsi que des photos de mes potes et moi jouant au street hockey, au lycée ...

Hors ligne

#12 2006-01-09 21:31:02

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: [1.5.x] Video Integrator 2.1

L'OS ne doit (ne devrait) rien changer  en réalité (ce n'est en fait pas si vrai que cela, les w2k et XP Pro sont moins tolérants avec les vidéos).
Ce qui doit être testé: c'est des vidéos de toutes sortes avec différents plugins et le maximum de browsers (en différentes versions).

(Belle machine t'as combien de mémoire la-dessus?)


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#13 2006-01-11 19:10:35

CHUCKYCHUCK
Membre
2005-09-25
19

Re: [1.5.x] Video Integrator 2.1

j'ai 512 de ram, mais j'évite de lancer de grosse applis pendant que vmware tourne :)
bon je ferais des tests avec firefox 1.5, 1.0.7, IE 6, Opera 8.5 avec quicktime 7 / mplayerplug-in 3.17
pour les 2 méthodes qu'on a mentionnés au dessus ( la "officielle", et la valide xhtml )
tu as un lien qui montre La méthode officielle d'apple ? j'ai trouvé une page sur le site d'apple mais elle ne parle que des tags embed et object je crois ( il y a aussi les exemples du site apple/trailers mais bon )

je te filerais les résultats ce week-end

bye


http://www.pikkitux.com des tutoriaux sur Ubuntu/Linux, l'informatique en général, la création web ...
ainsi que des photos de mes potes et moi jouant au street hockey, au lycée ...

Hors ligne

#14 2006-01-11 21:50:27

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: [1.5.x] Video Integrator 2.1

CHUCKYCHUCK a écrit:

j'ai 512 de ram, mais j'évite de lancer de grosse applis pendant que vmware tourne :)
bon je ferais des tests avec firefox 1.5, 1.0.7, IE 6, Opera 8.5 avec quicktime 7 / mplayerplug-in 3.17
pour les 2 méthodes qu'on a mentionnés au dessus ( la "officielle", et la valide xhtml )
tu as un lien qui montre La méthode officielle d'apple ? j'ai trouvé une page sur le site d'apple mais elle ne parle que des tags embed et object je crois ( il y a aussi les exemples du site apple/trailers mais bon )

je te filerais les résultats ce week-end

bye

La seule page de référence pour moi est:
HTML Scripting Guide for QuickTime > HTML Scripting > QuickTime <EMBED> and <OBJECT> Parameters
Dsl. sans Embed à priori ils ne savent pas faire. Bien sûr que ça marche avec certains navigateurs sans embed mais il y a des exceptions d'où l'embed, et au final non conformité W3C. Je continue mes tests de temps à autres mais à mon avis il n'y a pas de solution miracle.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#15 2006-01-13 17:09:16

Rmk
Invité

Re: [1.5.x] Video Integrator 2.1

J'ai un ptit souci (décidémment, c'est pas ma pèriode), quan dje clique sur ma catégorie "videos", j'ai l'erreur suivante qui apparit:

Code:

"Parse error: parse error, unexpected '}' in /var/www/free.fr/b/f/rmk57140/iufm/include/template.php(159) : eval()'d code on line 72"

je suis allé faire un tour du coté de template.php , ligne 72 et voila ce que j elis:

Code:

 /**
   * Destroys this template object. Should be called when you're done with
   * it, in order to clear out the template data so you can load/parse a new
   * template set.
   */
  function destroy()
    {
      $this->_tpldata = array();
    }

faut il modifier quelquechose de spécial ?

  •  » Plugins
  •  » [1.5.x] Video Integrator 2.1

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact