Annonce

  •  » Utilisation
  •  » Affichage de photos ne s'effectue plus

#1 2023-10-11 15:19:21

elvenezolano
Membre
2023-10-11
3

Affichage de photos ne s'effectue plus

Bonjour

Je suis confronté à un problème d'affichage que je ne parviens pas à résoudre seul. En quelques mots, j'ai installé Piwigo sur mon serveur Ubuntu. Lorsque j'importe des photos dans un répertoire, elle s'affichent bien dans la visioneuse à la première demande. Mais lorsque je clique sur une miniature pour l'afficher, j'obtiens un écran vide avec seulement le nom du fichier. Et si je reviens dans la visioneuse, toutes les photos ont disparu excepté le nom du fichier.

C'est ma première utilisation de Piwigo. Si quelqu'un pouvait me donner une piste de recherche, ce serait super.
Merci par avance

Version de Piwigo: 13.8.0
Version de PHP: 8.1
Version de MySQL: 8.0.34
URL Piwigo: https://galerie.hoteperso.fr

Hors ligne

#2 2023-10-11 15:35:25

Katryne
Membre
Le Revest-les-Eaux (Provence)
2016-12-03
1690

Re: Affichage de photos ne s'effectue plus

Je pense que c'est le nom des fichiers d'image qui pose problème. C'est normal que tu vois la miniature. Mais sur le web, le nom d'un fichier doit comporter exclusivement des chiffres et des lettres, pas d'espace, et pas de caractère spécial sauf les tirets - et _ Donc pas de point avant le dernier qui précède l'extension.

Ex d'un de tes noms de fichiers : 2009.11.14 03.07.39 : il faut remplacer ces points et l'espace (ya un espace entre 14 et 03) par un des tirets. Il va falloir renommer toutes ces images avant de les mettre sur le site. Certains logiciels de bureau permettent  de faire des renommages en masse, avec des remplacements de caractères. Moi j'utilise xnview pour cela.

Dernière modification par Katryne (2023-10-11 15:35:50)


https://album.chauvigne.info/ v.13.8.0  PHP: 8.2.17
http://photos.katrynou.fr/ ou https://balades.comoni.org/ (c'est le même) v.14.4.0 PHP: 8.1.22
Système d'exploitation: Linux - Hébergeur 1&1-Ionos - MySQL: 5.7.42
Bibliothèque graphique: External ImageMagick 6.9.11-60

Hors ligne

#3 2023-10-13 09:57:06

elvenezolano
Membre
2023-10-11
3

Re: Affichage de photos ne s'effectue plus

Merci pour la réponse, mais ça n'a pas réglé le problème. J'ai renommé mes fichiers sous la forme aaa-mm-jj_hh-mm-ss et les ai importés dans piwigo. Quand je me connecte sur ma galerie, j'ai bien l'affichage des photos. Quand je clique sur une pour la visionner, elle ne s'affiche pas, j'ai juste le nom du fichier. Et si je retourne sur la page précédente, je n'ai plus aucun affichage.
Je ne comprends pas du tout ce qui se passe. Est-ce un problème d'installation de l'appli, peut-être au niveau de php? Je pense avoir installé tous les modules pourtant.
merci d'avance pour l'aide que vous pourrez m'apporter.

Hors ligne

#4 2023-10-13 11:54:43

Katryne
Membre
Le Revest-les-Eaux (Provence)
2016-12-03
1690

Re: Affichage de photos ne s'effectue plus

Elles ont quelle extension les photos ? .jpg ? .png ?


https://album.chauvigne.info/ v.13.8.0  PHP: 8.2.17
http://photos.katrynou.fr/ ou https://balades.comoni.org/ (c'est le même) v.14.4.0 PHP: 8.1.22
Système d'exploitation: Linux - Hébergeur 1&1-Ionos - MySQL: 5.7.42
Bibliothèque graphique: External ImageMagick 6.9.11-60

Hors ligne

#5 2023-10-14 08:44:06

elvenezolano
Membre
2023-10-11
3

Re: Affichage de photos ne s'effectue plus

Bonjour, toutes mes photos sont  avec l'extension jpg.

Hors ligne

#6 2023-10-14 08:52:42

Katryne
Membre
Le Revest-les-Eaux (Provence)
2016-12-03
1690

Re: Affichage de photos ne s'effectue plus

Je peux télécharger tes photos, une à une, et donc les voir sur mon ordi, mais pas les visualiser dans le Piwigo. C'est étrange !
Essaye de changer de thème, des fois que .... Mais c'est peut-être aussi une histoire de config de ton serveur, auquel il manquerait des briques pour l'affichage. Je ne peux rien te dire de plus, je n'y connais rien en auto-hébergement.


https://album.chauvigne.info/ v.13.8.0  PHP: 8.2.17
http://photos.katrynou.fr/ ou https://balades.comoni.org/ (c'est le même) v.14.4.0 PHP: 8.1.22
Système d'exploitation: Linux - Hébergeur 1&1-Ionos - MySQL: 5.7.42
Bibliothèque graphique: External ImageMagick 6.9.11-60

Hors ligne

  •  » Utilisation
  •  » Affichage de photos ne s'effectue plus

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2024 · Contact