Annonce

  •  » Utilisation
  •  » Où peut-on voir les versions de PHP compatibles avec Piwigo ?

#1 2022-12-27 16:49:46

oliverfr
Membre
2013-04-27
184

Où peut-on voir les versions de PHP compatibles avec Piwigo ?

Bonjour,

J'ai testé pour voir ce qu'il se passerait si mon serveur passait en php 8.2, et ça a généré un peu de soucis avec piwigo, soucis certes mineurs, rien n'est cassé, c'est juste une pluie d'avertissements pour future obsolescence

Deprecated: Creation of dynamic property Smarty_Internal_Template::$compiled is deprecated in  (...)include/smarty/libs/sysplugins/smarty_internal_template.php on line 719

Concernant nombre de lignes piwigo.

Googler m'a montré qu'on peut demander à piwigo de ne pas afficher ce genre de messages ( $conf['show_php_errors'] = E_ALL & ~E_DEPRECATED & ~E_NOTICE & ~E_WARNING; en local config - https://piwigo.org/forum/viewtopic.php?id=31875 ).

Mais ça m'a fait me demander autre chose, parce que ça, je n'ai pas trouvé en googlant.

S'il vous plaît, quelqu'un sait-il où, sur le site de piwigo, serait-il fait mention de quelles versions de PHP sont officiellement compatibles, et avec quelles versions de piwigo ? Merci beaucoup !

Dernière modification par oliverfr (2022-12-27 16:50:40)

Hors ligne

#2 2022-12-28 00:22:45

k5
Équipe Piwigo
La reppe
2014-01-26
1350

Re: Où peut-on voir les versions de PHP compatibles avec Piwigo ?

Bonjour,
c'est marqué entre presque chaque release la compatibilité php.

https://fr.piwigo.org/historique-versions  -----> voir en détails

par exemple piwigo version 1 ---> php 4
piwigo version 2 ----> php 4 voire 5
etc...

A très vite


Piwigo 14.4 VM alpneLinux php 8.4
Piwigo 14.4 php 8.4 -- 8.4 mysql -- ImageMagick 7.1.1.34

Hors ligne

#3 2022-12-28 14:50:16

oliverfr
Membre
2013-04-27
184

Re: Où peut-on voir les versions de PHP compatibles avec Piwigo ?

OK, merci !

Hors ligne

#4 2022-12-28 18:05:51

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12648

Re: Où peut-on voir les versions de PHP compatibles avec Piwigo ?

Autant je peux dire quelle est la version "minimale" de PHP requise selon la version de Piwigo :

Code:

$conf['required_php_versions_for'] = array(
  '12'   => '7.0',
  '2.10' => '5.3',
  '2.7'  => '5.2',
  '1.4'  => '5.0',
  '1.0'  => '4.0',
);

... autant il est difficile voire impossible de dire la version "maximale". Comment aurions-nous pu savoir en 2005 que la version 1.4 ne serait pas compatible avec PHP 8.2 ?

A l'heure actuelle, avec la version 13.4.0 de Piwigo, la version minimale de PHP est la 7.0 et la maximale "testée" est la 8.1.


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

  •  » Utilisation
  •  » Où peut-on voir les versions de PHP compatibles avec Piwigo ?

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2024 · Contact