Annonce

  •  » Utilisation
  •  » [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

#1 2022-06-30 21:48:36

Katryne
Membre
Le Revest-les-Eaux (Provence)
2016-12-03
1709

[Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Bonsoir,
Sur mon piwigo en construction, j'avais 5 beaux pdf, là : https://album.chauvigne.info/index?/cat … -documents

Je mets à jour le Piwigo par la technique automatique depuis l'admin. Et les plugins aussi. Et les thèmes aussi. Et mes pdf m'offrent désormais une page blanche. Bien sûr que ça marchait avant ...

Enfin, pas tout-à-fait une page blanche, si on affiche les messages d'erreur :

Code:

Fatal error: Uncaught Error: Call to a member function is_cached() on null in /homepages/18/xxx/htdocs/album/_data/templates_c/jt3r05^be02402700200b71db73595aedb79fcb12f968c3_0.file.picture_contentKat.tpl.php:24 Stack trace: #0 /homepages/18/xxx/htdocs/album/include/smarty/libs/sysplugins/smarty_template_resource_base.php(123): content_62bdfd45030436_52540079(Object(Smarty_Internal_Template)) #1 /homepages/18/xxx/htdocs/album/include/smarty/libs/sysplugins/smarty_template_compiled.php(114): Smarty_Template_Resource_Base->getRenderedTemplateCode(Object(Smarty_Internal_Template)) #2 /homepages/18/xxx/htdocs/album/include/smarty/libs/sysplugins/smarty_internal_template.php(216): Smarty_Template_Compiled->render(Object(Smarty_Internal_Template)) #3 /homepages/18/xxx/htdocs/album/include/smarty/libs/sysplugins/smarty_internal_templatebase.php(232): Smarty_Internal_Template->render(false, 0) #4 /homepages/18/xxx/htdocs/album/include/smarty/libs/sysplugins/smarty_internal_templatebase.ph in /homepages/18/xxx/htdocs/album/_data/templates_c/jt3r05^be02402700200b71db73595aedb79fcb12f968c3_0.file.picture_contentKat.tpl.php on line 24

Que dois-je vérifier, s'il vous plait ?


https://album.chauvigne.info/ v.13.8.0  PHP: 8.2.17
http://photos.katrynou.fr/ ou https://balades.comoni.org/ (c'est le même) v.14.4.0 PHP: 8.1.22
Système d'exploitation: Linux - Hébergeur 1&1-Ionos - MySQL: 5.7.42
Bibliothèque graphique: External ImageMagick 6.9.11-60

Hors ligne

#2 2022-06-30 22:18:18

Katryne
Membre
Le Revest-les-Eaux (Provence)
2016-12-03
1709

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

La même chose m'était arrivé en avril avec Piwigo 12.2. Ça s'était réglé je ne sais comment  : https://fr.piwigo.org/forum/viewtopic.php?id=29648


https://album.chauvigne.info/ v.13.8.0  PHP: 8.2.17
http://photos.katrynou.fr/ ou https://balades.comoni.org/ (c'est le même) v.14.4.0 PHP: 8.1.22
Système d'exploitation: Linux - Hébergeur 1&1-Ionos - MySQL: 5.7.42
Bibliothèque graphique: External ImageMagick 6.9.11-60

Hors ligne

#3 2022-06-30 22:59:47

Katryne
Membre
Le Revest-les-Eaux (Provence)
2016-12-03
1709

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

C'est réglé : c'était dû à une template extension pour l'ancienne version de Bootstrap Darkroom. Je n'arrive pas à refaire la nouvelle pour le moment, mais au moins mes pdf sont accessibles.


https://album.chauvigne.info/ v.13.8.0  PHP: 8.2.17
http://photos.katrynou.fr/ ou https://balades.comoni.org/ (c'est le même) v.14.4.0 PHP: 8.1.22
Système d'exploitation: Linux - Hébergeur 1&1-Ionos - MySQL: 5.7.42
Bibliothèque graphique: External ImageMagick 6.9.11-60

Hors ligne

#4 2022-06-30 23:32:19

Katryne
Membre
Le Revest-les-Eaux (Provence)
2016-12-03
1709

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Je reviens sur ma Template extension :

Il s'agit de picture_content.tpl de Bootstrap Darkroom.
Je ne veux pas d'infobulle au survol de l'image, parce que c'est très laid toute cette description qui s'affiche par-dessus l'image et inutile puisque le texte est en-dessous.
Donc, en template-extention, à la fin de la ligne 24, je supprime l'affichage de la description en ne laissant que title"">

C'était OK dans les versions précédentes de Piwigo et du thème, mais si j'active la TE, même mise à jour dans la nouvelle version du thème, ça m'affiche ce méchant message d'horreur qui cause de smarty et de template compilé.

A tout hasard, je purge les templates compilés, mais ça fait pas avancer le schmilblik.

Qui pourrait m'aider, siouplait ?


https://album.chauvigne.info/ v.13.8.0  PHP: 8.2.17
http://photos.katrynou.fr/ ou https://balades.comoni.org/ (c'est le même) v.14.4.0 PHP: 8.1.22
Système d'exploitation: Linux - Hébergeur 1&1-Ionos - MySQL: 5.7.42
Bibliothèque graphique: External ImageMagick 6.9.11-60

Hors ligne

#5 2022-07-01 20:07:52

polowigo
Membre
2019-04-11
143

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Bonsoir Katryne,

Peux-tu redonner ta ligne 24 s'il te plaît ?

Hors ligne

#6 2022-07-01 20:25:51

Katryne
Membre
Le Revest-les-Eaux (Provence)
2016-12-03
1709

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Bonjour ami Polowigo

Je viens de remettre la version de Bootstrap de ma sauvegarde, pour vérifier si ça vient du thème ou du Piwigo. Et c'est pareil, si je modifie par TE le fichier picture_content.tpl pour vider le contenu de title, afin de ne rien avoir au survol, c'est bon pour les images, mais les pdf affichent un message d'erreur.

Ligne 24 originale :

Code:

<img {if $current.selected_derivative->is_cached()}src="{$current.selected_derivative->get_url()}" {$current.selected_derivative->get_size_htm()}{else}src="{$ROOT_URL}themes/bootstrap_darkroom/img/transparent.png" data-src="{$current.selected_derivative->get_url()}"{/if} alt="{$ALT_IMG}" id="theMainImage" usemap="#map{$current.selected_derivative->get_type()}" title="{if isset($COMMENT_IMG)}{$COMMENT_IMG|@strip_tags:false|@replace:'"':' '}{else}{$current.TITLE_ESC} - {$ALT_IMG}{/if}">

Ligne 24 modifiée par TE :

Code:

<img {if $current.selected_derivative->is_cached()}src="{$current.selected_derivative->get_url()}" {$current.selected_derivative->get_size_htm()}{else}src="{$ROOT_URL}themes/bootstrap_darkroom/img/transparent.png" data-src="{$current.selected_derivative->get_url()}"{/if} alt="{$ALT_IMG}" id="theMainImage" usemap="#map{$current.selected_derivative->get_type()}" title="">

Message d'erreur en affichage des pdf :

Code:

Fatal error: Uncaught Error: Call to a member function is_cached() on null in /homepages/18/d149996993/htdocs/album/_data/templates_c/jt3r05^be02402700200b71db73595aedb79fcb12f968c3_0.file.picture_contentKat.tpl.php:24 Stack trace: #0 /homepages/18/d149996993/htdocs/album/include/smarty/libs/sysplugins/smarty_template_resource_base.php(123): content_62bf345ca336a0_04916561(Object(Smarty_Internal_Template)) #1 /homepages/18/d149996993/htdocs/album/include/smarty/libs/sysplugins/smarty_template_compiled.php(114): Smarty_Template_Resource_Base->getRenderedTemplateCode(Object(Smarty_Internal_Template)) #2 /homepages/18/d149996993/htdocs/album/include/smarty/libs/sysplugins/smarty_internal_template.php(216): Smarty_Template_Compiled->render(Object(Smarty_Internal_Template)) #3 /homepages/18/d149996993/htdocs/album/include/smarty/libs/sysplugins/smarty_internal_templatebase.php(232): Smarty_Internal_Template->render(false, 0) #4 /homepages/18/d149996993/htdocs/album/include/smarty/libs/sysplugins/smarty_internal_templatebase.ph in /homepages/18/d149996993/htdocs/album/_data/templates_c/jt3r05^be02402700200b71db73595aedb79fcb12f968c3_0.file.picture_contentKat.tpl.php on line 24

Album avec des pdf et des images : https://album.chauvigne.info/index?/cat … -documents


https://album.chauvigne.info/ v.13.8.0  PHP: 8.2.17
http://photos.katrynou.fr/ ou https://balades.comoni.org/ (c'est le même) v.14.4.0 PHP: 8.1.22
Système d'exploitation: Linux - Hébergeur 1&1-Ionos - MySQL: 5.7.42
Bibliothèque graphique: External ImageMagick 6.9.11-60

Hors ligne

#7 2022-07-01 20:36:10

polowigo
Membre
2019-04-11
143

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Là comme ça je ne vois pas. Il faudrait que je teste en local la mise à jour manuelle pour tenter de déterminer ce qui cloche.

Hors ligne

#8 2022-07-03 20:09:22

polowigo
Membre
2019-04-11
143

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Bonsoir,

Pour l'instant, je n'ai pas réussi à reproduire ce comportement mais je n'ai pas utilisé la méthode manuelle ni encore appliqué tous les changements du dossier 12.x_to_12.3.0, seulement ceux qui me semblaient les plus importants.

Quoi qu'il en soit, les fichiers de smarty demeurent inchangés.

À tout hasard, as-tu essayé de désactiver tous tes plugins et tes autres T-E, histoire que rien n'interfère ?

Hors ligne

#9 2022-07-03 20:39:18

Katryne
Membre
Le Revest-les-Eaux (Provence)
2016-12-03
1709

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Coucou !
En désactivant les autres TE, c'est pareil, je les ai réactivées.
Pour les plugins, j'ai pas trop le courage, là, de suite : j'en ai 61 dont 43 activés. Faut que je me motive pour tester toussa et retrouver mes petits. Merci de ta ... compassion !


https://album.chauvigne.info/ v.13.8.0  PHP: 8.2.17
http://photos.katrynou.fr/ ou https://balades.comoni.org/ (c'est le même) v.14.4.0 PHP: 8.1.22
Système d'exploitation: Linux - Hébergeur 1&1-Ionos - MySQL: 5.7.42
Bibliothèque graphique: External ImageMagick 6.9.11-60

Hors ligne

#10 2022-07-04 14:08:33

polowigo
Membre
2019-04-11
143

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Bonjour,

C'est de la compassion... intéressée puisque nous avons à peu près les mêmes configurations et besoins.

Je vois une autre façon de procéder, même si ce n'est pas forcément plus simple ni plus approprié : si tu en a la possibilité, ce serait d'installer une 12.3.0 neuve de test, d'envoyer un pdf, de vérifier le résultat puis de mettre en place ta TE spéciale info-bulles. Et ensuite, activer un à un tes vingt cinq mille plugins.

Hors ligne

#11 2022-07-04 22:40:36

polowigo
Membre
2019-04-11
143

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Bonsoir,

De mon côté, j'ai fini de passer toutes les modifications sur un site local. Rien de neuf : je n'ai toujours pas de page blanche, ma couverture de pdf est toujours bien affichée.
Donc pas de souci côté core.

Restent donc soit les tweaks de ton côté, soit la procédure de mise-à-jour automatique mais je n'y crois guère.

Hors ligne

#12 2022-07-04 23:01:36

Katryne
Membre
Le Revest-les-Eaux (Provence)
2016-12-03
1709

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Bon, je vais installer un piwigo neuf, demain, je m'y mets. (j'espère que je vais mieux respecter cette auto-promesse que pour le vélo ou le régime).


https://album.chauvigne.info/ v.13.8.0  PHP: 8.2.17
http://photos.katrynou.fr/ ou https://balades.comoni.org/ (c'est le même) v.14.4.0 PHP: 8.1.22
Système d'exploitation: Linux - Hébergeur 1&1-Ionos - MySQL: 5.7.42
Bibliothèque graphique: External ImageMagick 6.9.11-60

Hors ligne

#13 2022-07-05 21:31:19

polowigo
Membre
2019-04-11
143

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Bonsoir Katryne,

Je viens de trouver une sacrée différence entre ton site et le mien : à partir de la page https://album.chauvigne.info/index?/cat … documents, j'affiche la carte d'Afrique correctement.
Mais depuis cette carte, quand je clique sur "suivant" (flèche droite ou zone droite de l'image), je me prends le Uncaught Error dans les dents.
En effet, à cet endroit, le lien pointe vers https://album.chauvigne.info/_data/i/up … 99x300.png alors que depuis la page album, le lien correct est https://album.chauvigne.info/picture?/a … -documents

Il y a donc bien du tripatouillage de contrebande par là.

Hors ligne

#14 2022-07-05 21:43:45

Katryne
Membre
Le Revest-les-Eaux (Provence)
2016-12-03
1709

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Je trouve pas pareil que toi.
Que ce soit à partir de l'image de la carte avec les flèches suivant/précédent, ou à partir de l'album, j'ai bien des liens qui se terminent par "category/8-documents" au survol de la souris.
Et bien sûr on se prend le méchant Fatal error ... dans la tronche, parce que les 2 éléments qui encadrent la carte sont des pdf.

J'ai pas encore pu tester une install neuve aujourd'hui.


https://album.chauvigne.info/ v.13.8.0  PHP: 8.2.17
http://photos.katrynou.fr/ ou https://balades.comoni.org/ (c'est le même) v.14.4.0 PHP: 8.1.22
Système d'exploitation: Linux - Hébergeur 1&1-Ionos - MySQL: 5.7.42
Bibliothèque graphique: External ImageMagick 6.9.11-60

Hors ligne

#15 2022-07-05 21:48:16

polowigo
Membre
2019-04-11
143

Re: [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

C'est fou ça, les liens ont changé !

Hors ligne

  •  » Utilisation
  •  » [Résolu] v. 12.3.0 en install automatique : mes pdf ne s'affichent plus

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2024 · Contact