Annonce

#1 2022-04-19 09:46:02

Etche52
Membre
2022-04-19
4

Impossible d'activer les plugins

Bonjour,
lorsque j'essaie d'activer des plugins, j'ai le message "x une erreur est survenue", y compris pour les plugins qui sont fournis dans piwigo lors de l'installation.
Piwigo 12.2.0
Système d'exploitation: Linux
PHP: 7.4.28 (Montrer les informations) [2022-04-19 07:44:03]
MySQL: 5.7.37-cll-lve [2022-04-19 09:44:03]
Bibliothèque graphique: External ImageMagick 6.9.10-68

J'ai tout supprimé sur mon site et fait une nouvelle installation, le problème persiste.
Pouvez-vous m'aider ? merci par avance,

Hors ligne

#2 2022-04-19 13:15:03

k5
Équipe Piwigo
La reppe
2014-01-26
889

Re: Impossible d'activer les plugins

Bonjour,
Il s'agit peut-être de droit de repertoire et de sous répertoire. Lecture, écriture et suppression ... ?
Sur quel hébergeur est installé Piwigo ?
A très vite


Beta test sur Github Codespaces !!!

Hors ligne

#3 2022-04-19 20:02:37

Etche52
Membre
2022-04-19
4

Re: Impossible d'activer les plugins

bonjour, mon hébergeur est Wantete.
En fait, il y a environ 1 an, j'ai pu activer des plugins notamment communauty pour donner les droits d'ajouts de photos à des utilisateurs
.Puis, il y a eu le changement de version de piwigo, je l'ai fait mais ai juste regardé les albums photos depuis.
Et hier, j'ai voulu (ré-)activer les plugins qui avaient tous été désactivés lors du changement de version (admin tools, communauty).
Je me suis demandé s'il y avait un lien avec le passage de piwigo à la version 12. J'ai créé un nouveau sous-domaine et ai procédé à une nouvelle installation, en partant de zéro,
et je me retrouve avec le même problème, les 4 plugins fournis dans les fichiers d'installation de piwigo sont désactivés, et impossible de les activer.

Hors ligne

#4 2022-04-20 05:17:28

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16179

Re: Impossible d'activer les plugins

Bonjour

Une erreur JS dans le navigateur ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2022-04-20 20:55:18

Etche52
Membre
2022-04-19
4

Re: Impossible d'activer les plugins

bonjour, j'utilise Firefox et j'ai fait l'essai avec Konqueror le navigateur internet de KDE. le message d'erreur est le même.

Hors ligne

#6 2022-04-21 00:59:21

k5
Équipe Piwigo
La reppe
2014-01-26
889

Re: Impossible d'activer les plugins

Bonjour,
je dirais d'essayer de forcer l'activation des plugins a partir de la base de donnee mysql.
Pour cela, dans phpmyadmin "piwigo_plugins", si vous voyez "inactive" vous pouvez modifier en "active".

Ce que @ddtddt voulait expliquer, c'est quand vous etes sur firefox sur votre gallerie piwigo? d'essayer de cliquer sur f12 et ce que ca donne comme erreur.

La difference entre la 11.5 et 12 est qu'il y a maintenant dans la base de donne en plus "piwigo_lounge".

A tres vite
k5


Beta test sur Github Codespaces !!!

Hors ligne

#7 2022-04-21 21:41:48

Etche52
Membre
2022-04-19
4

Re: Impossible d'activer les plugins

Bonjour, j'ai regardé avec phpmyadmin la table piwigo_plugins et c'est étonnant, mais elle est vide. J'ai donc supprimé tous les fichiers du répertoire plugins, Puis j'ai installé admin tools depuis piwigo, la table reste vide bien que le plugin apparaisse dans la liste des plugins. (piwigo_lounge aussi est vide)
En ce qui concerne Firefox, j'ai fait F12 après avoir eu le message d'erreur et voici ce qui apparaît dans la console :
INS: content-ads.js loaded:  https://galerie.rando52.org/admin.php?page=plugins content-scripts.js:1:3495
TSS: content-tss.js loaded:  https://galerie.rando52.org/admin.php?page=plugins content-scripts.js:1:12602
INS: content-blocked-items.js loaded:  https://galerie.rando52.org/admin.php?page=plugins content-scripts.js:1:31594
La mise en page a été forcée avant le chargement complet de la page. Si les feuilles de style ne sont pas encore chargées, cela peut provoquer un flash de contenu non stylisé. contentInject.js:5251:17
TSS: hosted page injected admin.php:4:21
Le cookie « pwg_plugin_manager_view » sera bientôt rejeté car son attribut « SameSite » est défini sur « None » ou une valeur invalide et il n’a pas l’attribut « secure ». Pour en savoir plus sur l’attribut « SameSite », consultez https://developer.mozilla.org/docs/Web/ … e/SameSite t315ui.js:145:244
Object { readyState: 4, getResponseHeader: getResponseHeader(a), getAllResponseHeaders: getAllResponseHeaders(), setRequestHeader: setRequestHeader(a, b), overrideMimeType: overrideMimeType(a), statusCode: statusCode(a), abort: abort(a), state: state(), always: always(), then: then()
, … }
t315ui.js:57:541
It didn't work

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact