Annonce

#1 2021-12-13 22:53:46

guiyou65
Membre
2010-01-16
35

[Résolu] Plus d'accès Admin

Bonsoir,

J'ai activé le plugin SmartAlbums et depuis l'accès admin est bloqué sur la même page d'erreur :


Code:

Warning:  [mysql error 1104] The SELECT would examine more than MAX_JOIN_SIZE rows; check your WHERE and use SET SQL_BIG_SELECTS=1 or SET MAX_JOIN_SIZE=# if the SELECT is okay

SELECT
    id
  FROM pwg_images
    LEFT JOIN pwg_image_category ON id = image_id
  WHERE category_id is null
  ORDER BY id ASC
; in /flex/storage/guiyou.fr/site/album/include/dblayer/functions_mysqli.inc.php on line 847


Fatal error: Uncaught Error: Call to a member function fetch_assoc() on bool in /flex/storage/guiyou.fr/site/album/include/dblayer/functions_mysqli.inc.php:908 Stack trace: #0 /flex/storage/guiyou.fr/site/album/admin/include/functions.php(3292): query2array('\nSELECT\n id\n...', NULL, 'id') #1 /flex/storage/guiyou.fr/site/album/admin.php(263): get_orphans() #2 {main} thrown in /flex/storage/guiyou.fr/site/album/include/dblayer/functions_mysqli.inc.php on line 908

J'ai essayé de désinstaller le plugin fautif en effaçant le répertoire. Aucun effet.
Je comprends en recherchant sur internet qu'il faudrait changer une valeur de configuration SQL. Mais je n'ai pas accès à ces configuration avec mon hébergement. Par ailleurs cela fonctionnait très bien avant l'installation de SmartAlbums. Et depuis fort longtemps (plus de 10 ans !)

Il a sans doute une solution mais je ne la trouve pas :(

C'est la deuxième fois que ça m'arrive depuis le passage à la dernière version de Piwigo. La fois précédente, il y a même pas 2 mois, faute de trouver une solution j'ai reinstallé tout le site 'from scratch' (~ 20000 photos !). J'aimerais bien ne pas avoir à recommencer. C'est très lourd. Merci d'avance pour votre aide.

Version de Piwigo: 12.1
Version de PHP: 7.3
Version de MySQL:
URL Piwigo: https://album.guiyou.fr

Hors ligne

#2 2021-12-13 23:26:54

guiyou65
Membre
2010-01-16
35

Re: [Résolu] Plus d'accès Admin

J'ai résolu le problème grâce à Patrice :
https://fr.piwigo.org/forum/viewtopic.p … 29#p231029

L'ajout des lignes :
// Envoie la commande SET SQL_BIG_SELECTS=1
  pwg_query("SET SQL_BIG_SELECTS=1");

dans functions_mysqli.inc.php ligne 62 a réglé le problème.

Cependant il serait bon d'intégrer la solution dans le code d'origine ou de permettre son activation par une option.

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact