Annonce

#1 2021-10-03 11:31:54

itallweb09
Membre
Paris
2021-10-01
11

Osm

Bonjour/Bonsoir,

Suite à upgrade 11.5

La carte OSM ne s'affiche plus sur les pages d'une image.
Seul le lien apparaît "voir dans OpenStreetMap"

Si quelqu'un a résolu ce problème....
Merci

Version de Piwigo: 11.5
Version de PHP: 5.6.40
Version de MySQL: MariaDB  5.5.57
URL Piwigo: local

Hors ligne

#2 2021-10-03 14:39:21

Katryne
Membre
Provence
2016-12-03
1172

Re: Osm

Hello !
je voulais faire tourner mon Piwigo en local. Ça marchait sauf les liens externes ET les cartes OSM, qui sont distantes, bien sûr. Est-ce le même souci ?


https://photos.revestou.fr/  v.12.2 - https://dardennes.revestou.fr/ v.11.5 - http://photos.katrynou.fr/ v.11.5 https://album.chauvigne.info/ v.12.2
Système d'exploitation: Linux - Hébergeur 1&1-Ionos PHP: 7.4.29 - MySQL: 5.7.38
Bibliothèque graphique: External ImageMagick 6.9.10-23

Hors ligne

#3 2021-10-03 15:05:59

itallweb09
Membre
Paris
2021-10-01
11

Re: Osm

non je ne crois pas
l'affichage de la carte OSM  sur la page photo unique marchait parfaitement en local avant que je n'effectue la MAJ 11.5.
Maintenant je n'ai plus qu'un lien "voir dans OpenStreetMap" à la place de la carte (si je clique sur le lien pas de problème, la localisation est bien présente & correcte). Je préférerais une intégration dans la page directement  comme auparavant.
S'il y a une solution....

Dernière modification par itallweb09 (2021-10-03 15:06:29)

Hors ligne

#4 2021-10-03 16:12:07

Katryne
Membre
Provence
2016-12-03
1172

Re: Osm

Revois bien ta config du plugin, car pour moi, OSM marche bien sur mes 5 Piwigos.


https://photos.revestou.fr/  v.12.2 - https://dardennes.revestou.fr/ v.11.5 - http://photos.katrynou.fr/ v.11.5 https://album.chauvigne.info/ v.12.2
Système d'exploitation: Linux - Hébergeur 1&1-Ionos PHP: 7.4.29 - MySQL: 5.7.38
Bibliothèque graphique: External ImageMagick 6.9.10-23

Hors ligne

#5 2021-10-03 17:51:36

JPD
Membre
Sud Bourgogne
2012-06-29
113

Re: Osm

bonsoir,
Même chose pour moi, depuis la mise à jour plus d'affichage de carte, seulement un lien dans la page photo. Je n'ai trouvé aucune solution pour l'instant si ce n'est d'arrêter les mises à jour que ne n'avais pas encore faites :mad en attendant un lifting du plugin.


Piwigo :12.2.0
PHP : 7.4.27
MySQL : 10.2.41-MariaDB
External ImageMagick 6.9.10.68

Hors ligne

#6 2021-10-03 19:58:55

Katryne
Membre
Provence
2016-12-03
1172

Re: Osm

Je me répète, désolée : quand on fait une mise à jour, tous les plugins sont désactivés et pour OSM, il faut refaire toute la config. Chaque fois, j'ai oublié de noter et je ne retombe sur mes pattes qu’après plusieurs essais.

Par ailleurs, vous avez en commun une BDD Maria DB, alors que j'ai MySQL.

Sur tous mes sites, 11.5 ou béta 12, les cartes OSM sont affichées.


https://photos.revestou.fr/  v.12.2 - https://dardennes.revestou.fr/ v.11.5 - http://photos.katrynou.fr/ v.11.5 https://album.chauvigne.info/ v.12.2
Système d'exploitation: Linux - Hébergeur 1&1-Ionos PHP: 7.4.29 - MySQL: 5.7.38
Bibliothèque graphique: External ImageMagick 6.9.10-23

Hors ligne

#7 2021-10-03 20:26:05

itallweb09
Membre
Paris
2021-10-01
11

Re: Osm

- configuration identique via des captures d'écran prises avant la MAJ donc piste éliminée
- Maria/MySQL - à voir ! quoique j'étais en MAriaDB sous 2.10 et ça marchait
- par contre, pb non lié au PHP  puisque en v7.3 je lis même problème (je suis en 5.6.40)

si d'autres retours...

Hors ligne

#8 2021-10-03 21:12:20

JPD
Membre
Sud Bourgogne
2012-06-29
113

Re: Osm

Non, non je confirme la config du plugin est bonne. J'ai testé plusieurs versions de PHP sans différence. Pour ce qui est de la DB je n'y peux rien (hébergement mutualisé), mais cela fonctionnait très bien avant la mise à jour.
Dreamer avait déjà indiqué ce problème : https://fr.piwigo.org/forum/viewtopic.php?id=29181
Sur une installation neuve ça fonctionne mais pas sur un site qui a migré de nombreuses fois. Ce n'est pas la première fois que j'ai des soucis avec les cartes OSM, mais des précédentes mises à jour les avaient résolues.


Piwigo :12.2.0
PHP : 7.4.27
MySQL : 10.2.41-MariaDB
External ImageMagick 6.9.10.68

Hors ligne

#9 2021-10-04 00:32:29

itallweb09
Membre
Paris
2021-10-01
11

Re: Osm

Migré càd  de version en version ?

ce que je trouve curieux, c'est que l'affichage d'une carte ne marche pas que sur  la page photo unique ??? pour ma part ...

Dernière modification par itallweb09 (2021-10-04 00:34:28)

Hors ligne

#10 2021-10-04 07:51:06

JPD
Membre
Sud Bourgogne
2012-06-29
113

Re: Osm

Bonjour,
Oui migration depuis des versions anciennes, au fils du temps,  jusqu'à l'actuelle.
Et oui aussi, c'est uniquement la carte sur la page photo qui ne s'affiche pas. Tout le reste est normal :)
Bonne journée.


Piwigo :12.2.0
PHP : 7.4.27
MySQL : 10.2.41-MariaDB
External ImageMagick 6.9.10.68

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact