Annonce

#1 2021-03-03 13:12:03

JMMO59
Membre
2021-01-30
28

synchro et tags

Bonjour,

Je suis en train de reconstruire "from scratch" ma photothèque suite à une perte des photos.
Grâce à plusieurs conseils pertinents, j'ai pu le faire en utilisant la synchro (moyennant en effet quelques subtilités pour le nommage des répertoires, problèmes d'accents, d'espaces, etc...)
Mais je viens de m'apercevoir que mes photos pourtant toutes tagguées avant upload/synchro, ne sont pas taguées dans piwigo. En clair, avant la RAZ de la base j'avais 455 tags, ils sont toujours là mais mes photos ne se recalent pas par rapport aux tags que je leur ai ajoutés avant l'upload/synchro...
Je suis sûr que j'ai loupé qq chose...
Merci de vos conseils

Piwigo 11.3.0
Système d'exploitation: Linux
PHP: 7.3.19-1~deb10u1
MySQL: 5.5.5-10.3.27-MariaDB-0+deb10u1
Bibliothèque graphique: GD 2.2.5

Hors ligne

#2 2021-03-03 13:23:58

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
15665

Re: synchro et tags

Bonjour,

Il faut mettre à jour la configuration local pour que les tag soient synchronisé

https://fr.piwigo.org/doc/doku.php?id=u … meta&s[]=iptc


donc un truc du genre

$conf['use_iptc'] = true;

$conf['use_iptc_mapping'] = array(
'keywords'        => '2#025',
'author'          => '2#122',
'name'            => '2#105',
'comment'         => '2#120'
);


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2021-03-03 19:01:31

JMMO59
Membre
2021-01-30
28

Re: synchro et tags

Impec. Merci pour cette info. Je commence à comprendre la logique du fichier config locale...

D'ailleurs, du coup, j'ai un autre problème. Sur 13500 photos rechargées, 10500 n'ont pas le code somme.
J'ai lu plusieurs choses dans les posts sur ce forum (correction d'un fichier avec des "]" manquants, purge des templates compilées, découplage JS/CSS etc... Et j'ai tout fait comme indiqué.
Avant j'avait une erreur 200 au bout d'un certain temps. Depuis mes modifs, il ne se passe plus rien quand je clique sur le lien qui est sencé relancer le calcul des 10500 codes sommes manquants...

Une idée peut-être?
Merci

Hors ligne

#4 2021-03-03 21:23:15

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
15665

Re: synchro et tags

Bonjour,

Les données se mette à jour si les champs sont vides


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#5 2021-03-04 08:21:12

JMMO59
Membre
2021-01-30
28

Re: synchro et tags

Ca veut dire qu'il faut que je mettre à vide les champs checksum des 10500 photos pour ensuite pouvoir les regénérer?
c'est curieux car s'il me dit que 10500 des 13000 photo ont un checksum manquant, c'est donc que ces 10500 ont le champ ad'hoc vide non? donc pourquoi ne regénère-t-il pas ceux là?
J'essaie de comprendre....

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2021 · Contact