Annonce

  •  » Installation
  •  » Erreur Admin > Utilisateurs > Groupes - Suite passage v11

#1 2021-01-28 13:56:09

tomdieu
Membre
2006-07-05
55

Erreur Admin > Utilisateurs > Groupes - Suite passage v11

Bonjour/Bonsoir,

Suite au passage à la v11.1.0 sur les 2 sites sous piwigo que j'héberge chez o2switch, j'ai le même problème.

Dans l'admin > Utilisateurs > Groupes , le message d'erreur suivant s'affiche systématiquement :

Sur http://www.kiki-et-domi.com/

Fatal error: Uncaught TypeError: Argument 3 passed to Smarty_Internal_Runtime_FilterHandler::runFilter() must be an instance of Smarty_Internal_Template, null given, called in /home/tbalay/sites/kiki-et-domi/include/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 429 and defined in /home/tbalay/sites/kiki-et-domi/include/smarty/libs/sysplugins/smarty_internal_runtime_filterhandler.php:33 Stack trace: #0 /home/tbalay/sites/kiki-et-domi/include/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php(429): Smarty_Internal_Runtime_FilterHandler->runFilter('post', '<?php\n/* smarty...', NULL) #1 /home/tbalay/sites/kiki-et-domi/include/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php(330): Smarty_Internal_TemplateCompilerBase->postFilter('<?php\n/* smarty...') #2 /home/tbalay/sites/kiki-et-domi/include/smarty/libs/sysplugins/smarty_template_compiled.php(236): Smarty_Internal_TemplateCompilerBase->compileTemplate(Object(Smarty_Internal_Template)) #3 /home/tbalay/sites/kiki-et-domi/i in /home/tbalay/sites/kiki-et-domi/include/smarty/libs/sysplugins/smarty_internal_runtime_filterhandler.php on line 33

Sur http://photos.balayley.fr/

Fatal error: Uncaught TypeError: Argument 3 passed to Smarty_Internal_Runtime_FilterHandler::runFilter() must be an instance of Smarty_Internal_Template, null given, called in /home/tbalay/public_html/photos/include/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 429 and defined in /home/tbalay/public_html/photos/include/smarty/libs/sysplugins/smarty_internal_runtime_filterhandler.php:33 Stack trace: #0 /home/tbalay/public_html/photos/include/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php(429): Smarty_Internal_Runtime_FilterHandler->runFilter('post', '<?php\n/* smarty...', NULL) #1 /home/tbalay/public_html/photos/include/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php(330): Smarty_Internal_TemplateCompilerBase->postFilter('<?php\n/* smarty...') #2 /home/tbalay/public_html/photos/include/smarty/libs/sysplugins/smarty_template_compiled.php(236): Smarty_Internal_TemplateCompilerBase->compileTemplate(Object(Smarty_Internal_Template)) #3 /home/tbalay/public_html/photos/i in /home/tbalay/public_html/photos/include/smarty/libs/sysplugins/smarty_internal_runtime_filterhandler.php on line 33

Version de Piwigo: 11.1.0
Version de PHP: 7.3.6
Version de MySQL: 10.3.27-MariaDB - MariaDB Server / cpsrvd 11.92.0.9 /  libmysql - 5.6.43

J'ai essagé de désactiver tout les plugins, ça n'a rien changé...

Merci d'avance pour votre aide!

Hors ligne

#2 2021-02-01 10:26:49

tomdieu
Membre
2006-07-05
55

Re: Erreur Admin > Utilisateurs > Groupes - Suite passage v11

Je suis le seul à avoir ce problème?

Hors ligne

#3 2021-02-01 11:00:20

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12512

Re: Erreur Admin > Utilisateurs > Groupes - Suite passage v11

Je n'ai pas eu d'autres retour sur ce bug en effet. Cela ne veut pas dire qu'il n'y pas de soucis à corriger. Mais sans reproduire ce bug, difficile à corriger.


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#4 2021-02-01 11:46:34

tomdieu
Membre
2006-07-05
55

Re: Erreur Admin > Utilisateurs > Groupes - Suite passage v11

Merci pour la réponse. Sur les 2 sites cités, ce bug est systématique et donc reproduisible à volonté ;-)

Hors ligne

#5 2021-02-01 15:05:20

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12512

Re: Erreur Admin > Utilisateurs > Groupes - Suite passage v11

Moi je ne le reproduis pas, c'est ce que je voulais dire. Mais je te demanderai peut-être un accès à ton environnement d'execution de Piwigo pour mieux comprendre.


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#6 2021-02-01 15:29:29

tomdieu
Membre
2006-07-05
55

Re: Erreur Admin > Utilisateurs > Groupes - Suite passage v11

ok, merci.

Hors ligne

#7 2021-02-01 18:50:45

tomdieu
Membre
2006-07-05
55

Re: Erreur Admin > Utilisateurs > Groupes - Suite passage v11

Petite info complémentaire (dont je viens de me rendre compte), ce n'est "que" la liste des groupes qui provoque un message d'erreur ( /admin.php?page=group_list ). La page permettant de gérer les permissions d'un groupe fonctionne (il faut juste connaître l'id du groupe à gérer ) : /admin.php?page=group_perm&group_id=1

Hors ligne

  •  » Installation
  •  » Erreur Admin > Utilisateurs > Groupes - Suite passage v11

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2021 · Contact