Annonce

  •  » Plugins
  •  » [Résolu] Extended description: problème avec les balises.

#1 2014-02-04 16:00:58

Gilles
Membre
Brie Comte Robert
2007-01-19
30

[Résolu] Extended description: problème avec les balises.

Bonjour.
J'ai un petit problème depuis ma migration sous PWG 2.6 (version très belle par ailleurs!) Le plugin Extended description (mis à jour, et compatible, d'après la page de ses développeurs)ne fonctionne plus bien.
Les balises de langue [lang=xx] fonctionnent bien, mais les balises de description étendue (du type <!--more--> ou <!--up-down--> ou <!--complete-->) ne fonctionnent plus bien: lorsque l'une de ces dernières est utilisée, la description ne s'affiche pas du tout sur la page d'accueil des galeries, alors que ça marche tout-à-fait bien sur la page des miniatures de chaque galerie.
Testé: lorsque je fais sauter le tag, tout fonctionne à nouveau. Testé avec plusieurs thèmes, le dysfonctionnement est reproduit quel que soit le thème.
Merci de votre aide!
Gilles

Hors ligne

#2 2014-02-04 16:07:22

patfrwar
Membre
Tours
2011-05-24
164

Re: [Résolu] Extended description: problème avec les balises.

bonjour

Question bête, as tu mis à jours le plugin ?
ce dernier est maintenant en version :
Extended Description --> Révision 2.6.0 (2014-01-28)

sur ma galerie j'ai pas de soucis et je suis en piwigo 2.6.1
cdlt

Hors ligne

#3 2014-02-04 16:15:50

Gilles
Membre
Brie Comte Robert
2007-01-19
30

Re: [Résolu] Extended description: problème avec les balises.

Merci de ta réponse rapide. Oui, tous les plugins que j'utilise ont été mis à jour lors de ma migration sur 2.6 (je viens de le vérifier).
Amicalement, Gilles

Hors ligne

#4 2014-02-05 10:03:32

Gilles
Membre
Brie Comte Robert
2007-01-19
30

Re: [Résolu] Extended description: problème avec les balises.

Désolé d'insister, un petit up ce matin... Quelqu'un aurait une idée de solution? Merci d'avance!
Gilles

Gilles a écrit:

Bonjour.
J'ai un petit problème depuis ma migration sous PWG 2.6 (version très belle par ailleurs!) Le plugin Extended description (mis à jour, et compatible, d'après la page de ses développeurs)ne fonctionne plus bien.
Les balises de langue [lang=xx] fonctionnent bien, mais les balises de description étendue (du type <!--more--> ou <!--up-down--> ou <!--complete-->) ne fonctionnent plus bien: lorsque l'une de ces dernières est utilisée, la description ne s'affiche pas du tout sur la page d'accueil des galeries, alors que ça marche tout-à-fait bien sur la page des miniatures de chaque galerie.
Testé: lorsque je fais sauter le tag, tout fonctionne à nouveau. Testé avec plusieurs thèmes, le dysfonctionnement est reproduit quel que soit le thème.
Merci de votre aide!
Gilles

Hors ligne

#5 2014-02-05 13:20:43

patfrwar
Membre
Tours
2011-05-24
164

Re: [Résolu] Extended description: problème avec les balises.

Bonjour

comme tu le vois dans le code et dans ma copie d'écran j'utilise : exended description sur mes Pages d'albums et je ne rencontre aucun soucis ma galerie est basée sur le thème stripped

Code:

Séjour sur l'île de Berder dans le golfe du Morbihan<!--complete--> 
<div style="margin-top: 10px; margin-bottom: 10px; text-align: center">
  <div class="cat_des_GT"><h1> Les Photos souvenir du séjour sur l'île de Berder<br> durant la semaine du 05 au 12 Mai 2013</h1></div>

cdlt


Images attachées

Hors ligne

#6 2014-02-05 14:37:40

Gilles
Membre
Brie Comte Robert
2007-01-19
30

Re: [Résolu] Extended description: problème avec les balises.

Bonjour, et merci de ton temps! Mon problème survient dès que j'utilise les balises 'étendues' (du type <!--more--> ou équivalent): dès que j'en place une (syntaxe vérifiée) (capture d'écran 1), le commentaire n'apparaît pas du tout sur la page de présentation des galeries (capture d'écran 2), mais apparaît bien (avec la balise correctement éxécutée) sur la page de la galerie capture d'écran 3),.
Si je fais sauter cette balise, l'affichage se fait correctement (mais trop long pour les miniatures de la page de présentation, ce qui est disgracieux, d'où ma question!). Les balises de langue sont correctement éxécutées, ainsi que le code html inséré.
Amicalement,
Gilles


Images attachées

Hors ligne

#7 2014-02-05 15:16:17

patfrwar
Membre
Tours
2011-05-24
164

Re: [Résolu] Extended description: problème avec les balises.

re

en fait maintenant ca me reviens c'est vrai que  <!--more--> je ne l'utilise pas car ca ne fonctionnait pas meme avec la version 2.5

j'utilise uniquement <!--complete--> et <!--up-down-->

désolé je ne peu pas d'aider plus

cdlt

Hors ligne

#8 2014-02-05 16:02:03

flop25
Équipe Piwigo
2006-07-06
6477

Re: [Résolu] Extended description: problème avec les balises.

question noob: c'est quoi la diff entre complete et mroe ?

Hors ligne

#9 2014-02-05 16:20:21

Gilles
Membre
Brie Comte Robert
2007-01-19
30

Re: [Résolu] Extended description: problème avec les balises.

Bonjour.
<!--more--> permet l'affichage de la description d'une galerie (p.ex.) de 2 façons différentes:
- Tout ce qui est avant la balise s'affiche sur la page d'accueil des galeries (ça permet de faire court), mais l'ensemble (avant <!--more-->  et après) s'affiche sur la page de la galerie en question.
<!--complete--> : la partie avant la balise s'affiche sur la page d'accueil des galeries, et seule la partie située après la balise s'affiche sur la page de la galerie en question.
Ces balises permettent une mise en page soigneuse, mais elles semblent ne pas fonctionner sous la version 2.6.1 de Piwigo (la version la plus récente du plugin est pourtant censée être compatible).
Gilles

Hors ligne

#10 2014-02-05 16:22:08

flop25
Équipe Piwigo
2006-07-06
6477

Re: [Résolu] Extended description: problème avec les balises.

si complete marche, alors ça peut faire la mm chose que more

Hors ligne

#11 2014-02-05 16:23:36

Gilles
Membre
Brie Comte Robert
2007-01-19
30

Re: [Résolu] Extended description: problème avec les balises.

non, aucune des balises testées (more, complete, up-down) ne marche!

Hors ligne

#12 2014-02-05 16:30:39

flop25
Équipe Piwigo
2006-07-06
6477

Re: [Résolu] Extended description: problème avec les balises.

ce n'est pas vraiment ce que dit patfrwar

Hors ligne

#13 2014-02-05 16:32:43

Gilles
Membre
Brie Comte Robert
2007-01-19
30

Re: [Résolu] Extended description: problème avec les balises.

... et pourtant c'est ce qui se passe chez moi!

Hors ligne

#14 2014-02-06 21:21:28

mistic100
Ex Equipe Piwigo
Lyon
2008-09-27
3556

Re: [Résolu] Extended description: problème avec les balises.

je confirme
ça doit venir des mes récents changements (ED 2.6.0)

edit : corrigé en 2.6.1

Dernière modification par mistic100 (2014-02-06 21:26:44)

Hors ligne

#15 2014-02-07 06:20:50

Gilles
Membre
Brie Comte Robert
2007-01-19
30

Re: [Résolu] Extended description: problème avec les balises.

mistic100 a écrit:

je confirme
ça doit venir des mes récents changements (ED 2.6.0)

edit : corrigé en 2.6.1

Merci de la réponse. Y a-t-il quelque chose que je puisse faire pour y remédier?  Dans le cas contraire, est-il possible que je re-migre en v. 5.x? Merci.
Gilles

Hors ligne

  •  » Plugins
  •  » [Résolu] Extended description: problème avec les balises.

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2020 · Contact