Annonce

  •  » Installation
  •  » Passage à la version 2.6.0 puis 2.6.1 message d'erreur

#1 2014-01-18 23:12:42

pcharra
Membre
Soyons
2012-04-08
42

Passage à la version 2.6.0 puis 2.6.1 message d'erreur

Bonjour à tous

Merci pour cette nouvelle version.

La mise à jour automatique vers la version 2.6 s'est bien déroulée et ça a l'air de fonctionner à une exception près, de temps en temps j'ai les messages d'erreur suivants

Notice: Undefined index: nb_categories in /homez.149/charra/www/phpwebgallery/include/functions_category.inc.php on line 542

Notice: Undefined index: count_images in /homez.149/charra/www/phpwebgallery/include/functions_category.inc.php on line 546

Notice: Undefined index: count_categories in /homez.149/charra/www/phpwebgallery/include/functions_category.inc.php on line 547


J'ai fait une réparation/optimisation de la base de donnée via l'administration. Mais le problème demeure.

Merci d'avance pour votre aide.

Cordialement
Patrick Charra

Dernière modification par pcharra (2014-02-04 11:31:04)


Version de Piwigo: 13.1.0
Version de PHP: 7.4.25
Version de MySQL: 5.7.40-log [2022-11-04 12:11:07]
URL Piwigo: https://photos.charra.net

Hors ligne

#2 2014-01-18 23:13:42

flop25
Équipe Piwigo
2006-07-06
6544

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

Bonjour
Renvoyez les fichiers par Ftp et écrasant ceux existant

Hors ligne

#3 2014-01-20 09:20:55

pcharra
Membre
Soyons
2012-04-08
42

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

flop25 a écrit:

Bonjour
Renvoyez les fichiers par Ftp et écrasant ceux existant

Merci pour la suggestion.

En fait comme la mise à jour  automatique s'était bien déroulée sans aucun message d'erreur, j'ai préféré attendre avant de renvoyer les fichiers par FTP.

Les messages d'erreurs sont apparus encore un peu de manière sporadique, puis ne se sont plus manifestés à partir du lendemain sans aucune intervention de ma part malgré une utilisation assez intense de Piwigo.
Je me demande si ce n'était pas tout bêtement un problème de cache (côté serveur, car j'avais effacé celui du navigateur), sous réserve que ces messages ne réapparaissent pas soudainement....


Version de Piwigo: 13.1.0
Version de PHP: 7.4.25
Version de MySQL: 5.7.40-log [2022-11-04 12:11:07]
URL Piwigo: https://photos.charra.net

Hors ligne

#4 2014-02-04 11:16:37

pcharra
Membre
Soyons
2012-04-08
42

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

Bonjour à tous.

Je pensais le problème résolu et en fait non.
Je venais de migrer automatiquement en 2.6.0 lorsque le pb est apparu.
Quand il est réapparu j'ai renvoyé tous les fichiers par ftp. Le problème persiste.
Je suis passé en 2.6.1 par migration automatique. Le problème persiste toujours.

Mais j'ai mieux cerné le problème.

Ces messages d'erreur

Notice: Undefined index: nb_categories in /homez.149/charra/www/phpwebgallery/include/functions_category.inc.php on line 542

Notice: Undefined index: count_images in /homez.149/charra/www/phpwebgallery/include/functions_category.inc.php on line 546

Notice: Undefined index: count_categories in /homez.149/charra/www/phpwebgallery/include/functions_category.inc.php on line 547

apparaissent systématiquement lors de la première consultation d'un album quelconque après une mise à jour
quelconque via l'administration (ajout de nouvelles photos, modification d'une seule photo, ou modification de l'ordre des photos). Dès lors que j'enregistre une modification, même minime, ces messages apparaissent lors de la 1ère consultation d'un album quelconque. Ensuite il n'apparaissent plus jusqu'à l'enregistrement d'une nouvelle modification.

Je suis sur un hébergement mutualité "pro" OVH,
        Système d'exploitation: Linux
        PHP: 5.4.23 (Montrer les informations) [2014-02-04 11:09:36]
        MySQL: 5.1.66-0+squeeze1-log [2014-02-04 11:09:36]
        Bibliothèque graphique: External ImageMagick 6.6.0-4

Base de données
        16910 photos (première photo ajoutée le Samedi 20 Mai 2006)
        618 albums dont 0 physique et 618 virtuels (21480 associations)
        355 tags (42037 associations)
        55 utilisateurs
        5 groupes


Version de Piwigo: 13.1.0
Version de PHP: 7.4.25
Version de MySQL: 5.7.40-log [2022-11-04 12:11:07]
URL Piwigo: https://photos.charra.net

Hors ligne

#5 2014-02-04 11:35:04

flop25
Équipe Piwigo
2006-07-06
6544

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

si vous utilisez le plugin multi view pour voir le problème avec d'autres comptes utilisateurs, ça le fait aussi ?

je pense que ça vient du cache utilisateur, car ces compteurs sont mis en cache

Hors ligne

#6 2014-02-04 18:41:16

pcharra
Membre
Soyons
2012-04-08
42

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

flop25 a écrit:

si vous utilisez le plugin multi view pour voir le problème avec d'autres comptes utilisateurs, ça le fait aussi ?
.../...

Oui, et les messages d'erreur s'affichent alors dans la fenêtre pop-up "Controller" du plugin quand on sélectionne un utilisateur la première fois après une modification. Si on sélectionne ensuite un autre utilisateur les messages ne s'affichent plus, ils ne s'affichent plus également si on revient au premier utilisateur.
Curieux....


Version de Piwigo: 13.1.0
Version de PHP: 7.4.25
Version de MySQL: 5.7.40-log [2022-11-04 12:11:07]
URL Piwigo: https://photos.charra.net

Hors ligne

#7 2014-02-04 21:17:44

flop25
Équipe Piwigo
2006-07-06
6544

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

j'ai notifié plg
toutes vos erreurs ressemblent à des pb de cache

Hors ligne

#8 2014-02-05 11:32:54

pcharra
Membre
Soyons
2012-04-08
42

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

flop25 a écrit:

j'ai notifié plg
toutes vos erreurs ressemblent à des pb de cache

OK, merci pour votre aide.


Version de Piwigo: 13.1.0
Version de PHP: 7.4.25
Version de MySQL: 5.7.40-log [2022-11-04 12:11:07]
URL Piwigo: https://photos.charra.net

Hors ligne

#9 2014-02-06 12:00:35

blad00x
Membre
2014-02-06
3

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

J'ai exactement le même problème après une installation "à neuf" de la version 2.6.1 de piwigo

Hors ligne

#10 2014-02-06 12:37:39

rvelices
Équipe Piwigo
2005-12-29
1417

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

Pouvez-vous installer le plugin rv_db_integrity et lancer un check dans la page admin / maintenance ?
S'il y a une incoherence dans la base, ca sortira ...

Hors ligne

#11 2014-02-06 13:25:30

blad00x
Membre
2014-02-06
3

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

voila j'ai installé le plugin et fais Réparer et optimiser la base de données mais sa n'as rien fait

Hors ligne

#12 2014-02-07 11:12:09

pcharra
Membre
Soyons
2012-04-08
42

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

rvelices a écrit:

Pouvez-vous installer le plugin rv_db_integrity et lancer un check dans la page admin / maintenance ?
S'il y a une incoherence dans la base, ca sortira ...

Bonjour
Voilà ce que j'obtiens (j'ai fait auparavant "Réinitialiser les contrôles d'intégrité" et "Réparer et optimiser la base de données")


Test     Resultat
#phpwebgallery_images.id (7 references)     Passés
#phpwebgallery_categories.id (7 references)     1 FAILED
1 error references; #phpwebgallery_user_cache_categories.cat_id referring to #phpwebgallery_categories.id
#phpwebgallery_tags.id (1 references)     1 FAILED
1 error references; #phpwebgallery_image_tag.tag_id referring to #phpwebgallery_tags.id
#phpwebgallery_groups.id (2 references)     Passés
Liens permanents (1 references)     Passés
#images(id,storage_category_id) dans #image_category (1 references)     Passés

Comment puis-je corriger ?

Merci d'avance...


Version de Piwigo: 13.1.0
Version de PHP: 7.4.25
Version de MySQL: 5.7.40-log [2022-11-04 12:11:07]
URL Piwigo: https://photos.charra.net

Hors ligne

#13 2014-02-07 20:09:19

rvelices
Équipe Piwigo
2005-12-29
1417

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

pour la premiere erreur,:
- allez dans Admin Maintenance / Update Album Information
- aller une fois sur la page publique
- refaire db_integrity

Si l'erreur persiste, c'est encore tres tres bizarre - il faut nous lister tous les plugins utilisées.

Hors ligne

#14 2014-02-07 20:31:33

pcharra
Membre
Soyons
2012-04-08
42

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

rvelices a écrit:

pour la premiere erreur,:
- allez dans Admin Maintenance / Update Album Information
- aller une fois sur la page publique
- refaire db_integrity

Si l'erreur persiste, c'est encore tres tres bizarre - il faut nous lister tous les plugins utilisées.

L'erreur persiste

Test    Resultat
#phpwebgallery_images.id (7 references)     Passés
#phpwebgallery_categories.id (7 references)    1 FAILED
1 error references; #phpwebgallery_user_cache_categories.cat_id referring to #phpwebgallery_categories.id
#phpwebgallery_tags.id (1 references)    1 FAILED
1 error references; #phpwebgallery_image_tag.tag_id referring to #phpwebgallery_tags.id
#phpwebgallery_groups.id (2 references)     Passés
Liens permanents (1 references)     Passés
#images(id,storage_category_id) dans #image_category (1 references)     Passés

Plugins installés et activés
LocalFiles Editor
RV DB Integrity


Plugins installés mais désactivés
Check upgrades
Language Switch
Multi view

Voilà...


Version de Piwigo: 13.1.0
Version de PHP: 7.4.25
Version de MySQL: 5.7.40-log [2022-11-04 12:11:07]
URL Piwigo: https://photos.charra.net

Hors ligne

#15 2014-02-11 14:17:09

blad00x
Membre
2014-02-06
3

Re: Passage à la version 2.6.0 puis 2.6.1 message d'erreur

j'ai la même erreur et elle persiste j'ai fais tout comme vous avez dis... et tout sa après un installation à neuf sans aucun plugins suplementaire ou autre

Hors ligne

  •  » Installation
  •  » Passage à la version 2.6.0 puis 2.6.1 message d'erreur

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact