Annonce

  •  » Plugins
  •  » UserAdvManager: Utilisateur créé manuellement non confirmé

#1 2013-03-16 10:45:40

PhilippeWd
Membre
2012-08-26
51

UserAdvManager: Utilisateur créé manuellement non confirmé

Bonjour,
j'ai configuré la confirmation par l'admin (voir screenshot):

Confirmation d'inscription:
Activer - Confirmation par l'administrateur

Quand l'admin crée l'utilisateur (ce n'est donc l'utilisateur qui s'inscrit)
il reçoit un message d'inscription. OK.

Mais lorsqu'il essaie de se connecter il a l'indication qu'il est en attente de confirmation par l'admin ...

Je vois ici 2 problèmes.
1. Comme il a été créé par l'admin il devrait être confirmé par défaut.
2. Ayant configuré un groupe "Attente" "Pour les utilisateurs n'ayant pas confirmé leur inscription", je m'attendais à le trouver dans l'onglet "Suivi des confirmations" si je mettais manuellement cet utilisateur dans le groupe "Attente". Mais il n'apparaît pas. Je ne peux donc même pas le confirmer.

Je ne peux donc pas utiliser cet intéressant plugin parce que les utilisateurs existants ne peuvent plus se connecter. Dommage  :-)

Merci
Philippe

Hors ligne

#2 2013-03-16 11:58:19

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: UserAdvManager: Utilisateur créé manuellement non confirmé

Bonjour,

Quelle version du plugin utilisez-vous ? Sur quelle version de galerie ?

PhilippeWd a écrit:

Quand l'admin crée l'utilisateur (ce n'est donc l'utilisateur qui s'inscrit)
il reçoit un message d'inscription. OK.

Non, ce n'est pas le fonctionnement normal. Quand l'admin créé un utilisateur, ce n'est pas l'utilisateur qui s'inscrit donc celui-ci n'est pas sensé recevoir de message s'inscription sauf si l'option "Confirmation d'inscription pour les admins" est activée. Ce qui ne semble pas être le cas chez vous.

PhilippeWd a écrit:

1. Comme il a été créé par l'admin il devrait être confirmé par défaut.
2. Ayant configuré un groupe "Attente" "Pour les utilisateurs n'ayant pas confirmé leur inscription", je m'attendais à le trouver dans l'onglet "Suivi des confirmations" si je mettais manuellement cet utilisateur dans le groupe "Attente". Mais il n'apparaît pas. Je ne peux donc même pas le confirmer.

C'est justement parce que les utilisateurs créés par l'admin sont confirmés par défaut que vous ne voyez pas votre utilisateur dans le suivi des confirmations. Il devrait se trouver dans votre groupe "Amis" (à vérifier dans le gestionnaire d'utilisateurs).

Je vais tâcher de trouver un peu de temps pour étudier la question ce W-E.

Hors ligne

#3 2013-03-16 12:39:57

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: UserAdvManager: Utilisateur créé manuellement non confirmé

Re,

J'ai tenté de reproduire en adoptant vos réglages du plugin en version 2.50.2 (tout du moins ceux visibles dans votre capture) mais sans succès. Lorsque je créé en user depuis l'interface d'admin, l'utilisateur est bien confirmé par défaut et ne reçoit pas de mail de confirmation d'inscription.

Quels sont les autres plugins actifs sur votre galerie ?

Pourriez-vous effectuer une sauvegarde de votre configuration de UAM et me la transmettre par MP (envoyez-moi un premier MP, je vous y répondrai et vous pourrez m'envoyer le fichier) ?

Hors ligne

#4 2013-03-16 17:45:53

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: UserAdvManager: Utilisateur créé manuellement non confirmé

Bien reçu le fichier de configuration. J'ai identifié un petit problème de "confusion" dans le code du plugin dans un cas particulier. J'ai corrigé et mes tests semblent concluants.

Je vais poursuivre encore quelques tests mais une version corrective du plugin sera publiée sous peu.

Hors ligne

#5 2013-03-17 14:22:20

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: UserAdvManager: Utilisateur créé manuellement non confirmé

Bonjour,

La version 2.50.3 de UAM, publiée aujourd'hui, devrait améliorer le fonctionnement que vous attendez. Merci de me faire un retour sur la résolution de votre problème car, même avant ce correctif, je n'étais pas capable de le reproduire.

Hors ligne

#6 2013-03-17 17:40:53

PhilippeWd
Membre
2012-08-26
51

Re: UserAdvManager: Utilisateur créé manuellement non confirmé

Bonjour,
Cela semble fonctionner !
L'utilisateur qui ne se connectait pas hier arrive à se connecter maintenant.
J'ai vérifié qu'en supprimant et recréant  cet utilisateur il pouvait toujours se connecter.
Merci beaucoup !
Philippe

Hors ligne

#7 2013-03-18 22:12:59

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: UserAdvManager: Utilisateur créé manuellement non confirmé

Bonsoir,

Grâce à PhilippeWd, j'ai identifié un bug de UAM et corrigé dans la version 2.50.4.

En fait, il s'agit d'un cas de figure bien particulier où des informations n'étaient pas inscrites en base de données si la confirmation par les admins est activée et qu'un utilisateur est ajouté manuellement par un admin.

Hors ligne

#8 2013-03-20 18:22:12

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: UserAdvManager: Utilisateur créé manuellement non confirmé

Nouveau bug corrigé dans la version 2.50.5 : Une erreur Mysql apparaissait au moment de la validation manuelle d'un utilisateur dans l'onglet de suivi des confirmations.

@PhilippeWd : Merci de bien vouloir confirmer (ou pas) si tout est ok maintenant.

Hors ligne

#9 2013-03-20 20:25:56

PhilippeWd
Membre
2012-08-26
51

Re: UserAdvManager: Utilisateur créé manuellement non confirmé

Bonsoir,
j'ai refait les tests.
1. Création manuelle du user. Message d'erreur "New user Manuel.JPG"
Le user n'est pas confirmé et apparaît dans le suivi des confirmations. Il faut le confirmer manuellement. Ensuite c'est OK.
2. Le user s'enregistre. Message d'erreur furtif "User register.PNG".
Le user apparaît dans le suivi de confirmations (l'admin reçoit en se loggant un message destiné au user)
Confirmation manuelle OK.
3. Le user s'enregistre. Message d'erreur furtif "User register.PNG".
La confirmation par email fonctionne (mais l'admin un message destiné au user "Confirmation email par admin.JPG").
Globalement ça marche. Mais ... :-)
Merci
Philippe

PS je n'arrive pas à attacher "New User Manual.jpg" qui fait 67 Ko.

Dernière modification par PhilippeWd (2013-03-20 20:32:02)

Hors ligne

#10 2013-03-20 23:55:20

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: UserAdvManager: Utilisateur créé manuellement non confirmé

Je suis perplexe...

PhilippeWd a écrit:

1. Création manuelle du user. Message d'erreur "New user Manuel.JPG"
Le user n'est pas confirmé et apparaît dans le suivi des confirmations. Il faut le confirmer manuellement. Ensuite c'est OK.

Qu'il faille confirmer l'inscription d'un utilisateur créé manuellement alors qu'une option demandant précisément une confirmation d'inscription pour les utilisateurs ajoutés par un admin me parait être un fonctionnement tout à fait logique et normal...

PhilippeWd a écrit:

2. Le user s'enregistre. Message d'erreur furtif "User register.PNG".
Le user apparaît dans le suivi de confirmations (l'admin reçoit en se loggant un message destiné au user)
Confirmation manuelle OK.
3. Le user s'enregistre. Message d'erreur furtif "User register.PNG".
La confirmation par email fonctionne (mais l'admin un message destiné au user "Confirmation email par admin.JPG").

Le message affiché en bandeau est générique et modifiable à votre convenance dans le plugin. Si seul un admin est habilité à valider les inscriptions, il faut adapter les textes (mail et bandeau) en fonction du contexte attendu. On ne peut pas cumuler deux types de validations "par les admins" et "par les utilisateurs".

UAM est un plugin assez complexe et apportant un certain nombre de fonctionnalités. J'ai fait en sorte de simplifier au maximum l'interface bien que ce soit toujours perfectible. Si pas déjà vu/lu, je rappelle qu'il y a une documentation complète du plugin dans le wiki de Piwigo

Si vous ne parvenez pas à trouver les réglages que vous attendez, expliquez-les le plus clairement possible (actions menées -> Résultat attendu) pour que je puisse vous orienter ou faire évoluer le plugin si possible.



Pour le message d'erreur, cela n'a rien à voir avec UAM mais avec Free et ceci : [Forum, topic 23674] Modification mot de passe MD5 "toute seule" !

Hors ligne

#11 2013-03-21 17:49:44

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: UserAdvManager: Utilisateur créé manuellement non confirmé

Philippe, j'ai modifié la personnalisation des textes affichés par UAM lors de la confirmation d'inscription par un admin via le lien donné dans le mail de validation. Est-ce que cela correspond plus à ce que vous attendez ?

Quant à l'erreur sur "is_readable()" au moment de l'inscription proprement dite de l'utilisateur, toujours pas d'explications de la part de Free (j'ai posé la question sur le newsgroup de support des pages persos). Mais cela ne semble pas gêner plus que cela.
A tester : Un nouvel utilisateur inscrit et validé a-t-il la possibilité de se connecter à votre galerie ?

Hors ligne

#12 2013-03-21 21:31:33

PhilippeWd
Membre
2012-08-26
51

Re: UserAdvManager: Utilisateur créé manuellement non confirmé

Eric,
Merci pour votre patience.
Oui jusqu'à maintenant un utilisateur inscrit et validé a toujours pu se connecter à la galerie.
L'important est que l'utilisateur, parfois bien novice, soit bien accompagné dans ses actions. Et je pense qu'on y est.
Après nos avis divergent un peu mais cela reste du second ordre.
Merci encore à vous et à l'équipe Piwigo !
Philipppe

Hors ligne

  •  » Plugins
  •  » UserAdvManager: Utilisateur créé manuellement non confirmé

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact