•  » Installation
  •  » Erreur migration 2.4.3 vers 2.5 chez FREE

#1 2013-03-10 01:13:33

grenouille31
Membre
2013-03-10
2

Erreur migration 2.4.3 vers 2.5 chez FREE

Bonjour,
J'ai tenté à 2 reprises la migration manuelle de ma galerie de la 2.4.3 vers la 2.5 hébérgée chez FREE.
Lors des 2 tentatives, après le transfert FTP ds fichiers de la 2.5, je lance http://xxxxx.free.fr/xxxx/upgrade.php et j'ai immédiatement l'erreur suivante:
xxxxxx/include/config_default.inc.php on line 773

Lorsque je remets mes fichiers de la 2.4.3, en lançant l'url de ma galerie, je tombe sur la page d'install. Je rempli les identifiants et je valide.
Suite à ça, ma galerie est opérationnelle. il me reste juste à retirer le mode maintenance.

J'ai cherché mais je n'ai pas trouvé de solution.
Si vous avez une solution rapide pour vous je suis preneur sinon, rester en 2.4.3 ne me dérange pas.

En tout cas, félicitations pour tous ces développements et cette galerie qui me rend entière satisfaction.

grenouille31

Hors ligne

#2 2013-03-10 01:24:03

mistic100
Ex Equipe Piwigo
Lyon
2008-09-27
3556

Re: Erreur migration 2.4.3 vers 2.5 chez FREE

Bonjour

ce que vous avez donné n'est pas l'erreur complète, il manque le début


pour info la ligne 773 c'est

Code:

$conf['chmod_value']= substr_compare(PHP_SAPI, 'apa', 0, 3)==0 ? 0777 : 0755;

qu'est-ce que free n'aime pas ? les opérateur ternaires (lol) ? ou une constante qui existe de puis PHP 4.2 (re-lol) ?

Hors ligne

#3 2013-03-10 15:29:54

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Erreur migration 2.4.3 vers 2.5 chez FREE

Je confirme qu'une mise à jour manuelle d'une galerie Piwigo 2.4.x vers 2.5.0 fonctionne parfaitement chez Free, hébergeur sur lequel je pratique les béta-tests Piwigo en ligne. Mais chut ! Faut pas que çà s'ébruite car ce n'est pas autorisé par les CGU ;o).


mistic100 a écrit:

pour info la ligne 773 c'est

Code:

$conf['chmod_value']= substr_compare(PHP_SAPI, 'apa', 0, 3)==0 ? 0777 : 0755;

qu'est-ce que free n'aime pas ? les opérateur ternaires (lol) ? ou une constante qui existe de puis PHP 4.2 (re-lol) ?

LOL aussi !

Hors ligne

#4 2013-03-10 15:32:48

flop25
Équipe Piwigo
2006-07-06
6477

Re: Erreur migration 2.4.3 vers 2.5 chez FREE

Donc, Eric, tu n'as aucun soucis de mdp admin ou autre ? essaye en te déconnectant/connectant

Hors ligne

#5 2013-03-10 15:40:53

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Erreur migration 2.4.3 vers 2.5 chez FREE

Comme je l'annonce ici : http://fr.piwigo.org/forum/viewtopic.ph … 04#p199904
Toutes mes galeries beta et RC 2.5 en ligne chez Free fonctionnent parfaitement sans pb de perte de mot de passe.

Hors ligne

#6 2013-03-10 15:42:02

flop25
Équipe Piwigo
2006-07-06
6477

Re: Erreur migration 2.4.3 vers 2.5 chez FREE

Eric a écrit:

Comme je l'annonce ici : http://fr.piwigo.org/forum/viewtopic.ph … 04#p199904
Toutes mes galeries beta et RC 2.5 en ligne chez Free fonctionnent parfaitement sans pb de perte de mot de passe.

Merci :)

Hors ligne

#7 2013-03-11 22:31:13

grenouille31
Membre
2013-03-10
2

Re: Erreur migration 2.4.3 vers 2.5 chez FREE

Merci à tous pour vos réponses:

Eric a écrit:

Je confirme qu'une mise à jour manuelle d'une galerie Piwigo 2.4.x vers 2.5.0 fonctionne parfaitement chez Free, hébergeur sur lequel je pratique les béta-tests Piwigo en ligne. Mais chut ! Faut pas que çà s'ébruite car ce n'est pas autorisé par les CGU ;o).

Je suis en 2.4.3.
Dois-je passer par les upgrades des versions intermédiaires jusqu'à la 2.5 ou bien ce n'est pas la peine?

Merci encore

Grenouille31

Hors ligne

#8 2013-03-11 22:52:04

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Erreur migration 2.4.3 vers 2.5 chez FREE

J'ai migré des versions 2.4.6 et 2.4.7 vers 2.5.0 sans problème. Une mise à jour depuis une version 2.4.3 ne devrait pas être plus problématique.

Hors ligne

  •  » Installation
  •  » Erreur migration 2.4.3 vers 2.5 chez FREE

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact