Annonce

  •  » Utilisation
  •  » [Résolu] Connexion impossible sur une galerie - Erreur 500

#1 2011-12-14 19:22:53

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

[Résolu] Connexion impossible sur une galerie - Erreur 500

Bonsoir à tous,

Une fois n'est pas coutume, j'ai un gros problème avec ma galerie principale chez Free (lien dans mon profil) : Impossible de me connecter normalement à la galerie, quelque soit le compte utilisé. Après la saisie du login et du mot de passe, j'ai une erreur 500. Après cette erreur, plus moyen d'accéder à la page d'index de la galerie car je retombe toujours sur cette erreur 500.

J'ai fini par trouver le moyen de réafficher la page d'index en supprimant le cookie généré dans mon Firefox. J'ai ensuite essayé avec d'autres navigateurs (IE et Chrome) avec la même punition :-(

J'ai levé le doute sur un éventuel plugin qui serait à l'origine de çà en les désactivant tous depuis ma base de données : Même résultat.

J'ai réussi à passer finalement en faisant "page précédente" dans mon navigateur. Mais je ne comprends pas ce qui peut causer ce problème très ennuyeux. J'ai demandé à Free s'il y avait des soucis sur le serveur qui m'héberge et l'admin, Yohan, m'a signifié un "RAS"...

Toutes suggestions seront les bienvenues ;-)

Hors ligne

#2 2011-12-15 18:18:00

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Connexion impossible sur une galerie - Erreur 500

@ddtddt : J'ai vu que tu as tenté de t'inscrire sur ma galerie. Est-ce que tu as subit toi aussi l'erreur 500 lors d'une tentative de connexion ? C'est pour apporter des éléments de preuve pour que Free veuille bien vérifier leurs serveurs.

J'ai essayé de créer un compte de test, moi aussi. Le compte se créé bien, je reçois les notifications d'usage issues de Piwigo et de UAM. Je peux valider mon inscription mais pas moyen de me connecter...

Hors ligne

#3 2011-12-15 19:54:03

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16179

Re: [Résolu] Connexion impossible sur une galerie - Erreur 500

oui plein de fois
j'ai surtout pas réussis 'officiellement à passer le CAPCHA:-(

Je voulais faire d'autre test avant de répondre
mais j'ai plein d'erreur comme cela chez free


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#4 2011-12-15 21:13:04

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Connexion impossible sur une galerie - Erreur 500

ddtddt a écrit:

oui plein de fois
j'ai surtout pas réussis 'officiellement à passer le CAPCHA:-(

Pourtant l'une des tentatives est bien passée. Par contre tu n'as pas reçu le mail de confirmation d'incription (ou alors tu n'y a pas répondu) car ton compte est toujours en attente de confirmation.

ddtddt a écrit:

Je voulais faire d'autre test avant de répondre
mais j'ai plein d'erreur comme cela chez free

Merci pour le retour :-)

Cela me conforte dans mon diagnostic du problème. C'est bien un souci avec le serveur Free qui héberge mon site. L'ennui c'est que Yohan ne semble pas "voir" qu'il y a un souci. Faut que j'apporte des arguments d'autant qu'une navigation sans s'identifier sur la galerie fonctionne parfaitement.

J'ai l'impression que le problème vient d'apache qui ne gère plus correctement les sessions. A suivre...

Hors ligne

#5 2011-12-16 21:07:56

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Connexion impossible sur une galerie - Erreur 500

Bon, l'admin de Free a fait une découverte concernant le problème de ma galerie. Il a trouvé ceci :
"Allowed memory size of 33554432 bytes exhausted (tried to allocate 20 bytes)".

J'ai l'impression qu'il s'agit d'un problème lié au serveur mais je n'en suis pas certain. Piwigo pourrait-il être à l'origine d'un tel dépassement de mémoire ? Ma galerie ne me semble pourtant pas si imposante et les requêtes Sql étaient bien avant le pb...

Je ne serai pas contre l'avis de quelques experts en serveurs Apache...

Hors ligne

#6 2011-12-17 02:54:58

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Connexion impossible sur une galerie - Erreur 500

Pour info, après de longues heures d'investigation sur le problème en travaillant sur un clone complet de mon site en local sous Wampserver configuré a minima comme les serveurs de Free, j'ai réussi à reproduire le dépassement de mémoire.

En lisant les lignes suivantes, j'ai compris que c'était Whois Online, le coupable :

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 472 bytes) in ../phpwebgallery/plugins/whois_online/include/wo_functions.inc.php on line 152

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 24 bytes) in ../phpwebgallery/include/functions_session.inc.php on line 101

En désactivant le plugin sur ma galerie en ligne, j'ai pu enfin récupérer mon accès ! Maintenant, faut que je comprenne pourquoi ce plugin s'est mis à déraper tout à coup sans que je n'ai rien touché aux réglages depuis qu'il est installé (soit plusieurs mois).

Que mon expérience puisse servir à d'autres ;-)
Maintenant, je peux aller me coucher...

Hors ligne

#7 2011-12-17 03:07:17

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Connexion impossible sur une galerie - Erreur 500

Fallait que j'en ai le coeur net avant le dodo : Whois Online fonctionnait parfaitement sur Piwigo 2.2 mais j'ai l'impression que depuis la 2.3, il y a un os. Je n'ai pas décortiqué son fonctionnement mais je pense qu'il y a un pb de compatiblité quelque part qui n'était pas visible au premier abord.

Hors ligne

#8 2012-05-13 13:04:49

Mascarille
Membre
Lyon Avignon
2009-12-21
796

Re: [Résolu] Connexion impossible sur une galerie - Erreur 500

Bonjour à tous,

Venant de rajouter de nouvelles images (scan de photos plus anciennes)
j'ai eu pour un album et un album seulement
              http://www.mascarille.com/galerie/index … egory/1849
un message d'erreur : Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 4305 bytes) in P:\galerie\admin\include\image.class.php on line 547

Comme Eric a eu un pb du même ordre (je n'utilise pas Whoisonline)

J'ai remarqué qu'une image n'avait pas de date de prise de vue (elle provient comme les autres d'un scanner + logiciel VueScan et non d'un appareil photo...)

En supprimant cette image ça fonctionne - Une piste peut-être pour le pb précédent

Piwigo 2.3.4
Système d'exploitation: WINNT
PHP: 5.3.1
mysql: 5.5.0
Bibliothèque graphique: GD bundled
35633 photos - 1082 albums

Bon Dimanche

Hors ligne

#9 2012-05-13 17:33:56

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] Connexion impossible sur une galerie - Erreur 500

Mascarille a écrit:

Comme Eric a eu un pb du même ordre (je n'utilise pas Whoisonline)

J'ai remarqué qu'une image n'avait pas de date de prise de vue (elle provient comme les autres d'un scanner + logiciel VueScan et non d'un appareil photo...)

Sauf que dans mon cas, le fait de désactiver Whois Online a résolu le pb. Et je ne vois pas quel rapport il peut y avoir entre ce plugin et une absence de méta-donnée dans une photo...

Hors ligne

  •  » Utilisation
  •  » [Résolu] Connexion impossible sur une galerie - Erreur 500

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact