Annonce

  •  » Outils
  •  » [Résolu] ploader sous linux 11.04

#1 2011-05-01 17:52:54

Usul
Membre
2010-12-26
15

[Résolu] ploader sous linux 11.04

Salux à tous,
j'ai téléchargé le ploader.
Il est décompressé dans mon /home/monnom.
Je suis ce qui est dit :
Modifier directement le script pLoader.sh (avec un éditeur de texte) pour changer de version d'Ubuntu. Vous pouvez exécuter pLoader.sh depuis n'importe où, par exemple un raccourci sur votre bureau.

Je modifie le script ploader.sh en :
#!/bin/bash

cd $(dirname $0)
./pLoader-1.5_ubuntu11.04

Je clic ensuite sur ploader.sh.
Et la, il ne se passe rien.
Ou ais-je fait une/des erreur/s ?

Kubuntu natty narval en 32 bits.
Merci de votre aide.

Dernière modification par Usul (2011-06-12 11:36:06)

Hors ligne

#2 2011-05-02 15:03:06

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12532

Re: [Résolu] ploader sous linux 11.04

Bonjour Usul,

Pour faire tourner pLoader sous Linux, la méthode recommandée, c'est de le lancer à partir des sources (aucune compilation nécessaire), lire le tutoriel sur [Forum, topic 16806] Installer pLoader sous linux 64bits (et autres ?)


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#3 2011-05-02 15:04:19

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12532

Re: [Résolu] ploader sous linux 11.04

(j'ai bien vu que tu étais en 32bits, ça ne change rien au fait que lancer pLoader à partir des sources c'est mieux pour Linux)

Je n'ai pas encore pris le temps de tester Ubuntu 11.04, si tu peux faire un retour sur le fonctionnement de pLoader dessus, ce serait sympa :-)


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#4 2011-05-02 16:19:18

Usul
Membre
2010-12-26
15

Re: [Résolu] ploader sous linux 11.04

Je n'ai pas encore pris le temps de tester Ubuntu 11.04, si tu peux faire un retour sur le fonctionnement de pLoader dessus, ce serait sympa :-)

Ok, je fais les essais demain et je donne le retour. Pas de soucis.
Merci pour ton aide.

Dernière modification par Usul (2011-05-02 16:19:43)

Hors ligne

#5 2011-05-06 20:09:09

Usul
Membre
2010-12-26
15

Re: [Résolu] ploader sous linux 11.04

plg a écrit:

si tu peux faire un retour sur le fonctionnement de pLoader dessus, ce serait sympa :-)

Alors voila le résultat, pas concluant pour l'instant.
Voici ce que me dit le terminal en ayant suivi ton lien.
Tout a bien fonctionné jusqu'au moment de lancer le programme.

$ cd ~/pLoader/src/
seve@seve:~/pLoader/src$ perl ploader.pl
Can't load '/usr/lib/perl5/auto/Wx/Wx.so' for module Wx: /usr/lib/perl5/auto/Wx/Wx.so: symbol wxDefaultVideoMode, version WXU_2.8 not defined in file libwx_gtk2u_core-2.8.so.0 with link time reference at /usr/lib/perl/5.10/DynaLoader.pm line 192.
at ploader.pl line 23
Compilation failed in require at ploader.pl line 23.
BEGIN failed--compilation aborted at ploader.pl line 23.

Et la ça bloque.

Que dois-je faire ?
Merci de ton aide.

Hors ligne

#6 2011-05-07 16:44:49

Usul
Membre
2010-12-26
15

Re: [Résolu] ploader sous linux 11.04

un petit up ?

Hors ligne

#7 2011-05-07 17:33:38

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12532

Re: [Résolu] ploader sous linux 11.04

je regarde ce soir :-)


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#8 2011-05-07 23:36:23

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12532

Re: [Résolu] ploader sous linux 11.04

On a donc affaire à un bug dans le packaging Ubuntu de la librairie Perl WX, voir https://bugs.launchpad.net/ubuntu/+sour … bug/754513

Je fais des essais pour contourner le problème en attendant qu'Ubuntu fournisse un correctif.


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#9 2011-05-07 23:38:29

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12532

Re: [Résolu] ploader sous linux 11.04

A noter que j'ai installé ploader depuis le Ubuntu Software Center, ce qui rend l'installation de pLoader encore plus facile :-)


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#10 2011-05-07 23:44:53

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12532

Re: [Résolu] ploader sous linux 11.04

En ligne de commande, lancer :

Code:

sudo cpan Wx

et cliquer sur entrée à chaque fois qu'il attend une réponse.

Normalement ça suffit (mais c'est un peu long, il compile une grosse librairie)


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#11 2011-05-07 23:53:08

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12532

Re: [Résolu] ploader sous linux 11.04

J'ai soumis un commentaire dans le bug sur Launchpad, j'espère qu'ils corrigeront le problème bientôt (a priori, il "suffit" de recompiler cette librairie)


Historiquement, premier utilisateur connu de Piwigo ;-)

Hors ligne

#12 2011-05-08 16:34:31

Usul
Membre
2010-12-26
15

Re: [Résolu] ploader sous linux 11.04

plg a écrit:

En ligne de commande, lancer :

Code:

sudo cpan Wx

et cliquer sur entrée à chaque fois qu'il attend une réponse.

Normalement ça suffit (mais c'est un peu long, il compile une grosse librairie)

alors j'ai installé le ploader par les dépôts.
Puis j'ai suivi ce qui est dit dans ta première réponse avec le lien.

J'ai ensuite fait dans le terminal : sudo cpan Wx et répondu par entrée à chaque demande.
Et à la fin j'ai ce message :
Warning (usually harmless): 'YAML' not installed, will not store persistent state
Running make test
  Can't test without successful make
Running make install
  Make had returned bad status, install seems impossible


Quand je lance :
cd ~/pLoader/src/
perl ploader.pl
J'ai toujours l'erreur :
~/pLoader/src$ perl ploader.pl
Can't locate Wx.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at ploader.pl line 23.
BEGIN failed--compilation aborted at ploader.pl line 23.

Voilà les news, une idée ?

Merci

Hors ligne

#13 2011-05-11 03:44:40

enzobr
Membre
2010-11-27
12

Re: [Résolu] ploader sous linux 11.04

Chez moi, avec ubuntu 11.04 mis à jour, et le code:

sudo cpan Wx

pLoader 1.6 fonctionne de nouveau correctement.

As tu une connection internet active quand tu lances sudo cpan wx ?
J'ai remarqué qu'il téléchargeait des paquets pendant la compilation.... le pb vien peut être de là ?

Bon courage,
Enzo

Hors ligne

#14 2011-05-11 16:15:23

Usul
Membre
2010-12-26
15

Re: [Résolu] ploader sous linux 11.04

enzobr a écrit:

Chez moi, avec ubuntu 11.04 mis à jour, et le code:

sudo cpan Wx

pLoader 1.6 fonctionne de nouveau correctement.

As tu une connection internet active quand tu lances sudo cpan wx ?
J'ai remarqué qu'il téléchargeait des paquets pendant la compilation.... le pb vien peut être de là ?

Bon courage,
Enzo

Oui, ma  connexion est acitve.
Comment as-tu procédé exactement ?

Perso, j'ai d'abord fait ce qui est dit ici :
http://fr.piwigo.org/forum/viewtopic.php?id=16806

puis j'ai lancé le sudo cpan wx en console, répondu par entrée à toutes les demandes.
Et enfin fait l'essai en lançant la dernière commande :
cd ~/pLoader/src/
perl ploader.pl

Et j'ai eu l'erreur du post plus haut.

Dernière modification par Usul (2011-05-11 16:16:48)

Hors ligne

#15 2011-05-12 03:36:07

enzobr
Membre
2010-11-27
12

Re: [Résolu] ploader sous linux 11.04

Usul a écrit:

Oui, ma  connexion est acitve.
Comment as-tu procédé exactement ?

Perso, j'ai d'abord fait ce qui est dit ici :
http://fr.piwigo.org/forum/viewtopic.php?id=16806

puis j'ai lancé le sudo cpan wx en console, répondu par entrée à toutes les demandes.
Et enfin fait l'essai en lançant la dernière commande :
cd ~/pLoader/src/
perl ploader.pl

Et j'ai eu l'erreur du post plus haut.

C'est un peu compliqué dans mon cas : j'ai upgradé une 10.04 sur laquelle marchait bien pLoader 1.5, en 10.10. Je suis passé à pLoader 1.6 sur ubuntu 10.10 (en suivant la procédure que tu donnes). Enfin, j'ai upgradé sur 11.04, pLoader 1.6 ne marchait plus, j'ai tenté pLoader 1.5 j'ai réinstallé imagemagic et pas mal de dépendances en version dev, puis j'ai vu ton message et la procédure proposée par Plg. La 1ère compil a planté. J'ai redémarré et la seconde était la bonne. Depuis, ça roule.
A noter que sur un autre PC avec moins de dépendances bizarres installées, ça ne marche pas. Par contre, j'ai réussi à lancer la version 1.5 depuis les sources... essaie peut être ?

Désolé de ne pas pouvoir être plus précis !
Enzo

Hors ligne

  •  » Outils
  •  » [Résolu] ploader sous linux 11.04

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact