Annonce

#1 2011-02-15 12:35:10

jp.harand
Membre
Dijon (21)
2010-10-15
247

[Résolu] menubar...

J'ai un dernier petit problème... (pour l'instant ;-)

En haut de la page picture.php de ma galerie, j'ai le message d'erreur

Notice:  Undefined index:  start in /homez.56/alterreb/www/galeriebocage/include/menubar.inc.php on line 147"

La ligne en question du fichier cité, c'est ça :

Code:

      $selection = array_slice( $page['items'], $page['start'], $page['nb_image_page'] );

Si je vous la mets dans son contexte (je la mets en gras) (EDIT : Tiens, ça marche pas le gras dans du code ! ;-)):

Code:

//------------------------------------------------------------------------ tags
  $block = $menu->get_block('mbTags');
  if ( $block!=null and !empty($page['items']) )
  {
    if ('tags'==@$page['section'])
    {
      $tags = get_common_tags(
        $page['items'],
        $conf['menubar_tag_cloud_items_number'],
        $page['tag_ids']
        );
      $tags = add_level_to_tags($tags);

      foreach ($tags as $tag)
      {
        $block->data[] = array_merge(
          $tag,
          array(
            'U_ADD' => make_index_url(
              array(
                'tags' => array_merge(
                  $page['tags'],
                  array($tag)
                  )
                )
              ),
            'URL' => make_index_url( array( 'tags' => array($tag) )
              ),
            )
          );
      }
    }
    else
    {
[b]      $selection = array_slice( $page['items'], $page['start'], $page['nb_image_page'] );[/b]
      $tags = add_level_to_tags( get_common_tags($selection, $conf['content_tag_cloud_items_number']) );
      foreach ($tags as $tag)
      {
        $block->data[] =
        array_merge( $tag,
          array(
            'URL' => make_index_url( array( 'tags' => array($tag) ) ),
          )
        );
      }
    }
    if ( !empty($block->data) )
    {
      $block->template = 'menubar_tags.tpl';
    }
  }

J'utilise un thème Sylvia juste un peu verdi par mes soins.
Je n'ai quasiment aucune personnalisation des CSS. (Si vous pensez que ça peut venir de là, je peux vous copier mes personnalisations faites avec Local Files Editor...

Qq1 a une idée ?
:-)

Dernière modification par jp.harand (2011-02-15 12:35:49)


» Galeries : Galerie du bocage de BourgogneDécouvertes nature en Bourgogne
» Plugins : Tag To Keyword
» Thèmes : SylviaReseauBocagesBourgogne (en cours)

Hors ligne

#2 2011-02-15 12:53:44

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] menubar...

Bonjour,

Je pense plus à un effet de bord avec un plugin...

Quel est la liste de vos plugins activés ?


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#3 2011-02-15 13:00:34

jp.harand
Membre
Dijon (21)
2010-10-15
247

Re: [Résolu] menubar...

Gotcha a écrit:

Bonjour,

Je pense plus à un effet de bord avec un plugin...

Quel est la liste de vos plugins activés ?

Oui probablement.
Je me souviens que quelques ajustements CSS avaient été nécessaires pour "contrer" quelques effets de bords du plugin qui permet de toujours afficher le menu.
Quel est son nom déjà... euh... Spread menus !

Liste de tous les plugins activés :

Additional Pages
Advanced Menu Manager
Advanced MetaData
Albums
Contact Form
Edit Maps&Earth
Extended Description
GMaps
Grum Plugins Classes.3
LMT
LocalFiles Editor
NBM Subscriber
Perso About
Personal Favicon
Piwigo AutoUpgrade
PWG Stuffs
RV DB Integrity   
RV Maps&Earth
Spread menus
Statistics
unTagged

Dernière modification par jp.harand (2011-02-15 13:01:10)


» Galeries : Galerie du bocage de BourgogneDécouvertes nature en Bourgogne
» Plugins : Tag To Keyword
» Thèmes : SylviaReseauBocagesBourgogne (en cours)

Hors ligne

#4 2011-02-15 13:12:15

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] menubar...

Commencer par désactiver le plugin "Spread menus" voir s'il n'y a pas un lien de cause à effet.

Sinon, il faudra désactiver tous les plugins pour être certain que le problème vient bien de l'un d'eux.

Petite documentation pour désactiver tout ses plugin rapidement : http://www.julien-moreau.fr/wiki/doku.p … er_plugins


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#5 2011-02-15 13:16:22

jp.harand
Membre
Dijon (21)
2010-10-15
247

Re: [Résolu] menubar...

Gotcha a écrit:

Commencer par désactiver le plugin "Spread menus" voir s'il n'y a pas un lien de cause à effet.

Bingo !
Désactiver Spread Menus a fait disparaître le message d'erreur.
Je signale le pb sur le forum dédié à Spread Menus... ou on continue de chercher ici ?
:-)


» Galeries : Galerie du bocage de BourgogneDécouvertes nature en Bourgogne
» Plugins : Tag To Keyword
» Thèmes : SylviaReseauBocagesBourgogne (en cours)

Hors ligne

#6 2011-02-15 13:21:37

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] menubar...

Hum... il faudrait faire une recherche sur ce problème, vois s'il n'a pas déjà été remonté en effet...


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#7 2011-02-15 14:02:02

jp.harand
Membre
Dijon (21)
2010-10-15
247

Re: [Résolu] menubar...

Gotcha a écrit:

Hum... il faudrait faire une recherche sur ce problème, vois s'il n'a pas déjà été remonté en effet...

Je cherche, je cherche...
Je trouve : http://fr.piwigo.org/forum/viewtopic.php?pid=156693
C'est le même problème que moi... sans solution.

Je trouve aussi : http://fr.piwigo.org/forum/viewtopic.php?id=17959.
C'est bien intéressant, mais ça ne résout pas le problème (ni le nom de l'image qui est  bizarrement placé - ni centré, ni aligné à gauche)...

Je continue de chercher...


» Galeries : Galerie du bocage de BourgogneDécouvertes nature en Bourgogne
» Plugins : Tag To Keyword
» Thèmes : SylviaReseauBocagesBourgogne (en cours)

Hors ligne

#8 2011-02-15 15:10:51

cljosse
Former Piwigo Team
2006-11-12
1167

Re: [Résolu] menubar...

jp.harand a écrit:

Gotcha a écrit:

Hum... il faudrait faire une recherche sur ce problème, vois s'il n'a pas déjà été remonté en effet...

Je cherche, je cherche...
Je trouve : http://fr.piwigo.org/forum/viewtopic.php?pid=156693
C'est le même problème que moi... sans solution.

Je trouve aussi : http://fr.piwigo.org/forum/viewtopic.php?id=17959.
C'est bien intéressant, mais ça ne résout pas le problème (ni le nom de l'image qui est  bizarrement placé - ni centré, ni aligné à gauche)...

Je continue de chercher...

Et En désacrivant le plugins AMM ?

Hors ligne

#9 2011-02-15 15:37:45

jp.harand
Membre
Dijon (21)
2010-10-15
247

Re: [Résolu] menubar...

cljosse a écrit:

Et En désacrivant le plugins AMM ?

Ca ne change rien. Toujours le même message d'erreur de "menubar".


» Galeries : Galerie du bocage de BourgogneDécouvertes nature en Bourgogne
» Plugins : Tag To Keyword
» Thèmes : SylviaReseauBocagesBourgogne (en cours)

Hors ligne

#10 2011-02-15 15:47:38

cljosse
Former Piwigo Team
2006-11-12
1167

Re: [Résolu] menubar...

page|'start'] est utilisé dans les plugins :
     RV Maps&Earth
     Edit Maps&Earth

en déactivant ces deux plugins...

Hors ligne

#11 2011-02-15 15:55:55

jp.harand
Membre
Dijon (21)
2010-10-15
247

Re: [Résolu] menubar...

cljosse a écrit:

page|'start'] est utilisé dans les plugins :
     RV Maps&Earth
     Edit Maps&Earth
en déactivant ces deux plugins...

Ca ne change rien. Toujours le même message d'erreur de "menubar".


» Galeries : Galerie du bocage de BourgogneDécouvertes nature en Bourgogne
» Plugins : Tag To Keyword
» Thèmes : SylviaReseauBocagesBourgogne (en cours)

Hors ligne

#12 2011-02-15 16:43:51

cljosse
Former Piwigo Team
2006-11-12
1167

Re: [Résolu] menubar...

Suite...
page['start'] est lié aux "tags"
  Et si je passe par les mots clefs je n'ai pas d'erreurs.

....>>>>
  En ecrivant
$page['start']=0 ;
a l'aide de localfiles editor

dans le fichier config.inc.php devrait en attendant une autre solution corriger le pb.

Dernière modification par cljosse (2011-02-15 16:45:21)

Hors ligne

#13 2011-02-15 17:00:54

jp.harand
Membre
Dijon (21)
2010-10-15
247

Re: [Résolu] menubar...

Impecc' !
Merci beaucoup.

(Notamment au niveau des métadonnées) j'ai une grosse différence de présentation selon si l'on passe par les mots-clés ou par les albums.
Comme je souhaite également afficher le nom plus près de l'image (c'est à dire intercaler le nom de l'image entre les boutons de navigation et l'image elle-même), je vais fouiller un peu et ...
...
mettre un (nouveau) message sur le forum quand j'en aurais marre de chercher !
;-)

Encore merci.


» Galeries : Galerie du bocage de BourgogneDécouvertes nature en Bourgogne
» Plugins : Tag To Keyword
» Thèmes : SylviaReseauBocagesBourgogne (en cours)

Hors ligne

#14 2011-02-15 17:49:21

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] menubar...

cljosse a écrit:

Suite...
page['start'] est lié aux "tags"
  Et si je passe par les mots clefs je n'ai pas d'erreurs.

....>>>>
  En ecrivant
$page['start']=0 ;
a l'aide de localfiles editor

dans le fichier config.inc.php devrait en attendant une autre solution corriger le pb.

Ca corrige donc le fonctionnement de Spread Menus ???

Si c'est le cas comment corriger le plugin lui même ?


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#15 2011-02-15 18:17:01

cljosse
Former Piwigo Team
2006-11-12
1167

Re: [Résolu] menubar...

Gotcha a écrit:

cljosse a écrit:

Suite...
page['start'] est lié aux "tags"
  Et si je passe par les mots clefs je n'ai pas d'erreurs.

....>>>>
  En ecrivant
$page['start']=0 ;
a l'aide de localfiles editor

dans le fichier config.inc.php devrait en attendant une autre solution corriger le pb.

Ca corrige donc le fonctionnement de Spread Menus ???

Si c'est le cas comment corriger le plugin lui même ?

Je ne sais pas exactement pourquoi le problème est apparu chez jp.harand
  Pour l'instant chez moi je n'ai pas pu reproduire le pb.
  Je vais poursuivre mes investigations...

Et je tiens la communauté au courant, si je trouve la source de dysfonctionnement.

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2021 · Contact