•  » Installation
  •  » [Résolu] erreur bloquante en mettant les plug a jour

#1 2010-08-13 12:11:05

bonnind
Membre
2009-11-22
16

[Résolu] erreur bloquante en mettant les plug a jour

bonjour a tous,

j'ai mis piwigo a jour vers la derniere version, puis reactiver les plug in.

ensuite j'ai mis les plug in a jour (un peu a la volee) et j'ai ce message :

Warning: include_once(./plugins/grum_plugins_classes-2/common_plugin.class.inc.php) [function.include-once]: failed to open stream: No such file or directory in /homez.170/davidpho/www/piwigo/plugins/AMenuManager/amm_root.class.inc.php  on line 19

Warning: include_once() [function.include]: Failed opening './plugins/grum_plugins_classes-2/common_plugin.class.inc.php' for inclusion (include_path='.:/usr/local/lib/php') in /homez.170/davidpho/www/piwigo/plugins/AMenuManager/amm_root.class.inc.php on line 19

Warning: include_once(./plugins/grum_plugins_classes-2/users_groups.class.inc.php) [function.include-once]: failed to open stream: No such file or directory in /homez.170/davidpho/www/piwigo/plugins/AMenuManager/amm_root.class.inc.php on line 20

Warning: include_once() [function.include]: Failed opening './plugins/grum_plugins_classes-2/users_groups.class.inc.php' for inclusion (include_path='.:/usr/local/lib/php') in /homez.170/davidpho/www/piwigo/plugins/AMenuManager/amm_root.class.inc.php on line 20

Warning: include_once(./plugins/grum_plugins_classes-2/css.class.inc.php) [function.include-once]: failed to open stream: No such file or directory in /homez.170/davidpho/www/piwigo/plugins/AMenuManager/amm_root.class.inc.php on line 21

Warning: include_once() [function.include]: Failed opening './plugins/grum_plugins_classes-2/css.class.inc.php' for inclusion (include_path='.:/usr/local/lib/php') in /homez.170/davidpho/www/piwigo/plugins/AMenuManager/amm_root.class.inc.php on line 21

Fatal error: Class 'common_plugin' not found in /homez.170/davidpho/www/piwigo/plugins/AMenuManager/amm_root.class.inc.php on line 24

et ce des l'accueil de mon site (www.david-photo.net) .

c'est plutot embarrassant...

comment puis je corriger cela ?

merci

Dernière modification par bonnind (2010-08-13 12:12:13)

Hors ligne

#2 2010-08-13 12:27:21

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
14682

Re: [Résolu] erreur bloquante en mettant les plug a jour

Connecte toi par FTP et supprimes 'grum_plugins_classes-2'

Ensuite dans ton admin installe la version adapté à Piwigo 2.1 (Pour ce plugin, il faut le désinstaller et le supprimer complètement pour qu'il fonctionne ;-)

N'hésite pas à utiliser la recherche sur le forum cette erreur est déjà sortie plusieurs fois


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2010-08-13 12:41:16

bonnind
Membre
2009-11-22
16

Re: [Résolu] erreur bloquante en mettant les plug a jour

merci mais je n'avais pas trouvé, desole.

ceci dit apres suppression du repertoire grum_plugins_classe-2,
j'ai toujours le meme message.

sniff

Hors ligne

#4 2010-08-13 12:58:05

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13330

Re: [Résolu] erreur bloquante en mettant les plug a jour

Via phpMyAdmin (BDD) dans la table piwigo_plugins sur la ligne correspondante à "grum_plugins_classe-2" il faut mettre "inactive".


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#5 2010-08-13 18:01:32

bonnind
Membre
2009-11-22
16

Re: [Résolu] erreur bloquante en mettant les plug a jour

j'ai pas la ligne en question ! :

      AMenuManager active 2.1.6
      AStat inactive 2.0.4
      AdditionalPages active 2.0.d
      AntiAspi active 2.0.b
      ContactForm active 1.0.8
      LinkRoot active 2.0
      LocalFilesEditor active 2.0.3
      NBC_UserAdvManager active 2.14.1
      PWG_Stuffs inactive 2.0.t
      SmiliesSupport inactive 2.0.a
      WiredForSound active 2.0.b
      admin_advices inactive 2.0.2
      autoupdate active 2.1.d
      c13y_upgrade active 0
      lmt active 1.1.0
      look_like_gbo2 inactive 2.0.h
      piclens active 0.4.2
      piwishack inactive 0.2
      pwgCumulus inactive 0.3.0
      rv_menutree inactive 2.0.c
      rv_sitemap inactive 2.0.a
      rv_thumbs inactive 2.0.c
      whois_online inactive 2.0.j

Hors ligne

#6 2010-08-13 21:26:25

grum
Équipe Piwigo
50% Nantes - 50% Paris
2007-09-10
2502

Re: [Résolu] erreur bloquante en mettant les plug a jour

je vois
AMenuManager active 2.1.6
Or, cette version du plugin est incompatible avec Piwigo 2.1, il faut passer à la version 2.2 (cf. [extension by grum] Advanced Menu Manager)
La version 2.1.6 exploite GrumPluginClasses 2, la version 2.2 exploite GrumPluginClasses 3

Idem pour les plugins Astat et LMT, il faut passer à la dernière version avant de les activer.


Mes photos avec Piwigo évidemment !
[ www.grum.fr ] [ photos.grum.fr ]

Hors ligne

#7 2010-08-14 18:22:01

bonnind
Membre
2009-11-22
16

Re: [Résolu] erreur bloquante en mettant les plug a jour

cool merci,

j'ai desactive tous les plug in et tout repris a zero (pour les plug in) et maintennt c ok.

merci beaucoup

Hors ligne

  •  » Installation
  •  » [Résolu] erreur bloquante en mettant les plug a jour

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact