Annonce

  •  » Styles
  •  » [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

#1 2010-06-18 01:56:42

tosca
Former Piwigo Team
Cévennes (Gard)
2006-09-23
3818

[Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

Erreur rencontrée en utilisant un certain nombre de thèmes avec [extension by Nicco] nbc ThemeChanger

Warning: include(/themeconf.inc.php) [function.include]: failed to open stream: No such file or directory in /homez.110/marienoe/www/piwigocamp/include/template.class.php on line 615

Warning: include() [function.include]: Failed opening '/themeconf.inc.php' for inclusion (include_path='.:/usr/local/lib/php') in /homez.110/marienoe/www/piwigocamp/include/template.class.php on line 615

Concerne les thèmes suivants :
    * BlancMont XL
    * Gally/Cuise
    * Gally/Graphite
    * Gally/Grum dark II
    * Gally/Lapis-lazuli
    * Grum dark II
    * Kardon
    * Luciano Amodio
    * MontBlanc XL
    * Simple Black
    * Simple Grey
    * Simple Sunset
    * Simple White
    * Sobre

L'erreur est reproductible sur cette galerie en visualisant les sous-catégories correspondantes de la catégorie "Galerie de thèmes".

A noter également : bien qu'installés les thèmes Simple Sunset et Pure_default restent présents sur l'onglet "Ajouter un thème"

Hors ligne

#2 2010-06-18 10:01:35

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

Je suppose que Theme Changer cherche à récupérer une variable qui n'existe plus ou qu'il ne sait pas manipuler.


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#3 2010-06-18 10:04:05

tosca
Former Piwigo Team
Cévennes (Gard)
2006-09-23
3818

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

Gotcha a écrit:

Je suppose que Theme Changer cherche à récupérer une variable qui n'existe plus ou qu'il ne sait pas manipuler.

Ca marche quand même avec pas mal d'autres thèmes :/

Hors ligne

#4 2010-06-18 10:09:29

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

La différence que je note dans le fichier themeconf.inc.php entre Sylvia et Sobre sont ces deux lignes :

Code:

'icon_dir'      => 'themes/Sylvia/icon',
'mime_icon_dir' => 'themes/Sylvia/icon/mimetypes/',

Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#5 2010-06-18 10:13:52

tosca
Former Piwigo Team
Cévennes (Gard)
2006-09-23
3818

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

Gotcha a écrit:

La différence que je note dans le fichier themeconf.inc.php entre Sylvia et Sobre sont ces deux lignes :

Code:

'icon_dir'      => 'themes/Sylvia/icon',
'mime_icon_dir' => 'themes/Sylvia/icon/mimetypes/',

Je ne pense pas que ça soit ça, car tous mes thèmes perso fonctionnent, et ils ne redéfinissent pas tous les répertoires (seulement Aquarelle, en fait).
Je pense d'ailleurs que ce sont des variables définies par défaut ... dans le thème par défaut, justement ;-)

Hors ligne

#6 2010-06-18 12:24:57

datajulien
Membre
Bruxelles (BE)
2009-07-29
282

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

j'ai tester la migration avec les 3 thèmes de bases.
Et tout marchais super bien.

Ce soir, je testerai avec l'installation d'autres thèmes pour regarder ce problème.

Hors ligne

#7 2010-06-19 05:52:33

tosca
Former Piwigo Team
Cévennes (Gard)
2006-09-23
3818

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

tosca a écrit:

L'erreur est reproductible sur cette galerie en visualisant les sous-catégories correspondantes de la catégorie "Galerie de thèmes".

J'ai provisoirement verrouillé les catégories correspondant aux thèmes en erreur, pour que ça ne fasse pas trop désordre ;-)

Hors ligne

#8 2010-06-19 11:53:48

datajulien
Membre
Bruxelles (BE)
2009-07-29
282

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

En fait, j'ai exactement le meme bug avec le plugin Multi View

Mais je n'en trouve pas la raison!

Hors ligne

#9 2010-06-19 13:15:17

datajulien
Membre
Bruxelles (BE)
2009-07-29
282

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

l'erreur arrive au niveau du contructeur

$template = new Template(PHPWG_ROOT_PATH.'themes', $user['theme'] );

Je continue mon investigation.

Hors ligne

#10 2010-06-21 09:53:07

datajulien
Membre
Bruxelles (BE)
2009-07-29
282

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

j'ai trouvé une piste, il y a un comportement suspect dans le core pwigo au niveau du fichier :
template.class.php
En effet, lorsqu'il s'agit des thèmes standard, un appel a la fonction
realpath(dir) retourne toujours une chaine valide.
Lorsqu'il s'agit des thèmes comme le blancMont XL cette même fonction retour la chaine null.


Cette builtin est utilisé dans les fonctions :
- set_template_dir
- set_theme
- set_extents
- load_themeconf

Hors ligne

#11 2010-06-21 10:16:18

datajulien
Membre
Bruxelles (BE)
2009-07-29
282

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

Ci dessous on voit bien que le realpath($dir) dans la fonction load_themeconf ne fonctionne pas pour le thème BlancMont XL.

Le soucie est l'espace entre BlancMont et XL.



Code:

Sylvia
set_template_dir - dir :./themes/Sylvia/template
set_template_dir - real_dir :
load_themeconf - dir :./themes/Sylvia
load_themeconf - realpath(dir ):C:\Documents and Settings\Administrator\Desktop\gallery\piwigo2.1\themes\Sylvia
load_themeconf - dir :./themes/default
load_themeconf - realpath(dir ):C:\Documents and Settings\Administrator\Desktop\gallery\piwigo2.1\themes\default
set_theme - local_head : ./themes/default/local_head.tpl
set_theme - realpath(local_head) : C:\Documents and Settings\Administrator\Desktop\gallery\piwigo2.1\themes\default\local_head.tpl

Dark
set_template_dir - real_dir :
load_themeconf - dir :./themes/dark
load_themeconf - realpath(dir ):C:\Documents and Settings\Administrator\Desktop\gallery\piwigo2.1\themes\dark
load_themeconf - dir :./themes/default
load_themeconf - realpath(dir ):C:\Documents and Settings\Administrator\Desktop\gallery\piwigo2.1\themes\default
set_theme - local_head : ./themes/default/local_head.tpl
set_theme - realpath(local_head) : C:\Documents and Settings\Administrator\Desktop\gallery\piwigo2.1\themes\default\local_head.tpl

BlancMont XL
set_template_dir - dir :./themes/BlancMont XL/template
set_template_dir - real_dir :
load_themeconf - dir :./themes/BlancMont XL
load_themeconf - realpath(dir ):C:\Documents and Settings\Administrator\Desktop\gallery\piwigo2.1

Hors ligne

#12 2010-06-21 10:24:14

datajulien
Membre
Bruxelles (BE)
2009-07-29
282

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

le problème vient de la table de piwigo210_themes (id, version, name)
ou la colonne name contient un espace.

Une fois cette  espace éliminé, tout fonctionne bien.

Petite question, quelle est la source de cette variable?

Hors ligne

#13 2010-06-21 10:32:03

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15127

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

name est facultatif et peut contenir des espaces.


id est automatique et contient le nom du répertoire.

=> ne pas utiliser ['name'] mais ['id']


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#14 2010-06-21 10:41:14

datajulien
Membre
Bruxelles (BE)
2009-07-29
282

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

le pb c'est que dans la variable $user[theme] est contenue le nom du thème et pas l'ID.

[edit]dans le module d'admin, lorsqu'on spécifie un thème par défaut c'est le nom du thème qui est enregistrer dans la table user_info[/edit]

[edit2] De plus le constructeur de la class Template prend en paramètre le nom du template, pas son ID. [/edit2]

Dernière modification par datajulien (2010-06-21 11:08:24)

Hors ligne

#15 2010-06-22 21:47:22

datajulien
Membre
Bruxelles (BE)
2009-07-29
282

Re: [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

corrigé.

Version 2.1.0.b en ligne.

Hors ligne

  •  » Styles
  •  » [Résolu] Erreur à l'utilisation d'un certain nombre de thèmes

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2023 · Contact