#1 2010-04-18 16:01:03

clemouel
Membre
94 - Val de Marne
2005-11-13
190

[Résolu] [2.1.0RC2] Impossible de tager des images

Bonjour,

Je n'arrive pas à tager des photos avec la version béta Piwigo  2.1.0RC2.

Quelque chose m'a-t-il échappé ?


Démarche
- 2 images synchronisées dans une catégorie ;
- 2 images ajoutées dans une autre catégorie avec la fonction administration / photos / ajouter / ajouter des photos ;
- vérification avec succès de la présence des catégories et images dans la galerie ;
- je crée avec succès deux tags (Equipe, tag) via la fonction administration / photos / tags ;
- je me rends dans administration / gérer / gérer les éléments de la catégorie / mode unitaire ;
- je sélectionne une image  ;
- dans ajouter les tags je tape Equipe (nom de mon tag ainsi créé) ;
- je vérifie que le bouton "sélection" est sélectionné ;
- je clique sur "Valider".

Résultat attendu
- le tag "Equipe" doit apparaitre en dessous le photo agrandie taguée dans la gallerie ;
- en cliquant dans "Tag" du menu de la galerie, vérifier la présence de "Equipe" et en cliquant sur "Equipe" présence de la photo miniature.

Résultat observé
- pas de nom de tag en dessous de la photo agrandie ;
- aucun tag mentionné dans la fonctionnalité tag.

Environnement de test
- OS = MS Windows Seven
- navigateur = Mozilla Firefox et MS IE 8
- installation pwg : création sur site test vierge.

Merci de votre aide.

Cyril

Dernière modification par clemouel (2010-04-18 16:13:44)

Hors ligne

#2 2010-04-18 17:27:59

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

clemouel a écrit:

Démarche
- 2 images synchronisées dans une catégorie ;
- 2 images ajoutées dans une autre catégorie avec la fonction administration / photos / ajouter / ajouter des photos ;
- vérification avec succès de la présence des catégories et images dans la galerie ;
- je crée avec succès deux tags (Equipe, tag) via la fonction administration / photos / tags ;
- je me rends dans administration / gérer / gérer les éléments de la catégorie / mode unitaire ;
- je sélectionne une image  ;
- dans ajouter les tags je tape Equipe (nom de mon tag ainsi créé) ;
- je vérifie que le bouton "sélection" est sélectionné ;
- je clique sur "Valider".

J'ai essayé de reproduire mais je n'ai pas remarqué de problème. A noter que, dans la gestion des éléments d'une catégorie en mode unitaire, on ne sélectionne pas d'image et il n'y a pas de bouton "Sélection". Ceci, on le trouve dans le mode global.

D'autre part, l'ajout de tags dans le mode unitaire est régit par de l'ajax. Il suffit de taper les premières lettres du tag que l'on a précédemment ajouté dans Panneau d'admin > Photos > Tags pour qu'ajax propose les correspondances disponibles.

Lors de mes test, les tags ainsi ajoutés apparaissent bien pour chaque photo taggée. Je ne vois pas de problème à ce niveau. Peut-être un souci local?

Hors ligne

#3 2010-04-20 08:49:48

vincent3569
Membre
Lyon
2006-05-31
608

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

bonjour

j'ai signalé ce pb sur la RC1 et il est toujours présent sur la RC2 [Forum, post 140161 by vincent3569 in topic 17517] mes retours sur la version 2.1RC2 et cela constitue une anomalie que je qualifierai de majeure :

l'ajout de tags sur les photos est impossible via le menu Catégories/gérer/éléments, aussi bien en mode global qu'en mode unitaire.
il est imposssible d'ajouter un tag existant ou de créer "à la volée" un tag depuis ce menu.

ça marche sur le trunk, mais pas sur mon site de test.
clemouel rencontre visiblement le même problème.

une piste ? je suis chez Free.

Hors ligne

#4 2010-04-20 14:35:08

clemouel
Membre
94 - Val de Marne
2005-11-13
190

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

Bonjour à tous,

Si cela peut aider, je suis également chez FREE comme Vincent.

Cyril

Hors ligne

#5 2010-05-07 02:08:31

Gegene
Membre
2010-04-26
19

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

Bonsoir

En effet:
Il suffit de taper les premières lettres du tag que l'on a précédemment ajouté dans Panneau d'admin > Photos > Tags pour qu'ajax propose les correspondances disponibles.

Mais cette utilisation est inconfortable si les tags sont nombreux...
Ne peut-on pas avoir un menu déroulant retourant l'ensemble des tags, et sur saisie d'un texte affiche une sélection comme actuellement..

Gégène

Hors ligne

#6 2010-05-07 02:15:42

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12615

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

Gegene a écrit:

Ne peut-on pas avoir un menu déroulant retourant l'ensemble des tags, et sur saisie d'un texte affiche une sélection comme actuellement..

Malheureusement non. J'ai sélectionné un plugin jQuery pour gérer l'ajout de tags à une photo, et je ne compte pas du tout le modifier. Par contre, il est prévu pour Piwigo 2.2 de revoir l'ergonomie de l'ajout de tags. L'ergonomie introduite pour Piwigo 2.1 est une solution temporaire justement pour ceux qui ont beaucoup de tags et qui ne veulent pas avoir un bloc de 300 cases à cocher comme en Piwigo 2.0.


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

#7 2010-05-07 10:24:37

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12615

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

En tout cas, je ne reproduis pas le problème d'ajout de tag. Environnements testés:

- ubuntu 9.04, Firefox 3.0.19
- ubuntu 9.04, Google Chrome 5.0.342.9
- MacOsX Snow Leopard 10.6, Firefox 3.5.4
- MacOsX Snow Leopard 10.6, Safari 4.0.5

Par contre, sous WindowsXP, IE6, il ne garde que le dernier tag :-/ mais IE6 est officiellement non supporté pour l'admin de Piwigo. Je n'ai pas d'autres versions de IE sous la main.

Le problème apparaît-il également sur la page d'édition d'une photo ? (en dehors de la gestion par lot)

Et autre remarque : quand on a entré son tag au clavier, il faut taper sur la touche "Entrée", le tag se transforme alors en un petit bloc sur fond bleu clair.

Pour info, l'ergonomie visée pour l'ajout de tags est décrite là [forum central anglophone] Improving the "add tags to photo" form. Basé sur les exemples Wordpress/Dotclear.


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

#8 2010-05-07 13:00:32

vincent3569
Membre
Lyon
2006-05-31
608

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

sous XP/IE7 et Vista/IE8 sur la RC2 installée sur Free (je n'ai pas testé avec Vista / FF, ni sur le trunk ni sur ma RC2, mais je vous tiens au courant ASAP) :

- j'ai créé des tags (tag1, tag2, ...) sur Admin/Photos/Tags
- je suis allé sur Admin/Catégories/Gérer/Elements (mode unitaire ou global)
- la saisie de la lettre "t" dans la zone "ajouter les tags" ne remonte pas la liste des tags disponibles pour cette lettre.
- la saisie d'un tag existant (tag1 ou tag5) et la validation avec la touche entrée ne mémorise pas le tag.

bref : impossible d'ajouter des tags aux photos !!

je n'ai pas tenté d'importer des photos et de faire une synchro, donc je ne sais pas dire si l'import des mots-clés sous forme de tags fonctionne ou pas.

toutes ces opérations marchent parfaitement bien sur le Trunk (le pb ne viendrait-il pas du coté serveur plutôt que du coté client ?)


PS : si ça peut utile à l'équipe de dev, voici l'adresse de la RC2, vous pouvez vous y inscire, je vous passerai en admin (merci de confirmer par la MP) pour analyse le pb : http://vincent.bourganel.free.fr/piwigoRC

Dernière modification par vincent3569 (2010-05-07 13:02:34)

Hors ligne

#9 2010-05-07 13:50:43

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12615

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

vincent3569 a écrit:

PS : si ça peut utile à l'équipe de dev, voici l'adresse de la RC2, vous pouvez vous y inscire, je vous passerai en admin (merci de confirmer par la MP) pour analyse le pb : http://vincent.bourganel.free.fr/piwigoRC

Je viens de m'inscrire avec le  nom d'utilisateur "plg". Je voudrais bien passer admin s'il te plaît.


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

#10 2010-05-07 13:53:16

vincent3569
Membre
Lyon
2006-05-31
608

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

je viens de tester sur une configuration un peu spéciale (offre "Hello" de Orange Internet : navigateur inconnu sur environement Linux, toujours vers mon site Free) : le pb est le même.

j'en reviens donc à ma question posée ci-dessus :

vincent3569 a écrit:

le pb ne viendrait-il pas du coté serveur plutôt que du coté client ?

Hors ligne

#11 2010-05-07 13:55:15

vincent3569
Membre
Lyon
2006-05-31
608

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

plg a écrit:

vincent3569 a écrit:

PS : si ça peut utile à l'équipe de dev, voici l'adresse de la RC2, vous pouvez vous y inscire, je vous passerai en admin (merci de confirmer par la MP) pour analyse le pb : http://vincent.bourganel.free.fr/piwigoRC

Je viens de m'inscrire avec le  nom d'utilisateur "plg". Je voudrais bien passer admin s'il te plaît.

c'est fait

Hors ligne

#12 2010-05-07 14:11:37

Gegene
Membre
2010-04-26
19

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

Bonjour

Bien noté pour les tags.
La version 2.1 n'est pas encore sortie...!
Où puis-je trouver une discution ou autre pour savoir les modifs futures sur les tags, pour
la version 2.2 et proposer des solutions.

Gégène

Hors ligne

#13 2010-05-07 14:14:27

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12615

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

Gegene a écrit:

Bien noté pour les tags.
La version 2.1 n'est pas encore sortie...!

Non, mais c'est imminent.

Gegene a écrit:

Où puis-je trouver une discution ou autre pour savoir les modifs futures sur les tags, pour
la version 2.2 et proposer des solutions.

Pour le moment, c'est surtout sur le forum central anglophone qu'une solution a été proposée. Ouvres un topic pour proposer des solutions.


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

#14 2010-05-07 18:09:27

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12615

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

vincent3569 a écrit:

plg a écrit:

vincent3569 a écrit:

PS : si ça peut utile à l'équipe de dev, voici l'adresse de la RC2, vous pouvez vous y inscire, je vous passerai en admin (merci de confirmer par la MP) pour analyse le pb : http://vincent.bourganel.free.fr/piwigoRC

Je viens de m'inscrire avec le  nom d'utilisateur "plg". Je voudrais bien passer admin s'il te plaît.

c'est fait

Je confirme : pareil pour moi, la touche "entrée" est inactive, de même que l'auto-complétion. Donc impossible d'ajouter un tag à une photo ou une sélection de photo. C'est propre au serveur. vincent3569, laisses moi le compte admin, je vais faire des essais.


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

#15 2010-05-07 18:26:19

plg
Équipe Piwigo
Nantes, France, Europe
2002-04-05
12615

Re: [Résolu] [2.1.0RC2] Impossible de tager des images

Et le gagnant est :

Code:

Fatal error: Call to undefined function json_encode() ...

Je vais inclure le script de compatibilité pour définir spécifiquement la fonction json_encode (le code est déjà dans include/ws_protocols/json_encoder.php


Les historiens ont établi que Pierrick était le premier utilisateur connu de Piwigo.

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2023 · Contact