Annonce

  •  » Plugins
  •  » [Résolu] paMOOramics ne marche pas style simple/grey

#1 2009-12-03 19:51:10

photo2bob
Membre
2009-12-03
28

[Résolu] paMOOramics ne marche pas style simple/grey

Bonjour,
Je suis nouveau sur Piwigo.
-  faut il se presenter sur votre forum?
-  Bravo pour votre projet, j'ai dicide d'utiliser Piwigo pour mon site
-  Je suis tres interresse par le template simple/grey, mais je n'arrive pas a utiliser le plugin paMOOramics avec ce template.
    Ca marche avec un template yoga/ .

J'ai cherche dans le forum, mais je n'ai rien trouve sur ce probleme.
Y a t'il un vrai probleme, ou juste un problem de config.
Merci d'avance pour vos reponses

Hors ligne

#2 2009-12-03 22:32:13

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] paMOOramics ne marche pas style simple/grey

Bonsoir et bienvenue sur le forum.

La présentation n'est pas obligatoire, les remerciements font toujours plaisir : merci.

Concernant ton problème, il y a peut-être une incompatibilité entre le plugin et le thème. Soit j'ai n'ai pas le temps et quelqu'un d'autre te donnera des éléments de réponses, soit il va falloir attendre que je termine mes travaux en cours.
Si dans une semaine tu n'as pas de réponse, n'hésites pas à relancer ce sujet :-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#3 2009-12-04 00:35:10

repie38
Former Piwigo Team
grenoble
2006-05-23
678

Re: [Résolu] paMOOramics ne marche pas style simple/grey

il est possible qu'il y'ai incompatibilité. une a deja été levé sur le template gally : [Bugtracker] ticket 1111
puis-je avoir un lien pour voir ce qui ne va pas ? (par mp si besoin)

edit : plus besoin de lien, je confirme, il y'a bien incompatibilité, causé par l'emploi de jQuery dans le template
(paMOOramics lui utilise mootools, les 2 chargé en meme temps font planté paMOOramics)
j'edite le bug et essai  de resoudre ca ;)

Dernière modification par repie38 (2009-12-04 00:47:44)

Hors ligne

#4 2009-12-04 01:10:42

repie38
Former Piwigo Team
grenoble
2006-05-23
678

Re: [Résolu] paMOOramics ne marche pas style simple/grey

ok, j'ai résolu, il faudra mettre a jour 1 fichier javascript dans le template.
je contact l'auteur pour qu'il publie tout ca.

en attendant je donne tout de meme la solution :
dans template\simple\js\scipts.js, on ajoute "jQuery.noConflict();", et on remplace chaque occurence de "$" par "jQuery", ce qui donne  :

Code:

jQuery.noConflict();
jQuery(document).ready(function(){
  jQuery("#theComments h3").click(function () {
    jQuery("#theComments div").toggle("slow");
  });

  jQuery("#menuswitcher").click(function(){
    if (jQuery("#menubar").is(":hidden")) {
      jQuery("#menubar").show("slow");
      jQuery.cookie('side-menu', 'showing', {path: "/"});
      return false;
    } else {
      jQuery("#menubar").hide("slow");
      jQuery.cookie('side-menu', 'hiding', {path: "/"});
      return false;
    }
  });

  // creates a variable with the contents of the cookie side-menu
  var sidemenu = jQuery.cookie('side-menu');
  // if cookie says the menu is hiding, keep it hidden!
  if (sidemenu == 'hiding') {
    jQuery("#menubar").hide();
  }
  if (sidemenu == 'showing') {
    jQuery("#menubar").show();
  };
});

/**
 * Cookie plugin
 * Copyright (c) 2006 Klaus Hartl (stilbuero.de)
 * Dual licensed under the MIT and GPL licenses:
 */
jQuery.cookie=function(name,value,options){if(typeof value!='undefined'){options=options||{};if(value===null){value='';options=jQuery.extend({},options);options.expires=-1;}
var expires='';if(options.expires&&(typeof options.expires=='number'||options.expires.toUTCString)){var date;if(typeof options.expires=='number'){date=new Date();date.setTime(date.getTime()+(options.expires*24*60*60*1000));}else{date=options.expires;}
expires='; expires='+date.toUTCString();}
var path=options.path?'; path='+(options.path):'';var domain=options.domain?'; domain='+(options.domain):'';var secure=options.secure?'; secure':'';document.cookie=[name,'=',encodeURIComponent(value),expires,path,domain,secure].join('');}else{var cookieValue=null;if(document.cookie&&document.cookie!=''){var cookies=document.cookie.split(';');for(var i=0;i<cookies.length;i++){var cookie=jQuery.trim(cookies[i]);if(cookie.substring(0,name.length+1)==(name+'=')){cookieValue=decodeURIComponent(cookie.substring(name.length+1));break;}}}
return cookieValue;}};

Hors ligne

#5 2009-12-04 08:29:06

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16335

Re: [Résolu] paMOOramics ne marche pas style simple/grey

repie38 a écrit:

je contact l'auteur pour qu'il publie tout ca.

j'ai loupé qqc ?


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#6 2009-12-04 10:11:45

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: [Résolu] paMOOramics ne marche pas style simple/grey

ddtddt a écrit:

repie38 a écrit:

je contact l'auteur pour qu'il publie tout ca.

j'ai loupé qqc ?

[Forum, post 125072 by repie38 in topic 14583] Jquery pour la partie public


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#7 2009-12-04 10:31:26

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16335

Re: [Résolu] paMOOramics ne marche pas style simple/grey

Gotcha a écrit:

ddtddt a écrit:

repie38 a écrit:

je contact l'auteur pour qu'il publie tout ca.

j'ai loupé qqc ?

[Forum, post 125072 by repie38 in topic 14583] Jquery pour la partie public

ça j'ai vu ;-)

c'est juste à propos de l'auteur de paMOOramics !


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#8 2009-12-04 14:22:32

repie38
Former Piwigo Team
grenoble
2006-05-23
678

Re: [Résolu] paMOOramics ne marche pas style simple/grey

héhé ... je ne me contact pas moi meme :p
je contact l'auteur de simple/grey, car c'est la qu'il faut faire une modif, pas dans pamooramics ;)

Hors ligne

#9 2009-12-04 14:24:26

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16335

Re: [Résolu] paMOOramics ne marche pas style simple/grey

repie38 a écrit:

héhé ... je ne me contact pas moi meme :p
je contact l'auteur de simple/grey, car c'est la qu'il faut faire une modif, pas dans pamooramics ;)

a ok lol j'étais encore bien réveillé !


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#10 2009-12-04 14:46:21

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15127

Re: [Résolu] paMOOramics ne marche pas style simple/grey

Je n'avais rien dit mais visiblement ddtddt était un peu en difficultés ce matin, ce qui est sans jeu de mots ou de sous-entendu assez rare, donc il en est pardonné.

On ne dénoncera pas l'auteur de simple/grey.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#11 2009-12-04 19:23:40

photo2bob
Membre
2009-12-03
28

Re: [Résolu] paMOOramics ne marche pas style simple/grey

Merci pour votre aide et surtout de la reactivite.

Ça marche, la preuve ici pour ceux qui sont interesses

http://photo2bob.fr/piwigo/

le sujet peut il etre resolu?

Hors ligne

#12 2009-12-04 20:59:18

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15127

Re: [Résolu] paMOOramics ne marche pas style simple/grey

Visualise ton premier post (tu y verras le lien).


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#13 2009-12-05 19:31:20

saimon
Membre
2006-12-04
367

Re: [Résolu] paMOOramics ne marche pas style simple/grey

Salut,
merci à repie38 pour la solution :-), j'intègre ça au thème dès que possible !

Hors ligne

#14 2009-12-08 00:08:15

saimon
Membre
2006-12-04
367

Re: [Résolu] paMOOramics ne marche pas style simple/grey

Hors ligne

#15 2009-12-08 12:37:40

repie38
Former Piwigo Team
grenoble
2006-05-23
678

Re: [Résolu] paMOOramics ne marche pas style simple/grey

merci a toi pour ce template ;)

Dernière modification par repie38 (2009-12-08 12:38:04)

Hors ligne

  •  » Plugins
  •  » [Résolu] paMOOramics ne marche pas style simple/grey

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2023 · Contact