•  » Utilisation
  •  » Problème lors d'une update... [RESOLU]

#16 2009-04-26 17:36:24

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Problème lors d'une update... [RESOLU]

kevingt3 a écrit:

je viens de revérifier, et finalement la plupart des plug de la 1.7.3 existent pour la 2.0.1, à part exif view...

bon je vais finalement me laisser tenter par cette nouvelle version je suppose qu'un plug similaire à exif view verra bientôt le jour si il n'existe pas déjà sans que je le connaisse...

A la bonne heure ! Tu ne le regretteras pas.

Donc, maintenant, tu peux :

1- Te connecter à ta base de données chez Free via PhpMyAdmin et supprimer toutes les tables ayant le préfix de PWG (par défaut, elles sont préfixées phpwebgallery

2- Te connecter sur ton espace chez Free via le FTP et supprimer tous les sous-dossiers du répertoire d'installation de PhpWebGallery SAUF le dossier "galleries"

Lorsque fait :

1- Dézippe le package de la 2.0.1 et envois tous les fichiers et dossiers SAUF "galleries" sur ton espace chez Free via le FTP.

2- Replaces tes fichiers mysql.inc.php et config_local.inc.php dans le répertoire "include" sur ton espace chez Free.

3- Avec ton navigateur, rends-toi sur http:\\[ton_site].free.fr\[dossier d'installation de Piwigo]\install.php et procède à l'installation de la galerie.

Après cela on restaurera tes utilisateurs.

Hors ligne

#17 2009-04-26 17:41:57

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: Problème lors d'une update... [RESOLU]

Il pourrait peux-être garder include/config_local.inc.php s'il a fait des modifications ^^


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#18 2009-04-26 17:49:56

kevingt3
Membre
2009-04-26
27

Re: Problème lors d'une update... [RESOLU]

je l'avais déjà sauvegardé celui là :p

Hors ligne

#19 2009-04-26 17:51:11

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Problème lors d'une update... [RESOLU]

Gotcha a écrit:

Il pourrait peux-être garder include/config_local.inc.php s'il a fait des modifications ^^

Ce n'est pas ce que j'ai préconisé ?

-> Sauvegarde préalable de mysql.inc.php et config_local.inc.php
-> Restauration des fichiers mysql.inc.php et config_local.inc.php après avoir uploadé sa distribution 2.0.1

Hors ligne

#20 2009-04-26 17:57:01

kevingt3
Membre
2009-04-26
27

Re: Problème lors d'une update... [RESOLU]

bon j'ai suivi tes instructions, mais lorsque je vais sur install.php un message me dit que piwigo est déjà installé, mais la galerie n'est biensur pas active...

Hors ligne

#21 2009-04-26 18:01:47

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Problème lors d'une update... [RESOLU]

kevingt3 a écrit:

bon j'ai suivi tes instructions, mais lorsque je vais sur install.php un message me dit que piwigo est déjà installé, mais la galerie n'est biensur pas active...

Zut ! C'est ma faute ! Je t'ai induit en erreur avec la restauration du fichier mysql.inc.php trop tôt. Supprimes le de ton espace Free puis relances l'install. Après l'install, tu pourras restaurer ton fichier mysql.inc.php. Cà devrait marcher.

Hors ligne

#22 2009-04-26 18:03:30

kevingt3
Membre
2009-04-26
27

Re: Problème lors d'une update... [RESOLU]

et je remet celui d'origine (du package) avant ?

Hors ligne

#23 2009-04-26 18:04:32

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Problème lors d'une update... [RESOLU]

oui. De toutes façons, il est vide ce lui là (0 octets).

Hors ligne

#24 2009-04-26 18:05:00

kevingt3
Membre
2009-04-26
27

Re: Problème lors d'une update... [RESOLU]

ok ^^ bon bah je me lance et te tiens informé

merci

Hors ligne

#25 2009-04-26 18:11:20

kevingt3
Membre
2009-04-26
27

Re: Problème lors d'une update... [RESOLU]

ok j'ai installé piwigo, mais lorsque je change le mysql la galerie me dit qu'il y a une erreur

Hors ligne

#26 2009-04-26 18:16:40

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Problème lors d'une update... [RESOLU]

kevingt3 a écrit:

ok j'ai installé piwigo, mais lorsque je change le mysql la galerie me dit qu'il y a une erreur

Edites ton fichier mysql.inc.php (avec un éditeur de texte simple comme notepad) et ajoutes ceci à la fin, avant le "?> :

Code:

define('PWG_CHARSET', 'utf-8');
define('DB_CHARSET',  'utf8');
define('DB_COLLATE',  '');

Puis renvoies le sur ton site, dans le dossier "include".

Hors ligne

#27 2009-04-26 18:17:19

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: Problème lors d'une update... [RESOLU]

Et un petit lien vers ton site ?

Hors ligne

#28 2009-04-26 18:19:29

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13324

Re: Problème lors d'une update... [RESOLU]

Ca doit venir de la ligne dans mysql.inc.php:

Code:

$prefixeTable = 'phpwebgallery_';

Remplaces là par:

Code:

$prefixeTable = 'piwigo_';

Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#29 2009-04-26 18:20:05

kevingt3
Membre
2009-04-26
27

Re: Problème lors d'une update... [RESOLU]

voilà le lien, j'essaie d'ajouter les lignes...

http://eos.400d.911.free.fr/galerie/

Hors ligne

#30 2009-04-26 18:24:23

kevingt3
Membre
2009-04-26
27

Re: Problème lors d'une update... [RESOLU]

bon et bien c'était bien le piwigo à mettre à la place de phpwebgallery ^^

là ça marche avec mon mysql (au fait il sert à quoi lui au juste ?? )

maintenant je serais prêt à réinjecter les utilisateurs je crois non ?

Hors ligne

  •  » Utilisation
  •  » Problème lors d'une update... [RESOLU]

Pied de page des forums

Propulsé par FluxBB

github twitter facebook newsletter Faire un don Piwigo.org © 2002-2019 · Contact