Annonce

#1 2009-04-19 13:39:15

Korben
Membre
2008-09-17
139

[résolu] Erreur Envoi Mail

Bonjour,

Je rencontre des problèmes lors de l'envoi de mails le part de Piwigo.

Voici ce que j'ai comme message lorsque Piwigo essaie d'envoyer un message lors d'un nouveau commentaire pour validation de celui-ci.


Warning: mail() [function.mail]: SMTP server response: 501 5.1.3 Bad recipient address syntax in C:\wamp\www\piwigo\include\functions_mail.inc.php on line 780


Le message est bien indiqué "Warning" mais aucun message n'est envoyé.

J'ai Piwigo 2.0.1
Apache 2.2.11
PHP 5.2.9-1
MySQL 5.1.32


Merci pour votre aide.
Je ne sais plus quoi faire.

Dernière modification par Korben (2009-04-27 22:26:35)


Piwigo 2.5.1

Hors ligne

#2 2009-04-19 13:51:41

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: [résolu] Erreur Envoi Mail

Il faut que tu regardes du coté de ton serveur pour autoriser l'envoie de mél


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#3 2009-04-19 14:01:05

Krio77
Membre
2009-03-08
14

Re: [résolu] Erreur Envoi Mail

J'ai déjà posé cette question sur le forum...restée sans réponse.

J'ai même essayer de monter un relai SMTP sur le serveur qui héberge ma galerie et checker les logs mais rien à faire...je ne vois pas...

Si aujourd'hui, on peut avancer, ça permettrait aux users de ma galerie de recevoir les mises à jour...

Hors ligne

#4 2009-04-19 14:03:06

Krio77
Membre
2009-03-08
14

Re: [résolu] Erreur Envoi Mail

Perso, mon serveur est paramétré pour accepter les envois de mails...

Et puis si on traduit le message : "Bad recipient address syntax", il est clair que le format de l'adresse envoyé est incorrect !

Alors, qui saurait nous dépatouiller à la ligne 780...

Hors ligne

#5 2009-04-19 14:11:23

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: [résolu] Erreur Envoi Mail

L'envoie de mél fonctionne sur beaucoup de galerie.

Est ce que l'adresse de ton webmaster et correcte au niveau de la syntaxe ?

pas d'espace, accent, caractère spéciaux . . .


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#6 2009-04-19 14:54:56

Korben
Membre
2008-09-17
139

Re: [résolu] Erreur Envoi Mail

Le fichier httpd.inf de Apache est normalement configuré pour l'envoi de mails.
l'adresse du Webmaster (moi-même) est correctement configurée.
Le serveur smtp est aussi correctement configuré.
Le firewall autorise aussi l'envoi de mail via le port smtp.
Et tous les problèmes annexes étant découverts, je ne vois pas comment résoudre ce problème car cette fonctionnalité d'envoi de mail m'est assez nécessaire.

Par contre, en regardant le fichier "functions_mail.inc.php" il est demandé un passeword pour la connexion smtp mais lorsque le serveur ne requiert pas de passeword comment la fonction agit ??


Piwigo 2.5.1

Hors ligne

#7 2009-04-19 15:41:37

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: [résolu] Erreur Envoi Mail

Korben a écrit:

Le fichier httpd.inf de Apache est normalement configuré pour l'envoi de mails.
l'adresse du Webmaster (moi-même) est correctement configurée.
Le serveur smtp est aussi correctement configuré.
Le firewall autorise aussi l'envoi de mail via le port smtp.
Et tous les problèmes annexes étant découverts, je ne vois pas comment résoudre ce problème car cette fonctionnalité d'envoi de mail m'est assez nécessaire.

Par contre, en regardant le fichier "functions_mail.inc.php" il est demandé un passeword pour la connexion smtp mais lorsque le serveur ne requiert pas de passeword comment la fonction agit ??

Merci pour la piste

As tu fait un essai en rajoutant un code sur ton smtp pour voir si cela résous le problème ?-)


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#8 2009-04-19 16:08:09

Korben
Membre
2008-09-17
139

Re: [résolu] Erreur Envoi Mail

Je ne peux pas sécuriser le service smtp puisque c'est celui de mon FAI. Je n'ai donc aucun droit sur ce service.
Je ne sais donc pas comment on peut résoudre ce pb.
Mais il y a peut-être quelque chose qui m'a échappé dans ma config apache, php ou piwigo !! Je ne sais pas.

En fait je monte ce site en serveur perso chez moi, il ne sera pas du tout mis chez mon FAI ou un autre. Ceci pour des raison de place sur serveur et autre.

Dernière modification par Korben (2009-04-19 16:09:45)


Piwigo 2.5.1

Hors ligne

#9 2009-04-19 18:12:12

Korben
Membre
2008-09-17
139

Re: [résolu] Erreur Envoi Mail

Je ne sais pas si ça va faire avancer le chmileblick  mais voici ce que renvoi la fonction concernée dans le log erreurPHP.

[19-Apr-2009 18:00:19] PHP Warning:  mail() [<a href='function.mail'>function.mail</a>]: SMTP server response: 501 5.5.4 Invalid Address in C:\wamp\www\piwigo\include\functions_mail.inc.php on line 780


Je tiens à préciser aussi que le module "php_smtp" est validé dans PHP

Si quelqu'un arrive avec tout ça à résoudre ce problème.
Je pense que c'est un mauvais renvoi de fonction PHP mais je ne suis pas spécialiste PHP alors...


Piwigo 2.5.1

Hors ligne

#10 2009-04-19 23:04:22

rub
Équipe Piwigo
Lille
2005-08-26
5239

Re: [résolu] Erreur Envoi Mail

Ton admin a une adresse valable?

Je peux avoir sur ta galerie en MP si tu veux.


Tu peux aussi essayer l'envoie smtp "maison" en indiquant le smtp que tu veux avec $conf['smtp_host'], le user et mot de passe étant facultatif.

Autre question, est-ce que les autres applications que tu as installés, envoient correctement les mails?

Hors ligne

#11 2009-04-20 11:41:33

Korben
Membre
2008-09-17
139

Re: [résolu] Erreur Envoi Mail

Le webmaster a comme adresse e-mail mon adresse perso que j'utilise tous les jours depuis des années.

Qd aux autres applications web si elles envoient correctement des messages, je ne sais pas car elles n'utilisent pas la messagerie.
Le serveur est actuellement en cours de paramétrage avant de le mettre en ligne chez moi.
Je n'ai pas encore ouvert le firewall pour donner acces via le net. La consultation est locale pour le moment, mais je teste tout avant d'ouvrir le firewall
Qd aux autres applications que j'utilise, les mails sont correctement envoyés, mais ce ne sont pas les applications web comme piwigo.

Je ne sais donc pas d'où peut provenir le problème et comment le résoudre.


Et d'ailleurs, tu me parle d'essayer d'utiliser l'envoie smtp "maison" en indiquant le smtp que tu veux avec $conf['smtp_host'], le user et mot de passe étant facultatif.
Mais comment on fait ça ? où mettre ce paramètre ?

Merci pour l'aide

Dernière modification par Korben (2009-04-20 11:47:46)


Piwigo 2.5.1

Hors ligne

#12 2009-04-20 13:41:18

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: [résolu] Erreur Envoi Mail

Korben a écrit:

Et d'ailleurs, tu me parle d'essayer d'utiliser l'envoie smtp "maison" en indiquant le smtp que tu veux avec $conf['smtp_host'], le user et mot de passe étant facultatif.
Mais comment on fait ça ? où mettre ce paramètre ?

Avec le plugin LocalFiles Editor, dans le fichier include/config_local.inc.php.

Une petite page à lire dans le Wiki pour découvrir les $conf


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#13 2009-04-20 14:05:55

Korben
Membre
2008-09-17
139

Re: [résolu] Erreur Envoi Mail

OK Merci

Si je comprends bien, il faut juste que je créé le fichier "config_local.inc.php" et que je mette dans ce fichier la ligne "$conf['smtp_host']" où "smtp_host" est le serveur smtp de mon FAI ???? C'est bien ça ?
Je ne comprends pas trop l'utilisation de ce fichier alors...
Merci

Dernière modification par Korben (2009-04-20 14:07:16)


Piwigo 2.5.1

Hors ligne

#14 2009-04-20 14:39:35

rub
Équipe Piwigo
Lille
2005-08-26
5239

Re: [résolu] Erreur Envoi Mail

Oui, mais le plus simple c'est encore d'utiliser le plugin LocalFiles Editor.

Pas contre, si tu es sous windows, tu peux normalement configurer le smtp d'envoi directement dans le php.ini.

Essaie de faire un fichier de test en php pour utiliser la fonction mail directement et voir si ca fonctionne déjà de base. Si ca ne fonctionne pas, essaie aussi de voir au niveau du support xampp.

Hors ligne

#15 2009-04-20 16:16:12

Korben
Membre
2008-09-17
139

Re: [résolu] Erreur Envoi Mail

OK Merci je vais essayer de voir du coté WAMP et aussi d'utiliser le fichier de paramètre local.


Piwigo 2.5.1

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact