Annonce

#1 2009-01-28 00:17:41

Rémy
Invité

Problème d'installation

Je viens de migrer de la version 1.6.2 vers la 1.7.3 et depuis je n'ai plus accès à la gallerie et j'ai le message suivant qui apparait.
L'accès à la galerie ce fait par http://www.loisirs-luemschwiller.org/phpwebgallery/

Merci d'avance pour votre aide


Warning: 
SELECT
  id, name, permalink, nb_images, global_rank,
  date_last, max_date_last, count_images, count_categories
FROM phpwebgallery_categories INNER JOIN phpwebgallery_user_cache_categories
  ON id = cat_id and user_id = 1
WHERE
(id_uppercat is NULL)
;
[mysql error 1054] Unknown column 'permalink' in 'field list'
#0    my_error /homez.51/loisirsl/www/phpwebgallery/include/functions.inc.php(632)
#1    pwg_query /homez.51/loisirsl/www/phpwebgallery/include/functions_category.inc.php(104)
#2    get_categories_menu /homez.51/loisirsl/www/phpwebgallery/include/menubar.inc.php(43)
#3    include /homez.51/loisirsl/www/phpwebgallery/index.php(171)
in /homez.51/loisirsl/www/phpwebgallery/include/functions.inc.php on line 948


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /homez.51/loisirsl/www/phpwebgallery/include/functions_category.inc.php on line 106


Warning: 
SELECT
  id, name, permalink, representative_picture_id, comment, nb_images, uppercats,
  date_last, max_date_last, count_images, count_categories
  FROM phpwebgallery_categories INNER JOIN phpwebgallery_user_cache_categories
  ON id = cat_id and user_id = 1
  WHERE id_uppercat is NULL

  ORDER BY rank
;
[mysql error 1054] Unknown column 'permalink' in 'field list'
#0    my_error /homez.51/loisirsl/www/phpwebgallery/include/functions.inc.php(632)
#1    pwg_query /homez.51/loisirsl/www/phpwebgallery/include/category_cats.inc.php(78)
#2    include /homez.51/loisirsl/www/phpwebgallery/index.php(249)
in /homez.51/loisirsl/www/phpwebgallery/include/functions.inc.php on line 948


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /homez.51/loisirsl/www/phpwebgallery/include/category_cats.inc.php on line 82

Warning: Cannot modify header information - headers already sent by (output started at /homez.51/loisirsl/www/phpwebgallery/include/functions.inc.php:947) in /homez.51/loisirsl/www/phpwebgallery/include/page_header.php on line 103

#2 2009-01-28 08:28:48

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: Problème d'installation

http://www.loisirs-luemschwiller.org/phpwebgallery/upgrade.php


Ajoute donc la ligne:

define('PHPWG_IN_UPGRADE', true);


dans include/mysql.inc.php
cette ligne doit être avant celle-ci:

?>


Puis tu relances le lien...
Tu viens nous donner le résultat.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#3 2009-01-29 08:39:17

Rémy
Invité

Re: Problème d'installation

Je viens de rajouter la ligne dans mysql.inc.php et suis allé au lien http://www.loisirs-luemschwiller.org/ph … pgrade.php

voici l'affichage
No upgrade required, the database structure is up to date

en allant http://www.loisirs-luemschwiller.org/phpwebgallery/  le problème persiste toujours.

A propos même dans la gestion des catégories celle ci n'apparaisse pas

Merci beaucoup de votre aide

#4 2009-01-29 09:35:18

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: Problème d'installation

Je vais te dépanner mais je voulais en être certain.

Tu t'enregistres STP sur le forum et je t'enverrai un MP.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#5 2009-01-29 14:30:13

Rémy
Invité

Re: Problème d'installation

C'est fait

et d'avance Merci

#6 2009-01-29 15:39:13

ddtddt
Équipe Piwigo
Quetigny (21) - France
2007-07-27
16208

Re: Problème d'installation

Rémy a écrit:

C'est fait

et d'avance Merci

tu post un message en étant connecté :)


Vous aimez Piwigo alors n'hésitez pas à participer avec nous, plus d'infos sur la page "Contribuer à Piwigo". Si vous n'avez pas beaucoup de temps et que vous souhaitez nous soutenir vous pouvez aussi le faire par un don.

Hors ligne

#7 2009-01-29 15:43:04

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: Problème d'installation

Pour l'instant, je ne peux toujours pas t'envoyer un MP.


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#8 2009-01-30 01:42:32

Remy
Membre
2008-08-13
16

Re: Problème d'installation

Je me suis bien inscrit sur le Forum

Hors ligne

#9 2009-01-30 09:20:21

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: Problème d'installation

MP envoyé...


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#10 2009-01-31 22:50:51

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: Problème d'installation

Le problème est assez bizarre, souvenez-vous la semaine passée...

[Forum, post 104584 by VDigital in topic 14676] A votre avis [message d'erreur]

Cette semaine, Rémy nous propose une version réchauffée.


Rémy était en 1.6.2 (en théorie).
Après le transfert des modules de la 1.7.3, il devait lancer upgrade.php (on va dire qu'il l'a réellement bien fait).

Pour preuve si je relance:
No database upgrade required, do not refresh the page

En fait, la table history_summary existe déjà. J'en conclue que upgrade_1.6.2.php s'est bien exécuté avant ma relance.
Et c'est là que le problème réside, car si history_summary existe bien,
history_backup n'existe pas (et on n'est pas chez free) alors que la table history a encore sa structure 1.6.2.

Je surnage dans un monde parallèle à phpwebgallery.
J'ai toutes les données (Merci Rémy), on saura identifier cette situation même si cela me semble totalement incohérent.

Ceci dit, je vais réparer la galerie de Rémy dès demain.

@+

(Je me demande si en 1.7.3, install.php ne se déroulerait pas sans problème même sur une base 1.6.2 existante.)


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#11 2009-02-01 10:15:33

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: Problème d'installation

VDigital a écrit:

(Je me demande si en 1.7.3, install.php ne se déroulerait pas sans problème même sur une base 1.6.2 existante.)

Confirmé !!!

Procédure d'install... Lancée sur une base existante 1.6.2

Utilisateurs vous devez suivre la procédure de mise à jour.
Upgrade en anglais.

Surtout ne lancez pas une installation sur une ancienne galerie.
Merci.









(Coté support):

Il faut mettre en commentaire le "die" dans upgrade.php

// +-----------------------------------------------------------------------+
// |                            upgrade launch                             |
// +-----------------------------------------------------------------------+

else
{
  if (in_array(PREFIX_TABLE.'history_summary', $tables))
  {
    //die('No database upgrade required, do not refresh the page');
  }

Puis lancer la bonne version d'upgrade ??? Laquelle? Dans le cas présent, c'était upgrade_1.6.2.php qu'il aurait dû dérouler au lieu de l'install.php
Donc on lance directement: .../upgrade.php?version=1.6.2

Cela sort plein de warnings mais cela marche...
Un petit coup de RV DB Integrity nous donnera satisfaction.

Ouf...!!!


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact