Annonce

  •  » Plugins
  •  » Download Multi - 0.9

#151 2009-08-12 10:45:44

flipflip
Membre
Lyon
2005-03-19
2316

Re: Download Multi - 0.9

Vraiment bizarre, essai de voir avec eux si il n'ont pas un cache quelque part.


Le cerveau à des capacités tellement étonnantes qu’aujourd’hui pratiquement tout le monde en à un

Mon site : http://www.blogoflip.fr

Hors ligne

#152 2009-08-12 10:56:50

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: Download Multi - 0.9

J'ai le même soucis chez Free.fr

...

Tu es certains de ton package ?


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#153 2009-08-12 11:04:03

flipflip
Membre
Lyon
2005-03-19
2316

Re: Download Multi - 0.9

Je viens de le télécharger directement depuis PEM est c'est bien la version 0.9-1 qui est hébergé. Dans le doute j'ai fais le test sur ma galerie qui est hébergé sur mon serveur. Je te joins une capture d'écran pour voir à quoi devrait ressembler l'admin.


Le cerveau à des capacités tellement étonnantes qu’aujourd’hui pratiquement tout le monde en à un

Mon site : http://www.blogoflip.fr

Hors ligne

#154 2009-08-12 11:05:59

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: Download Multi - 0.9

C'est bon, le panneau d'admin est maintenant correcte.
Je l'ai rempli, la configuration est prise en compte mais toujours les warnings en en-tête.


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#155 2009-08-12 11:07:03

flipflip
Membre
Lyon
2005-03-19
2316

Re: Download Multi - 0.9

T'a bien sélectionné un groupe ?


Le cerveau à des capacités tellement étonnantes qu’aujourd’hui pratiquement tout le monde en à un

Mon site : http://www.blogoflip.fr

Hors ligne

#156 2009-08-12 11:09:38

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: Download Multi - 0.9

Ca y est !!!! j'ai trouvé !!!

Il FAUT cocher la case pour avoir un commentaire. Par habitude je ne la cochais pas car pas envie de cette option lol

Je viens aussi de la décocher et plus de messages d'erreur !
Étrange comportement mais en tous cas, là c'est tout rentré dans l'ordre.

Regardes de ton coté si il ne manque pas un contrôle quelque part pour éviter ce désagrément :-)

Merci pour le suivi ;-)

Dernière modification par Gotcha (2009-08-12 11:12:47)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#157 2009-08-12 11:15:36

flipflip
Membre
Lyon
2005-03-19
2316

Re: Download Multi - 0.9

ATTENTION
Il y a un problème dont je viens de me rendre compte, si, dans le pattern du nom de fichier des archives, vous ne mettez pas la balise [ rand ] alors il y aura soit une erreur soit les archives s'écraseront au fur et à mesure.

[Bugtracker] ticket 1120

Dernière modification par flipflip (2009-08-12 11:17:13)


Le cerveau à des capacités tellement étonnantes qu’aujourd’hui pratiquement tout le monde en à un

Mon site : http://www.blogoflip.fr

Hors ligne

#158 2009-08-12 11:23:11

flipflip
Membre
Lyon
2005-03-19
2316

Re: Download Multi - 0.9

Ca y est !!!! j'ai trouvé !!!

Il FAUT cocher la case pour avoir un commentaire. Par habitude je ne la cochais pas car pas envie de cette option lol

Y a un truc que je comprend pas, au début tu me parle de warning sur group_id et maintenant c'est sur les commentaires... J'avoue ne pas comprendre ou tu a vraiment un problème ?

L'erreur sur group_id est dans le cas ou il n'y a pas de groupe sélectionné (nouvelle installation) ou alors lors du mise à jour du plugin (passage de la version 0.9 à 0.9-1) car le format de stockage de la configuration des groupes à changé. Dans tout les cas que se soit pour une mise à jour ou un nouvelle installation il faut absolument re-valider les paramètres du plugin !


Le cerveau à des capacités tellement étonnantes qu’aujourd’hui pratiquement tout le monde en à un

Mon site : http://www.blogoflip.fr

Hors ligne

#159 2009-08-12 11:58:47

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: Download Multi - 0.9

flipflip a écrit:

Dans tout les cas que se soit pour une mise à jour ou un nouvelle installation il faut absolument re-valider les paramètres du plugin !

J'ai surement homis de le faire à un moment ou a un autre. Je n'ai pas cherché à comparer les messages d'erreurs ça c'est vrai.

On va repartir de zero pour bien comprendre.
Je pars d'une installation propre, le plugin aillant était désactivé pour effacé.
Téléchargement via l'installateur automatique.
Installation.
Activation => Là j'ai le message suivant:

<br />
<b>Notice</b>:  Undefined index:  group_id in <b>/home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php</b> on line <b>56</b><br />
<br />
<b>Warning</b>:  in_array() [<a href='function.in-array'>function.in-array</a>]: Wrong datatype for second argument in <b>/home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php</b> on line <b>56</b><br />

<br />
<b>Notice</b>:  Undefined index:  group_id in <b>/home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php</b> on line <b>56</b><br />
<br />
<b>Warning</b>:  in_array() [<a href='function.in-array'>function.in-array</a>]: Wrong datatype for second argument in <b>/home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php</b> on line <b>56</b><br />

<br />
<b>Notice</b>:  Undefined index:  group_id in <b>/home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php</b> on line <b>56</b><br />
<br />
<b>Warning</b>:  in_array() [<a href='function.in-array'>function.in-array</a>]: Wrong datatype for second argument in <b>/home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php</b> on line <b>56</b><br />

<br />
<b>Warning</b>:  Cannot modify header information - headers already sent by (output started at /home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php:56) in <b>/home/gotcha/public_html/galerie/include/page_header.php</b> on line <b>98</b><br />

On va dire que c'est logique puis que le plugin n'est pas encore administré. Néanmoins, c'est gênant de voir des warning et donc pas logique quand même lol

A présent je renseigne tout SAUF l'activation du commentaire.
Là j'ai le message suivant après avoir bien validé mes réglages:

<br />
<b>Notice</b>:  Undefined index:  group_id in <b>/home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php</b> on line <b>56</b><br />
<br />
<b>Warning</b>:  in_array() [<a href='function.in-array'>function.in-array</a>]: Wrong datatype for second argument in <b>/home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php</b> on line <b>56</b><br />

<br />
<b>Notice</b>:  Undefined index:  group_id in <b>/home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php</b> on line <b>56</b><br />
<br />
<b>Warning</b>:  in_array() [<a href='function.in-array'>function.in-array</a>]: Wrong datatype for second argument in <b>/home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php</b> on line <b>56</b><br />

<br />
<b>Notice</b>:  Undefined index:  group_id in <b>/home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php</b> on line <b>56</b><br />
<br />
<b>Warning</b>:  in_array() [<a href='function.in-array'>function.in-array</a>]: Wrong datatype for second argument in <b>/home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php</b> on line <b>56</b><br />

<br />
<b>Warning</b>:  Cannot modify header information - headers already sent by (output started at /home/gotcha/public_html/galerie/plugins/download_multi/include/class.inc.php:56) in <b>/home/gotcha/public_html/galerie/include/page_header.php</b> on line <b>98</b><br />

Maintenant, je clique sur "Activer les commentaires dans le fichier zip, ne fonctionne pas chez free.fr" et je donne un texte au champs du dessous.
Je valide.
Et là: plus de warnings !
J'ai beau décocher l'option "Activer les commentaires dans le fichier zip, ne fonctionne pas chez free.fr" les warnings ne réapparaissent plus.

Voilà.

*********************
Pour [rand] peut-on utiliser "[date][rand]" ??


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#160 2009-08-12 12:55:23

flipflip
Membre
Lyon
2005-03-19
2316

Re: Download Multi - 0.9

Ok maintenant c'est plus clair. Au contraire je n'ai pas d'explication sur le pourquoi des warnings même après validation. Tu est sûr d'avoir sélectionné au moins groupe dans le contexte que tu me donne ? Mais à la limite un contrôle a été rajouté pour les prochaines versions donc il n'y a pas lieu de s'affoler plus que ça, car dans les deux cas d'erreur que tu donne se sont les même erreurs et sur le paramètre group_id donc rien à voir avec les commentaires d'archives.

J'ai beau décocher l'option "Activer les commentaires dans le fichier zip, ne fonctionne pas chez free.fr" les warnings ne réapparaissent plus.

Une fois les paramètres enregistrer c'est normal que l'erreur ne soit plus produite. En gros php signale que la variable group_id est vide et il aime pas, maintenant que la config est enregistré group_id contient une valeur donc sa passe.

Pour [rand] peut-on utiliser "[date][rand]" ??

Elles sont cumulables, tu peux même ajouter un autre texte genre : mesarchivesdu-[date]-[rand]


Le cerveau à des capacités tellement étonnantes qu’aujourd’hui pratiquement tout le monde en à un

Mon site : http://www.blogoflip.fr

Hors ligne

#161 2009-08-12 14:33:03

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: Download Multi - 0.9

Par curiosité, sur ma galerie, tu peux refaire la manipulation à ma place pour mieux t'en rendre compte ^^ Mais bon, maintenant tout va bien :-)

Ok pour [rand].

Merci


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#162 2009-08-13 08:19:55

flipflip
Membre
Lyon
2005-03-19
2316

Re: Download Multi - 0.9

Maintenant que tu a validé les paramètres il n'est pas possible de reproduire le problème sans être obligé de tout désinstaller.


Le cerveau à des capacités tellement étonnantes qu’aujourd’hui pratiquement tout le monde en à un

Mon site : http://www.blogoflip.fr

Hors ligne

#163 2009-08-13 09:25:29

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: Download Multi - 0.9

flipflip a écrit:

Maintenant que tu a validé les paramètres il n'est pas possible de reproduire le problème sans être obligé de tout désinstaller.

Exacte.


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

#164 2009-08-17 15:56:23

flipflip
Membre
Lyon
2005-03-19
2316

Re: Download Multi - 0.9

C'est officiel et décidé, à partir de la version 0.9-2, je suis obligé d'arrêter le support de la lib PclZip au profit de la class ZipArchive car ces quelques 100 lignes de codes me prenais bien trop de temps surtout que nous n'utilisons pas cette lib en interne.

Quel changement pour vous ? Il est probable que ceux qui héberge leurs galeries chez des gratuits, free.fr par exemple, ne puisse tout simplement ne plus utilisé le plugin.

Je suis désolé mais cette décision était nécessaire et surtout elle m'a été plus ou moins imposée par mon responsable. Si quelqu'un veut rependre cette partie c'est avec plaisir que je lui donne le bébé.

Pour éviter des problèmes lors de l'installation j'ai ajouté un contrôle si la class ZipArchive n'est pas présente alors le plugin refuse de s'installer.


Le cerveau à des capacités tellement étonnantes qu’aujourd’hui pratiquement tout le monde en à un

Mon site : http://www.blogoflip.fr

Hors ligne

#165 2009-08-17 20:34:43

Gotcha
Equipe Piwigo
Pierrelatte (26)
2007-03-14
13331

Re: Download Multi - 0.9

Pas trop grave encore, il reste les anciennes version pour fonctionner chez Free par exemple ;-)


Ayez comme premier réflexe de consulter le wiki.
Ensuite, veuillez effectuer une recherche sur le forum avant de poser votre question.

LE FAIRE EST LE REVELATEUR DE L'ETRE

Hors ligne

  •  » Plugins
  •  » Download Multi - 0.9

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2020 · Contact