Annonce

  •  » Plugins
  •  » [Plugin] nbc UserAdvManager

#1006 2013-10-22 13:30:56

Jalil
Membre
2013-10-15
34

Re: [Plugin] nbc UserAdvManager

Je suis d'accord que c'est étrange ...

Et je vais vous étonner :

L'utilisateur en question est à UAM_validated = "false" !

De même que 2 autres qui se sont également inscrits hier après-midi. Que je  soupçonne donc d'avoir le même problème ... (et donc de pouvoir accéder à la galerie ?)

Les 2 utilisateurs de ce matin n'ont pas eu le problème, ils sont bien à "true".

Le seul changement que j'ai fait ce matin, a priori avant les 2 inscriptions qui ont bien fonctionné, est de désactiver dans UAM le délai et la gestion automatique des confirmations. C'est une piste ?

Je vous renvoie un accès ?

Hors ligne

#1007 2013-10-22 13:42:09

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Plugin] nbc UserAdvManager

Le [Bugtracker] ticket 2979 a été corrigé dans la version 2.50.14.

@Jalil : Mettez à jour et vous pourrez réactiver la gestion automatique des utilisateurs non validés.

Hors ligne

#1008 2013-10-22 13:45:42

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Plugin] nbc UserAdvManager

Jalil a écrit:

Le seul changement que j'ai fait ce matin, a priori avant les 2 inscriptions qui ont bien fonctionné, est de désactiver dans UAM le délai et la gestion automatique des confirmations. C'est une piste ?

Certainement...

Jalil a écrit:

Je vous renvoie un accès ?

Mettez d'abord à jour le plugin (voir mon post précédent) et testez en créant un user par la voie "normale" de l'utilisateur.

Hors ligne

#1009 2013-10-22 17:59:24

Jalil
Membre
2013-10-15
34

Re: [Plugin] nbc UserAdvManager

Bon alors, j'ai mis à jour et réactivé la gestion auto des délai de confirmation.

Bon, je n'ai pas reproduit le problème. A voir à l'avenir si cela se reproduit ..

Par contre, j'ai d'autres remarques (Désolé, au moins j'espère faire avancer le plugin) :

1 - Lorsque je me suis inscrit avec un e-mail secondaire, le message qui s'affiche sur le site est "Inscription réussie, vous recevrez bientôt un email avec vos identifiants. Bienvenue !"
Rien ne me dit que je vais recevoir un e-mail de confirmation qu'il va falloir que je valide.

=> AMELIORATION 1 : Remplacer dans le cas de confirmation le message de création de compte standard par un nouveau message (paramétrable ?) qui précise bien que le compte doit être validé avant de pouvoir se connecter avec.

2 - Lorsque j'essaie de me connecter avec mes identifiants à mon compte NON validé, je n'ai aucun message d'erreur. Si je mets un login incorrect, j'ai bien un message de login incorrect. Mais si le login est correct et le compte non validé, je retombe juste sur la page d’accueil. Je ne sais pas ce qui se passe ....

=> CORRECTION : J'ai paramétré un message de refus d'ouverture de session. Celui-ci devrait être utilisé.

3 - Si je coche "m'envoyer un e-mail avec mes identifiants" lors de l'inscription, je reçois du coup 2 e-mails. L'un avec les identifants qui dit bienvenue, l'autre qui dit qu'il faut valider le compte avec un lien .... Cela peut être confusant (ça se dit ?)

=> AMELIORATION 2 : Supprimer le mail de base avec les identifiants et inclure ces identifiants dans le mail de confirmation de compte (celui avec le lien de confirmation).

4 - Lorsque j'ai cliqué sur le lien de confirmation, le message que j'ai eu sur le site est : "Clé d'activation incorrecte / expirée ou inscription déjà validée." alors que je venais à peine de créer le compte et de recevoir le mail !
Mais ça a marché quand même et je me suis retrouvé connecté automatiquement sur mon nouveau compte.

=> CORRECTION : Le message aurait dû être "Compte activé avec succès" ou quelque chose du genre.
Note : J'ai bien eu le mon message l'autre jour, donc quelque chose a du faire changer le comportement du plugin cette fois ci ....

Dernière modification par Jalil (2013-10-22 18:03:56)

Hors ligne

#1010 2013-10-22 18:27:18

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Plugin] nbc UserAdvManager

Jalil a écrit:

Par contre, j'ai d'autres remarques (Désolé, au moins j'espère faire avancer le plugin) :

Faut pas être désolé ! C'est comme cela que les choses peuvent évoluer ;-)

Jalil a écrit:

1 - Lorsque je me suis inscrit avec un e-mail secondaire, le message qui s'affiche sur le site est "Inscription réussie, vous recevrez bientôt un email avec vos identifiants. Bienvenue !"
Rien ne me dit que je vais recevoir un e-mail de confirmation qu'il va falloir que je valide.

=> AMELIORATION 1 : Remplacer dans le cas de confirmation le message de création de compte standard par un nouveau message (paramétrable ?) qui précise bien que le compte doit être validé avant de pouvoir se connecter avec.

Ce devrait être le cas si vous avez configuré le message d'information. Chez moi, par exemple, lorsqu'un utilisateur s'inscrit, il a le message suivant qui s'affiche en rouge et en bandeau sur la galerie :
"Désolé, vous n'avez pas encore validé votre inscription et vous ne pouvez pas vous connecter maintenant. Merci de vérifier votre boite aux lettres. Vous devriez y trouver un message comportant un lien pour valider votre inscription. Si ce n'est pas le cas, merci de contacter l'administrateur de la galerie."

Difficile de faire plus clair et lisible ^^

Activez "Rejeter les connexions des utilisateurs non confirmés" et personnalisez le texte.

Jalil a écrit:

2 - Lorsque j'essaie de me connecter avec mes identifiants à mon compte NON validé, je n'ai aucun message d'erreur. Si je mets un login incorrect, j'ai bien un message de login incorrect. Mais si le login est correct et le compte non validé, je retombe juste sur la page d’accueil. Je ne sais pas ce qui se passe ....

=> CORRECTION : J'ai paramétré un message de refus d'ouverture de session. Celui-ci devrait être utilisé.

Je confirme que c'est bien ce message qui devrait s'afficher (cf. plus haut). Le texte a-t-il été personnalisé ?

Jalil a écrit:

3 - Si je coche "m'envoyer un e-mail avec mes identifiants" lors de l'inscription, je reçois du coup 2 e-mails. L'un avec les identifants qui dit bienvenue, l'autre qui dit qu'il faut valider le compte avec un lien .... Cela peut être confusant (ça se dit ?)

=> AMELIORATION 2 : Supprimer le mail de base avec les identifiants et inclure ces identifiants dans le mail de confirmation de compte (celui avec le lien de confirmation).

Il n'est pas encore possible, techniquement, de fusionner les mails "standards" envoyé par Piwigo avec d'autres contenus. Cette option "envoyer un e-mail avec mes identifiants" est relativement récente et il n'y a pas moyen d'interagir avec elle pour l'instant.

Maintenant, de mon point de vue, le contenu et le sujet du mail avec les identifiants et celui de validation de l'inscription sont bien distincts et devrait le rester. En effet, un utilisateur aura tendance à conserver le mail avec ses identifiants (en guise d'aide mémoire) et supprimer celui pour la validation après usage qui ne lui servira plus ultérieurement.

Jalil a écrit:

4 - Lorsque j'ai cliqué sur le lien de confirmation, le message que j'ai eu sur le site est : "Clé d'activation incorrecte / expirée ou inscription déjà validée." alors que je venais à peine de créer le compte et de recevoir le mail !
Mais ça a marché quand même et je me suis retrouvé connecté automatiquement sur mon nouveau compte.

=> CORRECTION : Le message aurait dû être "Compte activé avec succès" ou quelque chose du genre.
Note : J'ai bien eu le mon message l'autre jour, donc quelque chose a du faire changer le comportement du plugin cette fois ci ....

Là, faudra que j'investigue plus profondément sur votre galerie car je n'ai pas reproduit sur mes galeries (en ligne et hors ligne). J'ai toujours eu le message de validation de l'inscription après avoir cliqué sur le lien dans le mail reçu. Exemple avec mon texte personnalisé :
"Bonjour truc ! Merci d'avoir confirmé votre inscription à la galerie. Veuillez cliquer sur l'icone de retour en haut et à droite pour vous connecter et profiter des images!"


Renvoyez moi un accès webmaster et je regarderai ce dernier point (et ferai des essais complets). Mais faudra patienter un peu car je ne serai dispo qu'en fin de soirée.

Hors ligne

#1011 2013-10-22 18:42:00

Jalil
Membre
2013-10-15
34

Re: [Plugin] nbc UserAdvManager

Eric a écrit:

Jalil a écrit:

Par contre, j'ai d'autres remarques (Désolé, au moins j'espère faire avancer le plugin) :

Faut pas être désolé ! C'est comme cela que les choses peuvent évoluer ;-)

Jalil a écrit:

1 - Lorsque je me suis inscrit avec un e-mail secondaire, le message qui s'affiche sur le site est "Inscription réussie, vous recevrez bientôt un email avec vos identifiants. Bienvenue !"
Rien ne me dit que je vais recevoir un e-mail de confirmation qu'il va falloir que je valide.

=> AMELIORATION 1 : Remplacer dans le cas de confirmation le message de création de compte standard par un nouveau message (paramétrable ?) qui précise bien que le compte doit être validé avant de pouvoir se connecter avec.

Ce devrait être le cas si vous avez configuré le message d'information. Chez moi, par exemple, lorsqu'un utilisateur s'inscrit, il a le message suivant qui s'affiche en rouge et en bandeau sur la galerie :
"Désolé, vous n'avez pas encore validé votre inscription et vous ne pouvez pas vous connecter maintenant. Merci de vérifier votre boite aux lettres. Vous devriez y trouver un message comportant un lien pour valider votre inscription. Si ce n'est pas le cas, merci de contacter l'administrateur de la galerie."

Difficile de faire plus clair et lisible ^^

Activez "Rejeter les connexions des utilisateurs non confirmés" et personnalisez le texte.

En fait, vous répondez là à mon point 2. Je vous réponds donc plus bas par rapport à votre retour.

Ici, je voulais parler du message qui s'affiche en vert SUR LE SITE, directement après avoir validé le formulaire d'inscription.

Eric a écrit:

Jalil a écrit:

2 - Lorsque j'essaie de me connecter avec mes identifiants à mon compte NON validé, je n'ai aucun message d'erreur. Si je mets un login incorrect, j'ai bien un message de login incorrect. Mais si le login est correct et le compte non validé, je retombe juste sur la page d’accueil. Je ne sais pas ce qui se passe ....

=> CORRECTION : J'ai paramétré un message de refus d'ouverture de session. Celui-ci devrait être utilisé.

Je confirme que c'est bien ce message qui devrait s'afficher (cf. plus haut). Le texte a-t-il été personnalisé ?

J'ai bien :
- Rejeter les connexions des utilisateurs non confirmés : Activer
- Le texte en dessous : "Désolé, votre inscription n'est pas encore validée et vous ne pouvez pas vous connecter maintenant."

Problème vérifiable par inscription sur ma galerie : http://jalil.arfaoui.net/photos
Test effectué sur Internet Explorer.

Eric a écrit:

Jalil a écrit:

3 - Si je coche "m'envoyer un e-mail avec mes identifiants" lors de l'inscription, je reçois du coup 2 e-mails. L'un avec les identifants qui dit bienvenue, l'autre qui dit qu'il faut valider le compte avec un lien .... Cela peut être confusant (ça se dit ?)

=> AMELIORATION 2 : Supprimer le mail de base avec les identifiants et inclure ces identifiants dans le mail de confirmation de compte (celui avec le lien de confirmation).

Il n'est pas encore possible, techniquement, de fusionner les mails "standards" envoyé par Piwigo avec d'autres contenus. Cette option "envoyer un e-mail avec mes identifiants" est relativement récente et il n'y a pas moyen d'interagir avec elle pour l'instant.

Maintenant, de mon point de vue, le contenu et le sujet du mail avec les identifiants et celui de validation de l'inscription sont bien distincts et devrait le rester. En effet, un utilisateur aura tendance à conserver le mail avec ses identifiants (en guise d'aide mémoire) et supprimer celui pour la validation après usage qui ne lui servira plus ultérieurement.

OK pour moi. Il n'est pas choquant d'en rester là pour le moment.

Eric a écrit:

Jalil a écrit:

4 - Lorsque j'ai cliqué sur le lien de confirmation, le message que j'ai eu sur le site est : "Clé d'activation incorrecte / expirée ou inscription déjà validée." alors que je venais à peine de créer le compte et de recevoir le mail !
Mais ça a marché quand même et je me suis retrouvé connecté automatiquement sur mon nouveau compte.

=> CORRECTION : Le message aurait dû être "Compte activé avec succès" ou quelque chose du genre.
Note : J'ai bien eu le mon message l'autre jour, donc quelque chose a du faire changer le comportement du plugin cette fois ci ....

Là, faudra que j'investigue plus profondément sur votre galerie car je n'ai pas reproduit sur mes galeries (en ligne et hors ligne). J'ai toujours eu le message de validation de l'inscription après avoir cliqué sur le lien dans le mail reçu. Exemple avec mon texte personnalisé :
"Bonjour truc ! Merci d'avoir confirmé votre inscription à la galerie. Veuillez cliquer sur l'icone de retour en haut et à droite pour vous connecter et profiter des images!"


Renvoyez moi un accès webmaster et je regarderai ce dernier point (et ferai des essais complets). Mais faudra patienter un peu car je ne serai dispo qu'en fin de soirée.

Alors sur ce dernier point, je crois avoir compris entre temps ce qui provoque le bug :
Je clique sur le lien de confirmation : photos?key=XXXX&userid=YYYYY
Le site m'affiche bien un message de confirmation en vert. Super !
Puis je veux me connecter. Je remplis donc mon login et password dans le menu à gauche, SANS QUITTER LA PAGE de confirmation.
Le site me connecte .... puis me ramène à la page ou j'étais ... à savoir photos?key=XXXX&userid=YYYYY.
Le site essaie donc à nouveau de valider ma clé, d'où le message d'erreur en rouge !

Il faudrait donc, selon moi, après connexion de l'utilisateur, tester si l'URL précédente contient un paramètre key, et le cas échéant le supprimer de l'URL avant de rediriger dessus ...

Hors ligne

#1012 2013-10-22 18:50:22

Jalil
Membre
2013-10-15
34

Re: [Plugin] nbc UserAdvManager

Toujours sur le point 4, c'est d'autant plus étonnant que si j'ouvre une page dans un autre onglet, ou même je clique simplement sur un lien du site, je vois que je suis déjà connecté automatiquement par la confirmation d'inscription (L'encadré Identification du menu dit "Bonjour machin").

Mais juste après la confirmation d'inscription, j'ai pourtant le formulaire de login dans le menu et non pas "Bonjour machin". Comme si au moment de l'affichage du menu, le site ne "sait pas encore" que je suis connecté ....

Hors ligne

#1013 2013-10-22 18:54:59

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Plugin] nbc UserAdvManager

Jalil a écrit:

En fait, vous répondez là à mon point 2. Je vous réponds donc plus bas par rapport à votre retour.

Ici, je voulais parler du message qui s'affiche en vert SUR LE SITE, directement après avoir validé le formulaire d'inscription.
(...)
J'ai bien :
- Rejeter les connexions des utilisateurs non confirmés : Activer
- Le texte en dessous : "Désolé, votre inscription n'est pas encore validée et vous ne pouvez pas vous connecter maintenant."

Problème vérifiable par inscription sur ma galerie : http://jalil.arfaoui.net/photos
Test effectué sur Internet Explorer.

J'ai testé une inscription sur votre galerie et je n'ai pas eu de message vert après avoir validé le formulaire... Et je n'ai pas eu non plus le message indiquant que l'inscription est en attente de validation :-(

Jalil a écrit:

Alors sur ce dernier point, je crois avoir compris entre temps ce qui provoque le bug :
Je clique sur le lien de confirmation : photos?key=XXXX&userid=YYYYY
Le site m'affiche bien un message de confirmation en vert. Super !
Puis je veux me connecter. Je remplis donc mon login et password dans le menu à gauche, SANS QUITTER LA PAGE de confirmation.
Le site me connecte .... puis me ramène à la page ou j'étais ... à savoir photos?key=XXXX&userid=YYYYY.
Le site essaie donc à nouveau de valider ma clé, d'où le message d'erreur en rouge !

Il faudrait donc, selon moi, après connexion de l'utilisateur, tester si l'URL précédente contient un paramètre key, et le cas échéant le supprimer de l'URL avant de rediriger dessus ...

Effectivement, c'est anormal mais je ne reproduit pas chez moi... Il y a quelque chose qui ne tourne pas rond sur votre galerie. En plus, 15 minutes après m'être inscrit, je n'ai toujours pas reçu le mail pour confirmer l'inscription.

J'ai l'impression que la mise à jour du plugin ne s'est pas correctement déroulée. Il faudrait que je vois par moi-même.

Hors ligne

#1014 2013-10-22 19:05:24

Jalil
Membre
2013-10-15
34

Re: [Plugin] nbc UserAdvManager

Bon, je vous rouvre un compte webmestre ....

Hors ligne

#1015 2013-10-22 19:15:26

Jalil
Membre
2013-10-15
34

Re: [Plugin] nbc UserAdvManager

C'est envoyé (mail).

Si au passage, vous me trouvez une explication au fait que l'utilisateur "julien" (28) aient pu se connecter (248 images vues si j'en crois AStat.2) alors qu'il n'est toujours pas validé ...

Hors ligne

#1016 2013-10-22 19:23:28

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Plugin] nbc UserAdvManager

Bien reçu les identifiants. Je regarde dès que je peux.

Hors ligne

#1017 2013-10-23 00:33:47

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Plugin] nbc UserAdvManager

J'ai trouvé la raison de tous les problèmes que vous rencontrez avec UAM. Tout est lié à la méthode de validation choisie qui est basée sur les status : Pour votre galerie, un utilisateur non validé est positionné avec le status "invité" (correspondant à Guest dans le code source de Piwigo) et un utilisateur validé est positionné avec le status "visiteur" (ou "User" dans le code).

Tout visiteur de passage non identifié sur la galerie est, de fait, en status "invité" (c'est l'utilisateur "Guest" présent dans les users par défaut de Piwigo). Et le fait d'utiliser ce status "invité" dans UAM pour catégoriser les utilisateurs non validés revient à ce qu'ils se trouvent avec des autorisations bancales : Inscrits, non validés mais ayant quand même l'accès...

C'est un cas de figure particulièrement tordu, faut reconnaitre. J'ai corrigé temporairement votre souci en configurant le status des utilisateurs non validés à "---------" dans UAM. Pour vos utilisateurs déjà inscrits mais pas validés (avec les status "invité"), il faut soit les valider manuellement via le plugin, soit les supprimer.

J'avais pensé, il y a quelques temps, à retirer cette fonction de positionnement sur les status car elle ne me parait plus très adaptée dans le cadre d'UAM. En effet, les status sont figés, non modifiables et ne devraient pas servir à catégoriser des utilisateurs pour leur donner accès à la galerie. Les groupes d'utilisateurs ou les niveaux de confidentialité sont plus adaptés.
Je vais donc surement retirer cette fonction dans la prochaine version, à moins que le besoin des utilisateurs du plugin soit motivé. Auquel cas, je pourrai simplement forcer la valeur du status pour les non validés à "-------". A voir...





Ensuite, concernant l'accès à la galerie immédiatement après avoir cliqué sur le lien de confirmation de l'inscription, il y a effectivement un problème de position. On peut s'identifier lorsqu'on est sur la page photos?key=XXXX&userid=YYYYY mais alors on recharge cette même page, ce qui relance le processus de validation qui échoue forcément (ne peut être utilisé qu'une seule fois). On se retrouve alors dans une situation perturbante où l'utilisateur est connecté avec succès à la galerie mais où il y a aussi un bandeau rouge indiquant "Clé d'activation incorrecte / expirée ou inscription déjà validée".

Techniquement parlant, c'est un comportement tout à fait logique et normal. Mais pour un utilisateur lambda, je comprends que ce soit perturbant. Mon idée serait de positionner une redirection automatique à partir de cette page photos?key=XXXX&userid=YYYYY vers la page d'accueil de la galerie. J'avais déjà mis çà en place dans une vieille version du plugin mais je ne rappelle plus pourquoi je l'ai retiré.

Cà me reviendra surement lorsque j'aurais recodé cela pour la prochaine version du plugin ;-)

En attendant, solution de contournement : Ajoutez un texte dans le bandeau vert de confirmation de l'inscription incitant l'utilisateur à cliquer sur le lien "Accueil" avant de se connecter.

Hors ligne

#1018 2013-10-23 01:18:37

Jalil
Membre
2013-10-15
34

Re: [Plugin] nbc UserAdvManager

Merci Eric, beau boulot !

Eric a écrit:

J'ai trouvé la raison de tous les problèmes que vous rencontrez avec UAM. Tout est lié à la méthode de validation choisie qui est basée sur les status : Pour votre galerie, un utilisateur non validé est positionné avec le status "invité" (correspondant à Guest dans le code source de Piwigo) et un utilisateur validé est positionné avec le status "visiteur" (ou "User" dans le code).

Tout visiteur de passage non identifié sur la galerie est, de fait, en status "invité" (c'est l'utilisateur "Guest" présent dans les users par défaut de Piwigo). Et le fait d'utiliser ce status "invité" dans UAM pour catégoriser les utilisateurs non validés revient à ce qu'ils se trouvent avec des autorisations bancales : Inscrits, non validés mais ayant quand même l'accès...

C'est un cas de figure particulièrement tordu, faut reconnaitre. J'ai corrigé temporairement votre souci en configurant le status des utilisateurs non validés à "---------" dans UAM. Pour vos utilisateurs déjà inscrits mais pas validés (avec les status "invité"), il faut soit les valider manuellement via le plugin, soit les supprimer.

J'avais pensé, il y a quelques temps, à retirer cette fonction de positionnement sur les status car elle ne me parait plus très adaptée dans le cadre d'UAM. En effet, les status sont figés, non modifiables et ne devraient pas servir à catégoriser des utilisateurs pour leur donner accès à la galerie. Les groupes d'utilisateurs ou les niveaux de confidentialité sont plus adaptés.
Je vais donc surement retirer cette fonction dans la prochaine version, à moins que le besoin des utilisateurs du plugin soit motivé. Auquel cas, je pourrai simplement forcer la valeur du status pour les non validés à "-------". A voir...

En effet, mais tout cela n'est pas très clair pour un débutant de Piwigo qui installe le plugin. En effet, c'est le réglage par défaut, car je ne me souviens pas avoir changé le statut sur lequel doit être positionné un visiteur non validé. En effet, cela ne change rien pour moi puisque j'ai paramétré que l'accès aux non validés doit être interdit.

Du coup, questions :
- Puis-je mettre le même statut pour les non confirmés et pour les confirmés (à savoir "Visiteur")?
- Ou vaut-il mieux laisser votre réglage pour les non confirmés : "---------"
- Ou vaut-il mieux que je supprimer carrément les statuts et que je remplace par 2 groupes "Confirmés" et "Non Confirmés" ?
- Est-il possible de rien mettre du tout ni dans status ni dans groupes ?

Eric a écrit:

Ensuite, concernant l'accès à la galerie immédiatement après avoir cliqué sur le lien de confirmation de l'inscription, il y a effectivement un problème de position. On peut s'identifier lorsqu'on est sur la page photos?key=XXXX&userid=YYYYY mais alors on recharge cette même page, ce qui relance le processus de validation qui échoue forcément (ne peut être utilisé qu'une seule fois). On se retrouve alors dans une situation perturbante où l'utilisateur est connecté avec succès à la galerie mais où il y a aussi un bandeau rouge indiquant "Clé d'activation incorrecte / expirée ou inscription déjà validée".

Techniquement parlant, c'est un comportement tout à fait logique et normal. Mais pour un utilisateur lambda, je comprends que ce soit perturbant. Mon idée serait de positionner une redirection automatique à partir de cette page photos?key=XXXX&userid=YYYYY vers la page d'accueil de la galerie. J'avais déjà mis çà en place dans une vieille version du plugin mais je ne rappelle plus pourquoi je l'ai retiré.

Cà me reviendra surement lorsque j'aurais recodé cela pour la prochaine version du plugin ;-)

En attendant, solution de contournement : Ajoutez un texte dans le bandeau vert de confirmation de l'inscription incitant l'utilisateur à cliquer sur le lien "Accueil" avant de se connecter.

Oui, on est bien d'accord que ce comportement, techniquement parfaitement logique, peut perturber l'utilisateur.
Mais ça me parait être une amélioration non urgente, du moment qu'on est bien connecté par la suite.

Par contre, ce qui n'est pas normal c'est que dans le menu (à l'arrivée sur le lien de confirmation), le bloc "Identification" me propose de me connecter alors que je le suis déjà ...



Enfin, avez-vous pu trouver une explication au fait que l'utilisateur "julien" (28) aient pu se connecter (248 images vues si j'en crois AStat.2) alors qu'il n'est toujours pas validé ... ?



Merci pour tout,

Hors ligne

#1019 2013-10-23 01:44:20

Eric
Équipe Piwigo
VALENCE (FR)
2005-03-25
4579

Re: [Plugin] nbc UserAdvManager

Jalil a écrit:

Du coup, questions :
- Puis-je mettre le même statut pour les non confirmés et pour les confirmés (à savoir "Visiteur")?
- Ou vaut-il mieux laisser votre réglage pour les non confirmés : "---------"

Si vous souhaitez continuer à gérer vos utilisateurs par leur status, laissez mon réglage.

Jalil a écrit:

- Ou vaut-il mieux que je supprimer carrément les statuts et que je remplace par 2 groupes "Confirmés" et "Non Confirmés" ?

Tout dépend jusqu'à quel niveau vous envisagez de gérer les permissions d'accès de vos utilisateurs. Imaginons que vous ayez une partie d'albums publics (vus par tout le monde), quelques albums privés pour les utilisateurs non-validés et le reste de vos albums privés pour les utilisateurs validés. Avec la gestion par groupes d'utilisateurs, il vous sera possible de définir les permissions d'accès à ces albums en fonction que l'utilisateur ait validé son inscription ou non.

Ceci n'est pas possible avec la gestion par status.

Jalil a écrit:

- Est-il possible de rien mettre du tout ni dans status ni dans groupes ?

Surtout pas ! C'est le principe même du plugin. Comment ferait-il pour catégoriser les utilisateurs en fonction de leur état de validation ?

Jalil a écrit:

Par contre, ce qui n'est pas normal c'est que dans le menu (à l'arrivée sur le lien de confirmation), le bloc "Identification" me propose de me connecter alors que je le suis déjà ...

Je ne pense pas. Le lien de confirmation n'effectue pas de connexion automatique. Il est donc nécessaire de s'identifier *après* avoir confirmé l'inscription.

Ou alors je n'ai pas compris votre raisonnement.

Jalil a écrit:

Enfin, avez-vous pu trouver une explication au fait que l'utilisateur "julien" (28) aient pu se connecter (248 images vues si j'en crois AStat.2) alors qu'il n'est toujours pas validé ... ?

Oui, cf mon post précédent :

Eric a écrit:

Et le fait d'utiliser ce status "invité" dans UAM pour catégoriser les utilisateurs non validés revient à ce qu'ils se trouvent avec des autorisations bancales : Inscrits, non validés mais ayant quand même l'accès...

Solution :

Eric a écrit:

Pour vos utilisateurs déjà inscrits mais pas validés (avec les status "invité"), il faut soit les valider manuellement via le plugin, soit les supprimer.

Hors ligne

#1020 2013-10-23 02:40:36

Jalil
Membre
2013-10-15
34

Re: [Plugin] nbc UserAdvManager

OK merci pour tout, c'est très clair !
(Nous sommes 2 insomniaques on dirait)

Dernier point de doute :

Eric a écrit:

Jalil a écrit:

Par contre, ce qui n'est pas normal c'est que dans le menu (à l'arrivée sur le lien de confirmation), le bloc "Identification" me propose de me connecter alors que je le suis déjà ...

Je ne pense pas. Le lien de confirmation n'effectue pas de connexion automatique. Il est donc nécessaire de s'identifier *après* avoir confirmé l'inscription.

Ou alors je n'ai pas compris votre raisonnement.

Il m'a bien semblé pendant mes tests qu'il y a avait eu connexion automatique ...
D'ailleurs, un simple F5 ou un clic sur "Accueil" remplaçait bien le bloc Identification par "Bonjour machin".
J'ai un doute, alors je referai un test demain ...

Hors ligne

  •  » Plugins
  •  » [Plugin] nbc UserAdvManager

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2021 · Contact