Annonce

  •  » Plugins
  •  » plugin "statistic" (non pris en compte)

#1 2008-01-20 11:02:28

galorbe
Membre
2006-10-07
30

plugin "statistic" (non pris en compte)

Bonjour les gens.
  J'ai installé le plugin "statistic" sur ma gallerie (phpWG 1.7) pour travailler avec "phpmyvisite" mais j'ai l'impression que les pages de ma galerie ne sont pas comptabilisées. Seul mes pages "html" du reste de mon site apparaissent dans les résultats. A noté que cela a marché qqes jours, puis plus rien. De plus, quand ça marche, phpmyvisite me donne par exemple 20 visiteurs, pour 60 l'historique de ma galerie... qui croire?
  Si, dans le cas ou le plugin "statistic" ne fonctionnerait pas, pourriez vous me dire ou coller les tags, dans quelle pages et a quel endroit?
  Pardon pour cette rafale de questions.
le site: www.galorbe.com (galerie = 'photo")

Edit: pour precision: le logo "phpmv" n'apparait pas sur mes pages.
edit2: j'ai ragardé les codes sources des pages, les tags n'apparaissent pas non plus (mais peut etre que je ne sais pas ou chercher).

Dernière modification par galorbe (2008-01-20 11:09:40)

Hors ligne

#2 2008-01-20 11:32:29

sakkhho
Membre
Paris
2007-04-02
1836

Re: plugin "statistic" (non pris en compte)

j'ai l'impression que le code est present sur toutes tes pages.
cherche <-- Plugin statistics-->
dans le code source.


Piwigo 2.3.5

Hors ligne

#3 2008-01-20 11:36:57

rub
Équipe Piwigo
Lille
2005-08-26
5239

Re: plugin "statistic" (non pris en compte)

sur index.php, il est présent et même 2 fois.
Tu as mis du google et du phpmyvisite, c'est peut-être le cause.

Et sinon, le comptage de l'histo et de phpmyvisite est différent (techniquement et fonctionnellement)

Hors ligne

#4 2008-01-20 11:51:14

galorbe
Membre
2006-10-07
30

Re: plugin "statistic" (non pris en compte)

Je dois m'y prendre comme une patate, mais je ne vois pas ces tags.
Effectivement, j'ai celles de phpmv et aussi celle de google analitic... croyez vous que cela pose problème? les non-prise en compte se faisaient sentir deja avant que je ne les rajoute.
Par contre, si vous me dite que les tags sont presents deux fois, il serait peut etre bien que je recommence tout proprement. En ce cas, comment puis je tout effacer et recoller mes tag?
Un grand merci à vous (et bienvenue Ruben ;) )

Hors ligne

#5 2008-01-20 12:12:47

rub
Équipe Piwigo
Lille
2005-08-26
5239

Re: plugin "statistic" (non pris en compte)

galorbe a écrit:

Je dois m'y prendre comme une patate, mais je ne vois pas ces tags.
Effectivement, j'ai celles de phpmv et aussi celle de google analitic... croyez vous que cela pose problème? les non-prise en compte se faisaient sentir deja avant que je ne les rajoute.
Par contre, si vous me dite que les tags sont presents deux fois, il serait peut etre bien que je recommence tout proprement. En ce cas, comment puis je tout effacer et recoller mes tag?

D'abord prend la dernière version qui corrige les doublons.
http://phpwebgallery.net/ext/extension_view.php?eid=174
http://forum.phpwebgallery.net/viewtopi … 077#p80077

Ensuite, essaie seulement avec google, puis seulement avec phpmyadmin pour voir si ca fonctionne.
(en même dans le bas de page)

galorbe a écrit:

Un grand merci à vous (et bienvenue Ruben ;) )

;-)

Hors ligne

#6 2008-01-20 12:26:06

sakkhho
Membre
Paris
2007-04-02
1836

Re: plugin "statistic" (non pris en compte)

attention j'ai l'impression que la derniere version n'insert aucun code...
comprend pas.


Piwigo 2.3.5

Hors ligne

#7 2008-01-20 12:38:26

galorbe
Membre
2006-10-07
30

Re: plugin "statistic" (non pris en compte)

J'ai donc mis la dernière version et je vais faire mes petits essais.
Chez moi, pas de probleme, il y a bien de quoi inserer le code, reste a voir si ça marche.
Merci encore à vous!

Hors ligne

#8 2008-01-20 12:40:49

sakkhho
Membre
Paris
2007-04-02
1836

Re: plugin "statistic" (non pris en compte)

j'ai modifier la derniere version...


Piwigo 2.3.5

Hors ligne

#9 2008-01-20 12:47:01

rub
Équipe Piwigo
Lille
2005-08-26
5239

Re: plugin "statistic" (non pris en compte)

sakkhho a écrit:

attention j'ai l'impression que la derniere version n'insert aucun code...
comprend pas.

C'est simple, j'avais écrit que je n'avais pas testé!

un or à la place du and et ca va mieux:

Code:

<?php
/*
Plugin Name: Statistics
Version: 1.7.f
Description: Add source code like Google Analytics on each page.
Plugin URI: http://phpwebgallery.net/ext/extension_view.php?eid=174
Author: Ruben & Sakkhho
Author URI: http://www.phpwebgallery.net
*/


if (!defined('PHPWG_ROOT_PATH')) die('Hacking attempt!');

define('STAT_DIR' , basename(dirname(__FILE__)));
define('STAT_PATH' , PHPWG_PLUGINS_PATH . STAT_DIR . '/');


function statistics_admin_menu($menu)
{
    array_push($menu, array('NAME' => 'Statistics',
      'URL' => get_admin_plugin_menu_link(STAT_PATH . 'admin/stat_admin.php')));
    return $menu;
}

function stat_candoit($type)
{
  global $conf, $user;

  $conf_statistics = explode("," , $conf['statistics']);

  $is_guest = (function_exists('is_a_guest') ? is_a_guest() : $user['is_the_guest']);

  if
  (
    (
      (($conf_statistics[0] == 'on') and ($type == 'header')) or 
      (($conf_statistics[1] == 'on') and ($type == 'tail'))
    ) and 
    (($conf_statistics[3] == 'on' and !is_admin()) or (empty($conf_statistics[3]))) and
    (($conf_statistics[4] == 'on' and !$is_guest) or (empty($conf_statistics[4])))
  )
  {
    return '
<!-- Plugin Statitics -->
'.$conf_statistics[2].'
<!-- Plugin Statitics -->';
  }
  else
  {
    return false;
  }
}

function stat_tail()
{
  global $template;

  if ($code_stat = stat_candoit('tail'))
  {
    $template->loadfile('tail');
    $template->uncompiled_code['tail'] = str_replace('</div> <!-- the_page -->', $code_stat.'
      </div> <!-- the_page -->', $template->uncompiled_code['tail']);
  }
}


function stat_header()
{
  global $template;

  if ($code_stat = stat_candoit('header'))
  {
    $template->assign_block_vars('head_element', array('CONTENT' => $code_stat));
  }
}


add_event_handler('get_admin_plugin_menu_links', 'statistics_admin_menu');
add_event_handler('loc_end_page_tail', 'stat_tail');
add_event_handler('loc_end_page_header', 'stat_header');

?>

Hors ligne

#10 2008-01-20 14:26:27

galorbe
Membre
2006-10-07
30

Re: plugin "statistic" (non pris en compte)

C'est bien la version 1.7.e que tu as modifié?
Faut donc que je la réinstalle.
Merci, vous etes des chefs!

Hors ligne

#11 2008-01-20 14:40:46

rub
Équipe Piwigo
Lille
2005-08-26
5239

Re: plugin "statistic" (non pris en compte)

galorbe a écrit:

C'est bien la version 1.7.e que tu as modifié?

C'est la 1.7.f.

Hors ligne

#12 2008-01-20 14:48:12

galorbe
Membre
2006-10-07
30

Re: plugin "statistic" (non pris en compte)

Ok, merci!

Hors ligne

#13 2008-01-20 14:50:03

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: plugin "statistic" (non pris en compte)

[HS]Frédéric, je change les images et liens vers ta galerie dans le BestOf cet après-midi.[/HS]


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

#14 2008-01-20 14:56:41

galorbe
Membre
2006-10-07
30

Re: plugin "statistic" (non pris en compte)

Wouahh.... merci oh grand gourou!!  :)
Honoré je suis.

Hors ligne

#15 2008-01-20 17:19:26

VDigital
Former Piwigo Team
Montpellier (FR)
2005-05-04
15126

Re: plugin "statistic" (non pris en compte)

Oui, mais tu cultives l'humour et les Arts dont la photographie...
8-)

PS: Nouvelle version en ligne: http://demo.phpwebgallery.net/index.php … ory/BestOf


Vincent -« Plus vidéaste averti que photographe amateur... »
La galerie - Le blog   

Piwigo est une application libre de gestion de photos en ligne.

Hors ligne

  •  » Plugins
  •  » plugin "statistic" (non pris en compte)

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact