Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Nicco
2007-04-30 11:56:15

oui c est clair que c est un peu compliqué comme présentation ..

je crois que j ai ouvert un poste sur le sujet du nouveau mod googlemap ou je parle de ces soucis... recherches un poste a moi qui parle de ca
j enumere les ptit soucis

sinon il vaut mieux demander au créateur du mod car moi je n utilise pas ca version du coup pour faire du support c est moins facile

sakkhho
2007-04-29 20:35:42

bonjour !

petite question sur l'install de ce mod :

dans le patch est il ecrit :

Index: install/config.sql
===================================================================
--- install/config.sql    (révision 1)
+++ install/config.sql    (copie de travail)
@@ -19,6 +19,11 @@
INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('rate','true','Rating pictures feature is enabled');
INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('rate_anonymous','true','Rating pictures feature is also enabled for visitors');
INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('page_banner','<h1>PhpWebGallery demonstration site</h1><p>My photos web site</p>','html displayed on the top each page of your gallery');
+INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('google_map_key','','Google map activation key');
+INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('google_map_activated','false','Activation of google map');
+INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('google_map_icon_rep','','Url for representant icon of google map');
+INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('google_map_icon_img','','Url for image icon of google map');
+INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('google_map_icon_cat','','Url for category icon of google map');

-- Notification by mail
INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('nbm_send_mail_as','','Send mail as param value for notification by mail');
Index: install/phpwebgallery_structure.sql
===================================================================
--- install/phpwebgallery_structure.sql    (révision 1)
+++ install/phpwebgallery_structure.sql    (copie de travail)
@@ -37,6 +37,8 @@
   `uppercats` varchar(255) NOT NULL default '',
   `commentable` enum('true','false') NOT NULL default 'true',
   `global_rank` varchar(255) default NULL,
+  `latitude` varchar(32) NOT NULL default '',
+  `longitude` varchar(32) NOT NULL default '',
   PRIMARY KEY  (`id`),
   KEY `categories_i2` (`id_uppercat`)
) TYPE=MyISAM;
@@ -168,6 +170,8 @@
   `has_high` enum('true') default NULL,
   `path` varchar(255) NOT NULL default '',
   `storage_category_id` smallint(5) unsigned default NULL,
+  `latitude` varchar(32) NOT NULL default '',
+  `longitude` varchar(32) NOT NULL default '',
   PRIMARY KEY  (`id`),
   KEY `images_i2` (`date_available`),
   KEY `images_i3` (`average_rate`),
@@ -368,3 +372,10 @@
   PRIMARY KEY  (`id`)
) TYPE=MyISAM;


+
+DROP TABLE IF EXISTS `phpwebgallery_googlecache`;
+CREATE TABLE `phpwebgallery_googlecache` (
+  `user_id` smallint(5) NOT NULL default '0',
+  `xmlinfos` text,
+  PRIMARY KEY  (`user_id`)
+) TYPE=MyISAM;

ca correspond au requete sql que j'install en me servant du fichier configmaps.sql ?

ce fichier contient :

INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('google_map_key','','Google map activation key');
INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('google_map_activated','false','Activation of google map');
INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('google_map_icon_rep','','Url for representant icon of google map');
INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('google_map_icon_img','','Url for image icon of google map');
INSERT INTO phpwebgallery_config (param,value,comment) VALUES ('google_map_icon_cat','','Url for category icon of google map');

--
-- Table structure for table `phpwebgallery_images`
--

ALTER TABLE `phpwebgallery_images`
ADD COLUMN `latitude` varchar(32) NOT NULL default '',
ADD COLUMN `longitude` varchar(32) NOT NULL default '';

ALTER TABLE `phpwebgallery_categories`
ADD COLUMN `latitude` varchar(32) NOT NULL default '',
ADD COLUMN `longitude` varchar(32) NOT NULL default '';

..

j'ai l'impression que dans ce fichier il n'y a pas tte les modifs necessaire. ce que j'ai mis en gras..

merci pour votre conseils avant que de me lancer dans l'install du mod !

Nicco
2007-04-28 03:32:18

voici ma reponse Vdigital  ;o)

hors sujet  =  http://forum.phpwebgallery.net/viewtopi … 663#p58663

VDigital
2007-04-27 20:31:21

[HS]Et moi, je t'ai mis un petit commentaire sur ta galerie.
C'était bien le jour de le faire.
8-)
[/HS]

Nicco
2007-04-27 20:27:55

salut bonjour a tous moi j ai modif ié la page de modif de plusieurs photos
et c est pas mal je gagne vachement de temps !!!

a+

BoboOfOxford
2007-04-27 10:04:34

pierred a écrit:

De mon coté, je vais tenter (je dis bien tenter) une petite modif pour que lorsque l'on renseigne les coordonnées de géoposition d'une catégorie, toute les photos à l'intérieur de cette catégorie prennent les même coordonnées !

En effet une fonction comme celle-ci serait bien utile. Tiens nous au courant !

pierred
2007-03-12 23:17:59

Deux warning en moins !!!

dans admin\cat_modify.php

remplacer :    

'L_LATITUDE'         => $lang['Latitude'],
'L_LONGITUDE'        => $lang['Longitude'],

par

'L_LATITUDE'         => $lang['latitude'],
'L_LONGITUDE'        => $lang['longitude'],

Le texte s'affichera corectement en plus dans l'administration, modification des infos d'une catégorie.

Je reste sur le fil pour solver le reste...
@+

pierred
2007-03-10 00:55:52

Encore quelques petits trucs d'encore moi !!!!,

1) Quand on veut rentrer la direction d'un répertoire pour spécifier des icones spéciales, lors de la validation, un \ est ajouté à coté de celui qui existe déjà
example : si mon dossier est "tools\iconsGMap" après validation on a "tools\\iconsGMap" !!!!

2 )Sinon comment marche exactement ces dossiers ?
Quels noms doivent avoir les icones ?
Peut-on spécifier une icone par galleries ?
Peut être qu'il y a un site qui explique tout ça !!!

3) Je pensais à un truc : quand on navigue sur la carte, les icones de déplacement gauche, droit, haut et bas ne servent à rien puisque l'on peut se déplacer avec la souris. On se sert juste de la barre de zoom !!! du moins c'est comme ça que j'utilise le soft !!! ;-)
Ne pourrait-on pas avoir juste un bouton "zoom in" et un bouton "zoom out" à l'extérieur de la zone de carte ce qui amméliorerait d'autant plus la visibilité.

4) Lorsqu'une image est géolocalisée, l'utilisateur est dans la gallerie, il clic sur le globe et il est redirigé vers la page google map. L'image ne pourrait-elle pas être centrée sur la position ? On ne pourrait pas non plus choisir la position du zoom ? Pourquoi ne pas avoir une deuxième toute petite carte googlemap sur le coté avec juste la vue des continents affichée dedans et que les deux cartes soient synchronisées entre elles ?

5) Si c'était possible aussi de ragrandir aussi un tout petit peu le cadre dans laquelle se trouve la carte car le bas de ce cadre se trouve confondu avec le bas de la carte. Un petit espace serait plus joli !!!! (c'est du détail)

6) non non j'arrête là !!!! il va me tuer Hugo !!! lol ou alors, il va dire "quel casse c......." !!!! lol
Avec tout le travail qu'on lui donne en plus !!!! m'enfin c'est déjà énorme le résultat !!! encore merci !!!

@+

pierred
2007-03-03 20:12:23

Salut Hugo, encore moi !!!!
Là, je reviens juste de vacances où j'ai fais le plein de belles photos, je les mets dans ma gallerie et le 1er commentaire que je reçois est : "mais c'est ou exactement ce lieu ???".
Il faut donc vraiment que je l'active ce mod Google Map !!!!

C'est alors que je voulais rentrer les coordonnées de géolocalisation de mes catégories que j'ai remarqué un petit problème. Partout où j'avais un message d'avertissement sur mon installation en local, je me retrouve sans affichage de "latitude" ni de "longitude" dans la partie "éditer les informations" des catégories elles même, ni même pour les catégories virtuelles.

Dans la page upload.php, j'ai toujours un warning :

Invalid argument supplied for foreach() in ....../gallerie/include/functions_html.inc.php on line 263

note : j'ai supprimer le début de l'adresse !

merci et @+

pierred
2007-02-15 02:21:19

Bon bah bonne nouvelle, une fois le MOD en ligne sur mon site je n'ai plus de message de warning ou quoi d'autres choses pas très jolie que ce soit. Tout marche super bien !!!! Encore merci Hugo pour ce MOD et le temps passé pour nous aider !!!!!

De mon coté, je vais tenter (je dis bien tenter) une petite modif pour que lorsque l'on renseigne les coordonnées de géoposition d'une catégorie, toute les photos à l'intérieur de cette catégorie prennent les même coordonnées !

Enjoy pour la suite ;oD

Nicco
2007-02-14 23:02:11

moi j ai installé le MOD sur une install neuve et tout marche bien !!!

et sinon Hugo j'ai poste un autre sujet pour toi  ;o)

hugo
2007-02-14 19:57:36

hum.. si ca correspond a des fichiers que je ne modifie pas, des lignes que je n'utilise pas, j'avoue avoir du mal a comprendre.

Zippes moi ton installation et envoies la moi par mail (sans les photos), comme ca je vois chez moi.

pierred
2007-02-14 00:26:54

Salut Hugo,

Je teste d'abord le MOD en local avant de le transférer sur mon site
pour ce qui est de mon fichier php.ini j'ai :      error_reporting  =  E_ALL & ~E_NOTICE

Sinon tout marche super bien avant de mettre le MOD, pas de message "notice" ni "warning" à signaler.

Ces messages n'apparaissent que quand je tente de synchroniser les données Google maps ou alors dans la page upload.php sinon rien !!!

Je vais tester en ligne voir ce que ça donne (j'ai deux sites dont un de test fait pour ça !!!)... je te tiens au courant.
Si tu veux je peux te faire une liste de tous les messages que j'obtiens.

merci

hugo
2007-02-13 08:20:31

- Tu utilises un php installé en local ou sur un hébergeur ? Et si tu peux regarder ton php.ini, dis moi ce qui est écrit sur cette ligne :
error_reporting  =  E_ALL & ~E_NOTICE & ~E_STRICT

- peux tu vérifier avant de mettre le MOD que tu as les mêmes erreurs, a mon avis oui. D'ailleurs ce ne sont pas des erreurs mais des avertissements, en principe tout marche (mais c'est pas beau)

mon avis c'est que ce n'est pas lié au MOD, tu as du activé un plus grand niveau de rapport des erreurs et il existe bcp de warnings dans PWG. Si tu confirmes que ce n'est pas lié au MOD, tu devrais le reporter plutot aux dev de PWG.

pierred
2007-02-13 06:25:31

Encore moi !!!
Bon, bah j'ai essayé d'installé 2 fois le nouveau Mod sur PWG 1.6.1 puis PWG 1.6.2 et toujours les mêmes bug du genre :

Undefined index: cat in C:\.....\phpwebgallery-1.6.2\upload.php on line 115
Warning: Invalid argument supplied for foreach() in C:\.......\phpwebgallery-1.6.2\include\functions_html.inc.php on line 264
Notice: Undefined index: cat_name in C:\......\phpwebgallery-1.6.2\upload.php on line 287

et lors de la sychronisation des données Google maps

Notice: Undefined index: is_the_guest in C:\......\phpwebgallery-1.6.2\include\page_tail.php on line 38

et d'autre toujours du même genre "Undefined index : ...."

Ce qui est bizard c'est que les problèmes surviennent sur des fichiers qui ne sont pas modifié pour le MOD !!!!

Est-ce encore moi qui m'y prend comme un manche ???
Merci

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact