Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

deheme
2021-09-27 10:50:27

Bonjour,
Ce cas de figure (partage d'un père qui ne contient pas de photo) a l'air de fonctionner avec la version 12.1.

Par contre, mais je n’arrive pas à l'exprimer correctement, les cas "tordus" n'ont pas l'air d'être pris en compte, par exemple lorsque l'un des fils est public et un autre privé, il semble qu'on ne puisse pas partager le père (feature ou bug?).

Peux tu nous dire à quoi s'attendre dans divers cas comme par ex :
- Partage d'un père avec des fils qui ont déjà été partagés avant le partage du père
- Partage d'un fils alors que le père est partagé
- Ajout d'un fils privé sous un père partagé
-...

DéHème

petitssuisses
2021-09-26 17:11:08

Bonjour

deheme a écrit:

"- Par contre, suite à l’essai que j’ai fait sur une galerie de test je te confirme que lorsque que le père ne contient pas de photo mais des albums privés qui eux ont des photos, la commande partage est inopérante.

Effectivement, c'est le cas quand on utilise la fonction partager directement depuis la page de l'album. Je vais corriger. Par contre, ça fonctionne depuis la page d'administration, peux tu confirmer ?

deheme
2021-06-17 19:55:37

bonsoir,

J’ai fait l’essai sur un album de test (sans autre plugin) avec 2 albums sous un album père, avec quelques photos dans chaque et je confirme le mauvais fonctionnement qu’il est facile de reproduire.

- Par contre, suite à l’essai que j’ai fait sur une galerie de test je te confirme que lorsque que le père ne contient pas de photo mais des albums privés qui eux ont des photos, la commande partage est inopérante.
- Le nom de l’album apparait sur le thème modus, mais pas sur Bootstrap Darkroom.

Je peux éventuellement donner un accès admin temporaire, mais le phénomène se produit sur mes autres galeries aussi.

Bien cordialement

k5
2021-06-17 19:51:09

Bonjour Lviatour,
Combien d'images voulez-vous afficher pour l'invité ?
A très vite

k5
2021-06-17 18:48:33

Bonjour deheme,
est ce que vous pourriez m'écrire combien il y a d'album et sous album avec ses photos svp merci ?
A très vite

k5
2021-06-14 18:02:48

Bonjour,
je viens de notifier l'auteur du plugin.
A très vite

deheme
2021-06-13 18:11:20

Bonsoir,

Pas de nouvelle des problèmes de la 11.8 évoqués dans le post ci-dessus?

DéHème.

deheme
2021-05-22 20:27:28

Bonsoir,

Pas de nouvelle des problèmes de la 11.8 évoqués dans le post ci-dessus?

DéHème.

deheme
2021-05-17 08:39:04

Bonjour,

Avec la 11.8, le comportement me semble identique sur ma galerie de test.

- Des notifications au premier lancement du lien codé :

Code:

Notice: Undefined index: count_images in /home/deheme/public_html/P4/include/functions_category.inc.php on line 546
Notice: Undefined index: count_categories in /home/deheme/public_html/P4/include/functions_category.inc.php on line 547

Pas sûr qu’elles n’existaient pas avant car elles disparaissent après le,premier essai.

- Le nom de l’album n’apparait toujours pas sous Bootstrap Darkroom alors qu’il est correct sous Modus

- La commande ”Partager cer album” est inopérante sur un album qui ne contient que des sous albums. Dés que j’ajoute une photo elle devient active et le lien public est correct.


Cordialement
DéHème

k5
2021-05-16 23:42:43

Bonjour,
Maintenant Essayez la 11.8
À très vite

deheme
2021-05-16 20:48:50

Merci de ta réponse Arnaud,
J’ai chargé la 11.7

Effectivement j’ai remis les autorisations à la main sur ces albums dont je ne voulais pas casser les clés.

Par contre, suite à l’essai que j’ai fait sur une galerie de test je te confirme que lorsque que le père ne contient pas de photo mais des albums privés qui eux ont des photos, la commande partage est inopérante.

Le nom de l’album apparait sur le thème modus, mais pas sur Bootstrap Darkroom.

Bien cordialement
Daniel

Par ailleurs, mais ça n’est pas directement lié aux problemes rencontrés je n’ai pas bien compris comment tu gérais les cas complexes comme :
- l’ajout de sous albums dans un album dejà partagé et plus généralement les changements d’arbo.
- le partage de deux sous albums separement et le père aussi (n’es tu pas en train de refaire une gestion des droits utilisateurs?)
Nous avions eu la discussion il y a quelques temps, tu m’avais convaincu et je m’étais résolu à utiliser la gestion de base des utilisateurs qui est plutôt bien faite, pour les cas "complexes" privés en gardant sharealbum pour les partages "publics".
Mon seul soucis étant de récupérer les clés d’auto login et de modifier leur période de validité. Je fais tout cela directement dans la bdd, avec les risques que cela comporte mais c’est trés souple. J’avais espéré une simple gestion des liens du type de la tienne mais avec les users piwigo...qui n’est jamais venue alors que la structure existe!

petitssuisses
2021-05-16 19:19:14

Bonjour,

merci pour vos retours
@deheme, le nom des albums devrait à nouveau s'afficher avec la dernière version 11.7
concernant les albums en arborescence, si certains de ne s'affichent pas, c'est probablement parce qqu'ils ne sont pas en mode privé ? Par ailleurs, le lien que vous avez donné fonctionne très bien. (on voit 2 sous-albums Rester chez vous (1 et 2)

@lviatour, il y a une nouvelle colonne dans la table "piwigo_sharealbum", si votre table s'appelle bien ainsi. Cette table devrait être créée automatiquement lorsque le plugin est mis à jour.
Essayez avec la version 11.7 et dites moi si OK ou KO

Bonne soirée

deheme
2021-05-14 15:38:25

Bonjour,

A priori je n’ai pas d’erreurs comme celles de Luc.

Effectivement quand je remets les droits "à la main" le comportement est bon (j’ai mis le groupe share_album pour retrouver mes accès).
Je ne souhaite pas repartager les albums déjà partagés pour ne pas perdre les liens existants. Par ailleurs, en l’absence de la fonction j’ai donné d’autres autorisations aux utilisateurs des partages, ce qui a peut être pertubé la logique.

Une piste cependant sur une galerie de test, j’ai l’impression que le refus de générer le lien (partager cet album accessible mais inopérant) se produit dans les cas ou l’album père ne contient que des sous albums (sans photo au premier niveau)?

DéHème

k5
2021-05-14 11:42:43

Bonjour Lviatour,
je notifie l'auteur du plugin.
A très vite

k5
2021-05-14 11:13:25

Bonjour Deheme,
Essayez menu "albums" -> gérer puis sélectionner votre album puis "éditer" puis onglet "permissions" --> type d'accès privé et remplir les groupes d'utilisateurs.
Revenir sur share album --> onglet "shared albums" --> clic sur votre album puis "Partager cet album"
A très vite

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2021 · Contact