Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

k5
2021-03-05 23:35:02

Bonjour
aaaah ouf !!!!!!
Cordialement
k5

je mets en résolu

Katryne
2021-03-05 23:30:30

Ça y est, c'est passé ! Mais je sais pas pourquoi ni comment.
Merci de ta patience, K5.

k5
2021-03-05 23:10:53
Katryne
2021-03-05 22:27:17

Je viens d'installer un Piwigo 11.3 en php4 sur mon Ionos et c'est bon avec la même version de php :

    Piwigo 11.3.0 Dernière version ?
    Système d'exploitation: Linux
    PHP: 7.4.15
    MySQL: 5.7.32-log
    Bibliothèque graphique: External ImageMagick 6.9.10-23

C'est OVH le problème ?

Katryne
2021-03-05 21:47:00

Voilà la config du Piwigo sur mon autre compte Legtux

    Piwigo 2.10.2
    Système d'exploitation: Linux
    PHP: 7.4.15
    MySQL: 5.5.5-10.3.27-MariaDB-0+deb10u1
    Bibliothèque graphique: ImageMagick 6.9.10-23

Katryne
2021-03-05 21:41:17

J'ai essayé avec un Piwigo 2.10.2, c'est pareil. Mes Piwigos qui tournent bien chez Legtux ont été installés avant php 7.4 et ont eu droit aux mises à jour successives du php sans problème. C'est l'install qui est impossible en php 7.4.

k5
2021-03-05 21:13:17

Bonjour,
essaye d'installer wordpress ou phpbb ...?
Cordialement
k5

Katryne
2021-03-05 20:52:04

K5, je comprends pas ce que tu me demandes de faire. C'est php 7.4 sur ce site, comme sur tout le serveur.

k5
2021-03-05 20:47:11

Bonjour
as-tu fais une phpinfo.php sur ton site pour tester si php 7 soit activé ?
Cordialement
k5

Katryne
2021-03-05 20:47:10

A tout hasard, j'ai posé un fichier local/config/database.inc.php avec juste : $conf['dblayer'] = 'mysqli'; dedans.
Mais je ne peux toujours pas installer : même messages d'erreur que signalés dans le premier post.

J'ai posté un message sur le forum Legtux.

Ce serait juste l'install qui poserait problème, puisque mes Piwigo tournent bien chez Legtux, mais en 2.10.2

Katryne
2021-03-05 20:17:17

Heu ... Je n'ai pas de dossier Piwigo : mon Piwigo est à la racine de mon hébergement. Tous mes dossiers sont en 755 et tous les fichiers en 644, comme d'habitude.

k5
2021-03-05 20:01:21

Bonjour,
quoique c'est peut-être un droit d'accés sur le dossier piwigo en 777
Cordialement
k5

Katryne
2021-03-05 19:52:31

Merci K5, j'avais lu ce message, mais je ne sais pas comment faire. Comme l'installation n'a pas commencé, je n'ai pas encore de fichier local/config/database.inc.php. Je dois l'inventer ?

k5
2021-03-05 19:46:57
Katryne
2021-03-05 18:08:05

Bonsoir, j'ai un hébergement chez Legtux, j'essaye d'y installer un Piwigo tout neuf, version 11.3. Mais ça veut pas ! J'ai des messages que je n'ai jamais encore rencontrés, pourtant, j'ai d'autres Piwigos sur d'autres comptes Legtux, mais en 2.10.2.

Warning: mysqli::__construct(): (HY000/2002): Connection refused in /var/www/legtux.org/users/XXX/www/include/dblayer/functions_mysqli.inc.php on line 52
    Warning: mysqli::set_charset(): Couldn't fetch mysqli in /var/www/legtux.org/users/XXX/www/include/dblayer/functions_mysqli.inc.php on line 88

Que se passe-t-il ? est-ce une question de mysql /mysqli ?

Voici la configuration du serveur de Legtux, loué chez OVH. (voir là : https://www.legtux.org/?page=serveur)

Le logiciel
OS : Debian Jessie (8.1)
Apache 2.4
PHP 7.2 (PHPInfo)
MySQL 5.7
Postfix

Le matériel
Serveur loué chez OVH
Processeur : Intel® Xeon E3 1225v2
Mémoire vive : 32 Go DDR3
Stockage : 2 To (en RAID-1)
Connexion réseau : 100 Mb/s


Merci d'avance de toute suggestion.

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact