Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Talence33
2020-12-04 08:41:50

ddtddt a écrit:

Bonjour,

tu ne réponds pas à ma question, qu'as tu mis à la place de localhost

il faut un truc du genre  'mysql51-106.perso'

Bonjour,
Merci ta réponse m'a orienté vers la solution: il fallait saisir pour l'hôte "bphesanssql.mysql.db" (adresse du serveur bdd OVH) et non pas "localhost".
Pour information à d'autres utilisateurs, cette adresse se trouve sur l'écran de synthèse de la bdd chez OVH.
Bonne journée.

ddtddt
2020-12-02 15:39:36

Bonjour,

tu ne réponds pas à ma question, qu'as tu mis à la place de localhost

il faut un truc du genre  'mysql51-106.perso'

Talence33
2020-12-02 12:12:40

ddtddt a écrit:

Bonjour,

Tu sélectionne bien MySqli ?

tu mets quoi dans l'adresse de la base de données ?

Bonjour,
Lors de la premier lancement de piwigo, sur http://bphesans.fr/pwg, j'ai l'affichage de connexion à la bdd
-----------------------------------------------------------------------------------
Hôte   
localhost
Utilisateur   
bphesanssql
Mot de passe   
mot de passe que je saisie (fonctionne avec phpmyadmin de chez OVH)
Nom de la base de données   
bphesanssql
Préfixe des noms de tables   
piwigo_
----------------------------------------------------------------------------------
Les données que je rentre sont celles qui me permettent d'accéder à la même bdd via le php myadmin  chez OVH.

En local sur mon poste, la connexion via un script PHP se fait bien:
echo "<html>
       <head><title>Test de MySQL5 avec PHP5</title></head>
       <body>";
$conn=mysqli_connect("", "talence33", "anahbp33","ASUSsql")
        or die("Impossible de se connecter : " . mysql_error());
        $mess='Connexion réussie:'."<br />";
        echo $mess;
J'ai bien "Connexion réussie", le même script sur mon site chez OVH (avec les bons login,pass et nom de la base) ne connecte pas.
Cordialement.

ddtddt
2020-11-30 19:21:43

Bonjour,

Tu sélectionne bien MySqli ?

tu mets quoi dans l'adresse de la base de données ?

Talence33
2020-11-30 18:45:30

Bonsoir,
J'ai installé Piwigo (la dernière version) en local (sur 2 PC). Deux PC sous Ubuntu, PHP 7, aucun problème tout fonctionne (accès à la bdd ok).
J'essaie d'installer Piwigo sur un domaine que j'ai chez OVH. Pour cela je copie toute la configuration nécessaire sur monsite (l'archive piwigo-2.10.2.zip que j'ai décompressée en local). Le problème lors du premier lancement de Piwigo est que l'accès à ma bdd OVH est systématiquement refusé. Le nom de la base, le login, le password sont ceux que j'utilise pour accèder à la bdd via phpmyadmin sur le site OVH.
Sûrement un problème de config. Chez OVH ils me répondent que ce n'est pas leur périmètre d'intervention.
Avez-vous une idée pour résoudre ce problème?
Merci d'avance.

(Ici votre message)

Version de Piwigo: 2.10
Version de PHP: 5.4.45

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact