Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

tramway61
2021-04-01 13:41:35

Bonjour,
Je remonte ce post car j'ai toujours le problème. Même après passage en 7.2 ou en 7.4. Sur cette dernière version, j'ai d'ailleurs ces notices:

Notice: Trying to access array offset on value of type bool in /home/argentan/public_html/lesphotosdethierry.fr/plugins/memories/blockhome/main.inc.php on line 34

Notice: Trying to access array offset on value of type bool in /home/argentan/public_html/lesphotosdethierry.fr/plugins/memories/blockhome/main.inc.php on line 35

Notice: Trying to access array offset on value of type bool in /home/argentan/public_html/lesphotosdethierry.fr/plugins/memories/blockhome/main.inc.php on line 36

Je suis donc revenu en 7.3 et cherche un solution. J'ai toujours quelques irréductibles qui n'ont que des smartphones :)

Je suis en V. 11.4.

J'ai envoyé Piwigo par FTP après avoir effacé les fichiers sauf galleries, upload, plugins, thèmes, template-extension, local et _data.

Pas de plugin personnel, et seulement des infos sur les métadonnées (comme sur mon autre site qui fonctionne bien) dans LocalFiles

J'aimerais éviter de refaire une nouvelle installation. Ou alors me donner la démarche à suivre pour éviter de renvoyer toutes mes photos et perdre certaines infos ;)

Piwigo 11.4.0 Dernière version ?
Système d'exploitation: Linux
PHP: 7.3.23 (Montrer les informations) [2021-04-01 13:39:43]
MySQL: 10.3.27-MariaDB [2021-04-01 13:39:43]
Bibliothèque graphique: ImageMagick 7.0.10-10

Par avance merci

@+
Thierry

grom.cris
2020-11-22 21:40:04

Salut, par curiosité , j'ai tenté ton site sur l'application iOS iPhone .
Ca fonctionne parfaitement .
Tu pourrais les aiguiller sur l'appli

Par contre, sur le navigateur, safari ou firefox, je confirme que ca ne marche pas
@+



tramway61 a écrit:

Bonjour,

Après avoir suivi vos conseils, rien de bien nouveau.

Toujours le même message d'erreur.

J'ai de nouveau envoyer les fichiers piwigo 2.10.2 sans amélioration.

Passé en PHP 7.4, j'ai des erreurs supplémentaires

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/argentan/public_html/lesphotosdethierry.fr/plugins/bbcode_bar/include/functions.inc.php on line 14

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/argentan/public_html/lesphotosdethierry.fr/plugins/bbcode_bar/include/functions.inc.php on line 25

Notice: Trying to access array offset on value of type bool in /home/argentan/public_html/lesphotosdethierry.fr/plugins/memories/blockhome/main.inc.php on line 34

Notice: Trying to access array offset on value of type bool in /home/argentan/public_html/lesphotosdethierry.fr/plugins/memories/blockhome/main.inc.php on line 35

Notice: Trying to access array offset on value of type bool in /home/argentan/public_html/lesphotosdethierry.fr/plugins/memories/blockhome/main.inc.php on line 36

Je suis repassé en php 7.3, et j'attends la prochaine mise à jour.

Et si ça pose problème pour certains de mes lecteurs, je vais essayer de les convaincre de passer par une tablette ou un PC :)

Merci encore de votre aide

@+
Thierry

ddtddt
2020-11-13 18:49:39

Bonjour

en php 7.2 ?

tramway61
2020-11-13 14:28:42

Bonjour,

Après avoir suivi vos conseils, rien de bien nouveau.

Toujours le même message d'erreur.

J'ai de nouveau envoyer les fichiers piwigo 2.10.2 sans amélioration.

Passé en PHP 7.4, j'ai des erreurs supplémentaires

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/argentan/public_html/lesphotosdethierry.fr/plugins/bbcode_bar/include/functions.inc.php on line 14

Deprecated: Array and string offset access syntax with curly braces is deprecated in /home/argentan/public_html/lesphotosdethierry.fr/plugins/bbcode_bar/include/functions.inc.php on line 25

Notice: Trying to access array offset on value of type bool in /home/argentan/public_html/lesphotosdethierry.fr/plugins/memories/blockhome/main.inc.php on line 34

Notice: Trying to access array offset on value of type bool in /home/argentan/public_html/lesphotosdethierry.fr/plugins/memories/blockhome/main.inc.php on line 35

Notice: Trying to access array offset on value of type bool in /home/argentan/public_html/lesphotosdethierry.fr/plugins/memories/blockhome/main.inc.php on line 36

Je suis repassé en php 7.3, et j'attends la prochaine mise à jour.

Et si ça pose problème pour certains de mes lecteurs, je vais essayer de les convaincre de passer par une tablette ou un PC :)

Merci encore de votre aide

@+
Thierry

ddtddt
2020-11-10 13:53:41

Bonjour

je dirais en premier de supprimer smartpocket et de le réinstaller

tramway61
2020-11-10 11:36:33

Bonjour,

J'ai bien menubar.tpl dans smartpocket.

Sur mon autre site, je n'utilise pas Smartpocket et le site s'affiche sans problème sur smartphone. J'utilise Modus sur les deux.

Ce problème ne me gênerait pas plus que ça mais j'ai 2 ou 3 visiteurs qui ne surfent que sur smartphone. C'est un site familial

Je pense à une réinstallation. Je ne perdrais que les stats.

@+

Thierry

ddtddt
2020-11-10 05:31:29

Bonjour

les droits sur le fichier le message d'erreur c'est Unable to load template file 'menubar.tpl'

est ce que le fichier menubar.tpl est bien présent dans smartpocket\template ?

k5
2020-11-09 22:02:53

Bonjour,
essayer le plugin "check files integrity", et/ou essaye de changer de php en 7.4
Cordialement
k5

tramway61
2020-11-09 21:20:43

Re,

Pas d'avancée avec Smart Pocket. Il ne veut pas s'activer (Modus, Bootstrap et Elegant installés)

Ce qui m'étonne, c'est que j'ai un autre site à la config quasi identique sur lequel je ne rencontre pas ce problème (https://argentanwebferro.fr/AWF)

Je suis dans l'impasse.

@+

Thierry

JPD
2020-11-09 16:42:35

Bonjour,

Idem sous iOS; il vous faut ajouter le thème Smar Pocket pour que cela fonctionne.

k5
2020-11-09 15:16:33

Bonjour,
Avec tablette android 7 ca fonctionne mais avec telephone android 6 ça met 3 erreurs.
Cordialement
k5

tramway61
2020-11-09 14:54:34

Bonjour,

J'ai un site sous Piwigo depuis plus de 8 ans. Pas de problème de visualisation sur PC et sur tablette 10". Par contre, on me signale un message d'erreur sur smartphone (Android, pour IOS, je ne sais pas).

Warning: include{/themeconf.inc.php}: failed to open stream: No such file or directory in /home/********/public_html/lesphotosdethierry.fr/include/template.class.php on line 1141

Warning: include(): Failed opening '/themeconf.inc.php' for inclusion (include_path='.:/opt/alt/php73/usr/share/pear') in /home/********/public_html/lesphotosdethierry.fr/include/template.class.php on line 1141

Fatal error: Uncaught-->Smarty: Unable to load template file 'menubar.tpl' <-- thrown in /home/********/public_html/lesphotosdethierry.fr/include/smarty/libs/sysplugins/smarty_internal_template.php on line 139

J'ai renvoyé les fichiers par FTP, comparé les fichiers avec un autre site qui fonctionne, mais je ne trouve rien qui me permette de régler le problème.

Si quelqu'un avait une solution, je lui en serait gré

Version de Piwigo: 2.10.2
Version de PHP: 7.3.23
Version de MySQL: 10.3.26-MariaDB [2020-11-09 14:26:10]
URL Piwigo: http://www.lesphotosdethierry.fr

Thème: Modus
Hébergement: O2switch

Merci
@+

Thierry

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact