Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

plg
2018-05-21 17:25:20

Bonjour Justine5,

Justine5 a écrit:

Est-ce que il y a une bonne ;-) raison? qui m'échappe

Non, comme toutes les modules de code "tout fait" qu'on utilise dans Piwigo, il faut régulièrement les mettre à jour, tout en vérifiant que la mise à jour ne casse rien (ou n'entraîne pas un prérequis trop contraignant, comme demander PHP 7 alors que Piwigo 2.9 ne demande que PHP 5.2).

Justine5 a écrit:

J'ai simplement remplacé les 3 fichiers utilisés ;-) sans savoir si on devait adapter un minimum le code? test en-cours

Pour savoir si le PHPMailer que Piwigo utilise est le standard, il suffit de le comparer à sa version officielle. Si on l'utilise "tel quel", il n'y a pas de modification spécifique à reporter.

Je te propose de continuer à tester ton Piwigo avec la mise à jour de PHPMailer et si tu t'en sens capable, proposer une Pull-Request qui nous permettra de l'intégrer en quelques clics.

flop25
2018-05-21 17:06:25

Bonjour et merci
c'ets intéressant !

Justine5
2018-05-19 23:26:38

Bonsoir, apparement la version de PHPMailer est une vieille 5.2.21 alors qu'existe une 5.2.26
Et même une 6.x maintenant

Est-ce que il y a une bonne ;-) raison? qui m'échappe
apparemment il y a plusieurs failles de sécurité! publiées depuis
https://github.com/PHPMailer/PHPMailer#security

J'ai simplement remplacé les 3 fichiers utilisés ;-) sans savoir si on devait adapter un minimum le code? test en-cours

Version de Piwigo: 2.9.3
Version de PHP: 5.6.35
Version de MySQL: 5.6.39
URL Piwigo: En local

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact