Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

BrandonCougar
2018-01-31 22:17:04

Bonsoir,

merci pour ton aide mais ça ne me convient pas car j'ai quand même plus de visiteurs non inscrits et du coup pour eux ça ne fonctionne plus.

JPD
2018-01-21 13:57:59

D'accord pour la première partie de ta réponse.
Mais par contre cela fonctionne bien avec les utilisateurs inscrits (2ème partie de ta réponse) s'ils n'ont pas été explicitement autorisés à accéder ces albums. Voir aide Piwigo ci-dessous :
"Publique / Privé
Les permissions n'existent que pour les albums privés. Une fois qu'un album est privé, il vous faut explicitement autoriser les utilisateurs ou les groupes à y accéder."

Bon après-midi.

BrandonCougar
2018-01-21 11:39:17

Bonjour JPD,

merci pour ton aide... c'est ce à quoi j'ai pensé au premier abord mais ça ne fonctionne pas car ces albums ont vocation à être utilisés pour la page d'accueil et l'affichage des photos récentes pour tous les visiteurs (donc les non inscrits qui n'ont pas accès aux albums privés).

D'autre part cela ne règle pas le problème pour les utilisateurs inscrits qui voient donc ces albums dans le menu en mode mobile alors que j'aimerais mieux que non.

JPD
2018-01-21 11:30:04

Bonjour,
Pourquoi simplement ne pas les mettre en albums privés (Albums > Propriétés) ??
Bonne journée.

BrandonCougar
2018-01-21 09:51:40

Bonjour,

pas sûr que mes explications soient claires... mon besoin : masquer certains albums dans le menu.
En mode classique --> ça marche très bien avec ExtendedDescription et les balises qui vont bien
En mode mobile (avec SmartPocket) --> les ballises d'ExtendedDescription ne sont pas prises en compte

Si quelqu'un a une astuce je suis preneur. Merci

BrandonCougar
2018-01-14 09:24:15

Bonjour,

apparemment certaines options proposées par le plugin ExtendedDescription ne sont pas prises en compte par le plugin SmartPocket et notamment le masquage d'un album dans le menu et la galerie.

En gros j'ai un album Accueil qui contient les photos qui s'affichent à l'ouverture ainsi qu'un album contenant les photos récentes pour les afficher en vignette dans le menu à gauche mais ces albums sont normalement masqués or ça fonctionne très bien sauf avec le thème SmartPocket qui ne semble pas prendre en compte les balises du plugin.

J'utilise les balises de masquage sur l'album Accueil :
http://fr.piwigo.org/forum/showimage.php?pid=223253&filename=Piwigo-ExtendedDescription.png

L'album Accueil est bien masqué avec un thème classique (ordinateur) :
http://fr.piwigo.org/forum/showimage.php?pid=223253&filename=Piwigo-Menu.png

Par contre l'album Accueil (et pareil pour Photos récentes) apparait sur la version SmartPocket :
http://fr.piwigo.org/forum/showimage.php?pid=223253&filename=Screenshot_2018-01-14-09-18-08.png


URL Piwigo: https://stefczu.fr/

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact