Annonce

Écrire une réponse

Veuillez écrire votre message et l'envoyer

Cliquez dans la zone sombre de l'image pour envoyer votre message.

Retour

Résumé de la discussion (messages les plus récents en premier)

Thom1
2017-12-20 07:09:57

Salut,

Avec ce serveur, est-ce que tu peux envoyer en tls toujours sans préciser le port ?
Je t'avais dit une bêtise en essayant le port 587 avec tls, car tls utilise le port 25.

Bonne journée.

RvHerve
2017-12-19 23:32:47

Bonsoir,

J'ai abandonné l'idée d'utiliser le port sécurisé 465 en SSL pour le SMTP.
J'ai trouvé la solution avec une compte mail fourni par mon hébergeur NUXIT utilisant le port 25 par défaut.
J'ai donc ajouté dans LocalFiles Editor le code suivant :

$conf['smtp_host'] = 'smtp.exemple.org';
$conf['smtp_user'] = 'mon_username';
$conf['smtp_password'] = 'my-password';
// 'ssl' or 'tls'
$conf['smtp_secure'] = null; 

Cela fonctionne maintenant correctement et les mails à destination d'un email free.fr ne sont plus considérés comme SPAM.
Merci encore pour votre aide même si je suis toujours preneur d'une solution pour utiliser le port 465 en SSL pour l'envoi de mail par SMTP.

Bonne soirée.
Hervé

Thom1
2017-12-19 16:39:40

Bonjour,

As-tu essayé avec un autre compte mail d'un autre prestataire smtp ?

RvHerve
2017-12-19 16:01:59

Bonjour,

Merci pour cette proposition mais je ne souhaite pas prendre le risque d'installer un plugin non supporté depuis plus de 4 ans. Cette solution aurait été un contournement du problème.

Je souhaite donc me passer de l'envoi par la fonction mail() de php pour utiliser mon propre SMTP comme me l'a suggéré Thom1. La solution est bien de le configurer via le plugin LocalFiles Editor mais pour cela il faut que la fonction "fsockopen" soit autorisée pour le port 465 utilisé pour le SMTP, comme indiqué en commentaire du fichier "config_default.inc.php" (// smtp configuration (work if fsockopen function is allowed for smtp port).

Mais voilà, où configurer cette fonction fsockopen ?
Personne depuis 2009 n'a-t-il eu besoin d'utiliser son propre SMTP pour envoyer des notifications ?

Merci beaucoup pour vos réponses à venir.
Bonne journée.
Hervé

ddtddt
2017-12-19 06:11:37

Bonjour,

extension:315
n'est pas marqué compatible 2.9 mais peux être qu'il fonctionne

RvHerve
2017-12-18 23:15:53

Bonsoir ddtddt,

Oui, j'ai essayé ce plugin mais c'est pire entre guillemets. Le mail que j'aurai dû recevoir dans ma BAL Free ne m'est jamais parvenu car toujours considéré comme SPAM. Pire car je n'ai pas reçu de message d'erreur en retour puisque l'email expéditeur est une fausse adresse en utilisant l'extension.
Merci mais ce n'est pas une solution.
Bonne nuit.

ddtddt
2017-12-18 19:23:54

Bonjour

tu as essayé extension:735

Thom1
2017-12-18 17:58:30

Là tout de suite je n'ai pas d'autres solutions à te proposer… À méditer ! :)

RvHerve
2017-12-18 17:35:41

J'ai essayé avec le port 587 en tls mais j'ai le même Warning.
J'ai l'impression qu'il faut creuser du côté de "// smtp configuration (work if fsockopen function is allowed for smtp port)" mais je ne sais pas où...

Thom1
2017-12-18 17:26:02

Même si je n'y crois pas du tout, tu peux tenter avec le port 587 en tls.

RvHerve
2017-12-18 17:19:01

J'ai essayé sans préciser le port. Dans ce cas j'ai le message "Internal Server Error". Le port semble donc obligatoire.
En remettant le port 465, j'ai essayé par exemple jean.dupont@free.fr ou jean.dupont et j'ai le même Warning.
En essayant "tls", j'ai le même Warning.
En mettant en commentaire l'option " $conf['smtp_secure'] = ssl; ", j'ai le même Warning.
Une autre idée ?
Merci encore.

Thom1
2017-12-18 16:43:13

Bonjour,

As-tu essayer avec juste « $conf['smtp_host'] = 'smtp.free.fr'; » (sans préciser le port) ?

Est-ce que tu indiques bien l'adresse complète du compte dans l'option « $conf['smtp_user'] = 'mon_username'; » (par exemple jean.dupont@free.fr) ?

As-tu essayer l'option « $conf['smtp_secure'] = ssl; » avec "ssl" ou "tls" ou carrément de la commenter pour désactiver le chiffrement de la connexion ?

Bonne soirée.

RvHerve
2017-12-18 16:32:22

Bonjour,

Merci pour ta réponse et désolé pour cette réponse tardive.
J'ai utilisé LocalFiles Editor et j'ai indiqué le code suivant :
$conf['smtp_host'] = 'smtp.free.fr:465';
$conf['smtp_user'] = 'mon_username';
$conf['smtp_password'] = 'my-password';
// 'ssl' or 'tls'
$conf['smtp_secure'] = ssl;

J'ai le message d'erreur suivant :
Warning: Mailer Error: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/ … leshooting in /web/condamin/photos/include/functions_mail.inc.php on line 916

Dans le commentaire du fichier "config_default.inc.php", il est indiqué "// smtp configuration (work if fsockopen function is allowed for smtp port)" donc apparemment je dois configurer autre chose mais je ne sais pas où.

As-tu une piste à me donner ?

Merci beaucoup pour ton aide.

Thom1
2017-12-08 19:19:33

Bonjour,

Bien que ceci soit totalement indépendant de Piwigo, tu as au moins deux possibilités pour, peut-être, corriger ce souci :
- tu fais passer tes mails par un relai SMTP que free ne considère par comme spam,
- tu peux toujours tenter d'envoyer les mails en te connectant à ton serveur smtp plutôt que d'utiliser la fonction mail() de php. Ceci se règle dans LocalFiles Editor (configuration locale) :

Code:

$conf['smtp_host'] = 'smtp.example.org';
$conf['smtp_user'] = 'username@example.org';
$conf['smtp_password'] = 'your-password';
// 'ssl' or 'tls'
$conf['smtp_secure'] = tls;

Sinon tu peux également vérifier que l'adresse IP qui envoie les mails ne soit pas considérée comme spameuse (https://mxtoolbox.com/blacklists.aspx)

J'espère que ces quelques pistes t'aideront.

RvHerve
2017-12-08 16:46:31

Bonjour,

Depuis le mois de juin 2017, tous les mails de notifications aux utilisateurs envoyés vers des destinataires en free.fr sont considérés comme SPAM par Free. Tous les autres destinataires en gmail.com, yahoo.fr, hotmail.com, orange.fr, etc. reçoivent bien les notifications.
J'ai essayé depuis juin 2017 de prévenir Free en suivant leur procédure pour les prévenir et qu'il corrige leur filtre anti-spam mais sans succès.
Avez-vous déjà connu ce problème ? Que puis-je faire ? Je ne peux tout de même pas demander à mes destinataires de changer leur email ?

Mon hébergeur est NUXIT.

Merci pour votre aide.

Hervé

Version de Piwigo: dernière

Pied de page des forums

Propulsé par FluxBB

github twitter newsletter Faire un don Piwigo.org © 2002-2022 · Contact